当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求救,悲剧的ATi驱动
帖子发表于 : 2010-04-18 20:35 

注册: 2010-04-18 20:28
帖子: 72
送出感谢: 0 次
接收感谢: 0 次
忘了问,说的开源支持randeon HD么我的是3450
从9.10升级到10.04成功,
一路更新,不小心把fglrx也更新了,导致现在opengl开不了,xbmc和好多程序没法用
卸载时出现了如下错误



apt-get remove fglrx
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
下列软件包将被【卸载】:
fglrx
升级了 0 个软件包,新安装了 0 个软件包,要卸载 1 个软件包,有 11 个软件包未被升级。
有 1 个软件包没有被完全安装或卸载。
解压缩后将会空出 60.0MB 的空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 158325 个文件和目录。)
正在删除 fglrx ...
dpkg-divert: 删除“diversion of /usr/lib/libGL.so.1.2 to /usr/lib/fglrx/libGL.so.1.2.xlibmesa by fglrx”时
软件包名不匹配
发现了“diversion of /usr/lib/libGL.so.1.2 to /usr/lib/fglrx/libGL.so.1.2.xlibmesa by xorg-driver-fglrx”
dpkg:处理 fglrx (--remove)时出错:
子进程 已安装的 post-removal 脚本 返回了错误号 2
正在处理用于 ureadahead 的触发器...
在处理时有错误发生:
fglrx
E: Sub-process /usr/bin/dpkg returned an error code (1)
搜索论坛上的办法不管用,之后出现相同错误
谢谢各位高手
知道自己是菜鸟还当小白鼠,悔当初不该阿

补充下opengl出错信息
leo@leo-desktop:~$ glxinfo |grep -i opengl
X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 153 (GLX)
Minor opcode of failed request: 19 (X_GLXQueryServerString)
Serial number of failed request: 14
Current serial number in output stream: 14


最后由 leo89819 编辑于 2010-04-19 23:16,总共编辑了 2 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 求救,悲剧的ATi驱动
帖子发表于 : 2010-04-18 20:44 
头像

注册: 2008-11-01 20:43
帖子: 17328
系统: 自动检测比较好
送出感谢: 44
接收感谢: 11
在硬件驱动里禁用!


_________________
谁是我?KL.Uiq8 YinMeng


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 求救,悲剧的ATi驱动
帖子发表于 : 2010-04-18 20:54 

注册: 2010-04-18 20:28
帖子: 72
送出感谢: 0 次
接收感谢: 0 次
速腾1994 写道:
在硬件驱动里禁用!

禁用了的
是说禁用了就相当于使用了开源驱动吗?
如果是那为什么我禁用后还是不能支持opengl呢?难道是我装的有问题?
谢谢 :em23


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 求救,悲剧的ATi驱动
帖子发表于 : 2010-04-18 23:17 

注册: 2005-05-01 12:54
帖子: 920
送出感谢: 0 次
接收感谢: 0 次
禁用fglrx后再更新次系统,会安装一堆的libgl之类的东西,然后就可以用开源驱动开3D了


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 求救,悲剧的ATi驱动
帖子发表于 : 2010-04-19 14:09 

注册: 2010-04-18 20:28
帖子: 72
送出感谢: 0 次
接收感谢: 0 次
Freesnake 写道:
禁用fglrx后再更新次系统,会安装一堆的libgl之类的东西,然后就可以用开源驱动开3D了

我的系统已经是最新的了说,用的cn99的源
重装了遍你说的libgl但没有效果。更悲剧的是昨天还支持xv输出今天不知道为什么不行了


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 求救,悲剧的ATi驱动
帖子发表于 : 2010-05-27 11:29 

注册: 2010-03-26 20:24
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
我的显卡是3470,也是从9.10升级到10.04遇到了跟你一模一样的问题,而且导致不能安装新软件了。
google了好久,终于找到解决的方法,但不明白到底是咋回事。
sudo dpkg-divert --rename --remove /usr/lib/libGL.so.1.2
然后就是更新软件,确保更新显卡驱动。


最后由 蓝火龙 编辑于 2010-05-27 11:55,总共编辑了 1 次

页首
 用户资料  
 
7 楼 
 文章标题 : Re: 求救,悲剧的ATi驱动
帖子发表于 : 2010-05-27 11:33 

注册: 2010-05-26 15:29
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
没有人对我的问题哪怕看一眼,这是Ubuntu的精神,一个圈子不理求助者?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译