当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Nvidia私有驱动plymouth不显示的解决方案
帖子发表于 : 2010-05-06 21:03 

注册: 2008-06-09 15:23
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
安装完nvidia的私有驱动后plymouth就不显示了(我的1440*900)。
解决办法很简单,
sudo gedit /boot/grub/grub.cfg
把vga=792改成vga=868
868是1440*900 16位,24位grub好像就不支持了。
其他分辨率可以参考下表
# FRAMEBUFFER RESOLUTION SETTINGS
# +----------------------------------------------------------------+
# | 640x480 |800x600 |1024x768 |1280x1024|1280x800 |1600x1200
# ----+-------------------------------------------------------------
# 256 | 0x301=769 0x303=771 0x305=773 0x307=775 0x31C=796
# 32K | 0x310=784 0x313=787 0x316=790 0x319=793 0x360=864 0x31D=797
# 64K | 0x311=785 0x314=788 0x317=791 0x31A=794 0x361=865 0x31E=798
# 16M | 0x312=786 0x315=789 0x318=792 0x31B=795 0x362=866 0x31F=799
# +----------------------------------------------------------------+
如果上表没有,那就查到你的分辨率的16进制值转成10进制就好了。
如果重启黑屏不要惊慌,只是没显示而已。多系统只要记得是第几项,心里计算着选择,一样可以进入系统,然后改回来就可以了。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: Nvidia私有驱动plymouth不显示的解决方案
帖子发表于 : 2010-05-07 0:36 
头像

注册: 2010-01-28 10:45
帖子: 19507
送出感谢: 6
接收感谢: 41
:em11 :em11 :em11


_________________

*********宁静致远*********
如果我说的有什么不对,请看签名第一行


页首
 用户资料  
 
3 楼 
 文章标题 : Re: Nvidia私有驱动plymouth不显示的解决方案
帖子发表于 : 2010-05-07 19:10 
头像

注册: 2007-12-08 9:05
帖子: 63
送出感谢: 0 次
接收感谢: 1
找不到vga呀,我的文件里面没有vga这一项


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译