当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 配置lamp出现的错误
帖子发表于 : 2010-05-24 23:20 

注册: 2010-05-16 0:18
帖子: 61
地址: 北京朝阳
系统: win8
送出感谢: 2
接收感谢: 0 次
viewtopic.php?f=48&t=274929详见此贴,
这是本人配置是出现的错误, 汇总一下, 方便以后的朋友。


感谢” lainme“朋友
代码:
wiki原文

代码:
找到“blowfish_secret”在后面填上任意字母

$cfg['Servers'][$i]['auth_type']='cookie';
$cfg['Servers'][$i]['host']='localhost';
$cfg['Servers'][$i]['connect_type']='tcp';
$cfg['Servers'][$i]['compress']='false';
$cfg['Servers'][$i]['extension']='mysql';



修改前
代码:
$cfg['blowfish_secret'] = ''; /* YOU MUST FILL IN THIS FOR COOKIE AUTH! */

/*
* Servers configuration
*/



修改后。
代码:
$cfg['blowfish_secret'] = 'sd'; /* YOU MUST FILL IN THIS FOR COOKIE AUTH! */

$cfg['Servers'][$i]['auth_type']='cookie';
$cfg['Servers'][$i]['host']='localhost';
$cfg['Servers'][$i]['connect_type']='tcp';
$cfg['Servers'][$i]['compress']='false';
$cfg['Servers'][$i]['extension']='mysql';


/*
* First server
*/
$i++;



请问,这样对吗?





原文
代码:
编辑php配置文件
sudo gedit /etc/php5/apache2/php.ini
在extension下面加上

extension=php5-mcrypt.so


可是我搜索,有好多个, 在最下面有
代码:
; If you wish to have an extension loaded automatically, use the following
; syntax:
;
;   extension=php5-mcrypt.so
;



已经有了。。。。。 请问,这个还需要修改吗?



wiki这是误人阿。
找到“blowfish_secret”在后面填上任意字母

$cfg['Servers'][$i]['auth_type']='cookie';
$cfg['Servers'][$i]['host']='localhost';
$cfg['Servers'][$i]['connect_type']='tcp';
$cfg['Servers'][$i]['compress']='false';

这么多字,只有[color=#0040FF] “”找到“blowfish_secret”在后面填上任意字母“”
这一句有用。

其余的语句不要动。。[/color]




代码:
我手贱,不知道修改了什么文件。

打开127.0.0.1/phpmyadmin 能打开页面。

登录就错误。。一开始是登录没反应, 下面的“需要cook***”的消失了。

现在是登录就跳转。
代码:
糟糕!此链接好像已损坏。
建议:
在 Google 上搜索:

$cfg['Servers'][$i]['extension']='mysql';

我解决错误的办法: 一开始phpmyadmin错误,提示“链接表的额外特性尚未激活。要查出原因,请点击此处。‘
然后我就给删除了, 又解压了一下, 一开始文件夹名是”phpmyadmin“解压后变成了”phpMyAdmin“

文件名错误, 依小弟愚见,(这时候可以打开页面)点登录将跳转到某一个页面,可是路径错误,跳不过去,所以就错误。。呵呵。。

代码:
#1045 无法登录 MySQL 服务器



呵呵, 这个, 这个问题更简单, 我的账户密码错了。 或许还有其他的问题, 比如需要指向什么的,mysql服务有没有启动等。LAMP包应该是不需要的,略过,需要的朋友可以g baidu 之。

代码:
无效的索引搜索没找到

phpmyadmin/config 就是这个文件, 我修改了上面的

$cfg['Servers'][$i]['auth_type']='cookie';
$cfg['Servers'][$i]['host']='localhost';
$cfg['Servers'][$i]['connect_type']='tcp';
$cfg['Servers'][$i]['compress']='false';
$cfg['Servers'][$i]['extension']='mysql';

解决方法, 很愚笨, 重新解压phpmyadmin包,替换掉这个文件。。。。。
代码:
短语密码

解决方法: 找到blowfish_secret”在后面填上任意字母 依然是这个文件phpmyadmin/config
代码:
链接表的额外特性尚未激活。要查出原因,请点击此处。



这是最后一个问题。

1.先建立一个名为phpmyadmin的数据库

2.然后把目录下scripts/create_tables.sql导入到这个库

3.打开config.inc.php配置文件.



$cfg['Servers'][$i]['pmadb'] = ''; // 'phpmyadmin' - see scripts/create_tables.sql
$cfg['Servers'][$i]['bookmarktable'] = ''; // 'pma_bookmark'
$cfg['Servers'][$i]['relation'] = ''; // 'pma_relation'
$cfg['Servers'][$i]['table_info'] = ''; // 'pma_table_info'
$cfg['Servers'][$i]['table_coords'] = ''; // 'pma_table_coords'
$cfg['Servers'][$i]['pdf_pages'] = ''; // 'pma_pdf_pages'
$cfg['Servers'][$i]['column_info'] = ''; // 'pma_column_info'
$cfg['Servers'][$i]['history'] = ''; // 'pma_history'

修改为

$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin'; // 'phpmyadmin' - see scripts/create_tables.sql
$cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark'; // 'pma_bookmark'
$cfg['Servers'][$i]['relation'] = 'pma_relation'; // 'pma_relation'
$cfg['Servers'][$i]['table_info'] = 'pma_table_info'; // 'pma_table_info'
$cfg['Servers'][$i]['table_coords'] = 'pma_table_coords'; // 'pma_table_coords'
$cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages'; // 'pma_pdf_pages'
$cfg['Servers'][$i]['column_info'] = 'pma_column_info'; // 'pma_column_info'
$cfg['Servers'][$i]['history'] = 'pma_history'; // 'pma_history'


如果上述不行看是否设置了php.ini 文件的 session.save_path 路径。

我好像把ession.save_path 路径给del了。。哈哈。

还有就是”清空session,重启,刷新浏览器!呵呵“ 这个我没看懂。。。 请大牛指教。。。


_________________
少年听雨歌楼上,红烛昏罗帐。壮年听雨客舟中,江阔云低断雁叫西风。
  而今听雨僧庐下,鬓已星星也。悲欢离合总无情,一任阶前点滴到天明


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 配置lamp出现的错误
帖子发表于 : 2010-05-24 23:41 

注册: 2010-05-16 0:18
帖子: 61
地址: 北京朝阳
系统: win8
送出感谢: 2
接收感谢: 0 次
最后一个请不要测试, 时准时不准的!


_________________
少年听雨歌楼上,红烛昏罗帐。壮年听雨客舟中,江阔云低断雁叫西风。
  而今听雨僧庐下,鬓已星星也。悲欢离合总无情,一任阶前点滴到天明


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 配置lamp出现的错误
帖子发表于 : 2010-05-25 13:24 
头像

注册: 2008-09-13 19:17
帖子: 7789
系统: Arch Linux (x86_64)
送出感谢: 10
接收感谢: 77
其实你只是用做这个用途的话完全不需要折腾,apt-get几个程序就行了,连配置都不用动手,除非特殊需求。

比如phpmyadmin源里就是有的,安装中会让你设置用户名密码,安完就能用。要用mysql,只要apt-get php5-mysql,不用去修改php.ini

网上那些教程大多比较通用,所以常常出现编译、从官网下载手动安装、手动改很多配置之类,Ubuntu大多只需要apt-get,坛子里有ubuntu下用LAMP的教程


_________________
博客:http://www.lainme.com


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译