当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 系统好像坏了!
帖子发表于 : 2010-05-28 23:07 

注册: 2009-02-04 13:55
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
在终端的操作和显示如下:
biositemap@biositemap:~$ sudo apt-get install mysql
E: dpkg 的操作被中断了, 您必须手动执行 'sudo dpkg --configure -a' 以修复这个问题。
biositemap@biositemap:~$ sudo dpkg --configure -a
正在设置 texlive-base (2009-7) ...
Running mktexlsr. This may take some time... done.
Building format(s) --all --cnffile /etc/texmf/fmt.d/10texlive-base.cnf.
This may take some time...
fmtutil-sys failed. Output has been stored in
/tmp/fmtutil.ba73ZQoD
Please include this file if you report a bug.

dpkg:处理 texlive-base (--configure)时出错:
子进程 已安装的 post-installation 脚本 返回了错误号 1
dpkg:依赖关系问题使得 texlive-luatex 的配置工作不能继续:
texlive-luatex 依赖于 texlive-base (>= 2009-1);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-luatex (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-generic-recommended 的配置工作不能继续:
texlive-generic-recommended 依赖于 texlive-base (>= 2009-1);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-generic-recommended (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-pstricks 的配置工作不能继续:
texlive-pstricks 依赖于 texlive-generic-recommended (>= 2009-1);然而:
软件包 texlive-generic-recommended 还没有被配置。
texlive-pstricks 依赖于 texlive-base (>= 2009-1);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-pstricks (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-latex-base 的配置工作不能继续:
texlive-latex-base 依赖于 texlive-base (>= 2009-1);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-latex-base (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 latex-beamer 的配置工作不能继续:
latex-beamer 依赖于 texlive-latex-base;然而:
软件包 texlive-latex-base 还没有被配置。
dpkg:处理 latex-beamer (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-font-utils 的配置工作不能继续:
texlive-font-utils 依赖于 texlive-base (>= 2009-1);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-font-utils (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-extra-utils 的配置工作不能继续:
texlive-extra-utils 依赖于 texlive-base (>= 2009-1);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-extra-utils (--configure)时出错:
依赖关系问题 - 仍未被配置
正在设置 moodle (1.9.4.dfsg-0ubuntu4) ...


然后就停在这里不动了,几个小时也不动!
如果使用新利得也是提示“E: dpkg 的操作被中断了, 您必须手动执行 'sudo dpkg --configure -a' 以修复这个问题。 ”
我是学生物信息的,现在正在学习linux,还不是很懂,希望高手们能告诉我具体应该怎么做!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 系统好像坏了!
帖子发表于 : 2010-05-28 23:11 
头像

注册: 2010-01-28 10:45
帖子: 19507
送出感谢: 6
接收感谢: 41
执行这个
代码:
sudo dpkg --configure -a


_________________

*********宁静致远*********
如果我说的有什么不对,请看签名第一行


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 系统好像坏了!
帖子发表于 : 2010-05-28 23:25 

注册: 2009-02-04 13:55
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
monk 写道:
执行这个
代码:
sudo dpkg --configure -a

我执行过了,您没看到我那些代码里执行过这个命令了吗?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 系统好像坏了!
帖子发表于 : 2010-05-28 23:26 

注册: 2009-02-04 13:55
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
monk 写道:
执行这个
代码:
sudo dpkg --configure -a



执行过之后就会停在“正在设置 moodle (1.9.4.dfsg-0ubuntu4) ...”这里,几个小时也不动!


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 系统好像坏了!
帖子发表于 : 2010-05-28 23:32 
头像

注册: 2010-01-28 10:45
帖子: 19507
送出感谢: 6
接收感谢: 41
代码:
sudo apt-get install -f


_________________

*********宁静致远*********
如果我说的有什么不对,请看签名第一行


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 系统好像坏了!
帖子发表于 : 2010-05-29 17:48 

注册: 2009-02-04 13:55
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
monk 写道:
代码:
sudo apt-get install -f


执行这个最后也是会听留在“正在设置 moodle (1.9.4.dfsg-0ubuntu4) ...”这里几个小时不动!


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 系统好像坏了!
帖子发表于 : 2010-05-29 19:16 
头像

注册: 2008-08-03 22:29
帖子: 326
送出感谢: 0 次
接收感谢: 0 次
又是源里的texlive……唉……

实在不行只能搞 /var/lib/dpkg/status


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译