当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : mount出现怪问题:文件消失
帖子发表于 : 2010-06-21 19:06 

注册: 2008-04-12 12:44
帖子: 980
送出感谢: 1
接收感谢: 2
我的硬盘情况见附件v0.png,/home目录挂载在/dev/sda3
/home/pt/Videos里面有个文件,参见附件v1.png
现在,我想用/dev/sda9来挂载/home/pt/Videos,
输入命令行:
sudo mount -t ext4 /dev/sda9 /home/pt/Videos
挂载成功后,
pt@pt-laptop:~$ ls /home/pt/Videos
FILE0030.MOV

可是奇怪的事情发生了,
1.我从文件系统,进行查看,没有看见任何文件(打开了查看隐藏文件功能),参见附件v2.png
2.我从磁盘查看,也没有看见任何文件,参见附件v3.png

请问,什么原因呢?


附件:
v3.png
v3.png [ 105.45 KiB | 被浏览 321 次 ]

v2.png
v2.png [ 101.07 KiB | 被浏览 321 次 ]

v1.png
v1.png [ 97.42 KiB | 被浏览 321 次 ]

v0.png
v0.png [ 114.69 KiB | 被浏览 321 次 ]

页首
 用户资料  
 
2 楼 
 文章标题 : Re: mount出现怪问题:文件消失
帖子发表于 : 2010-06-21 19:08 

注册: 2008-01-09 22:41
帖子: 18311
送出感谢: 0 次
接收感谢: 6
刚刚理解错误

以前遇到过,是挂载参数错误造成的。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: mount出现怪问题:文件消失
帖子发表于 : 2010-06-22 0:31 

注册: 2008-06-08 15:01
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
sudo mount -t ext4 /dev/sda9 /home/pt/Videos

目录 /home/pt/Videos 下的文件都隐藏掉,代替之看到的是 /dev/sda9 上的文件。 这是linux文件系统的一个特性。

你还可以再次挂载 其他分区到 /home/pt/Videos, 看看。一样的。 linux的挂载点可以重复迭代挂载,迭代隐藏前代的文件。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: mount出现怪问题:文件消失
帖子发表于 : 2010-06-22 0:33 

注册: 2008-06-08 15:01
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
我说的是“隐藏”不是平常意思的.xx文件的隐藏,是文件系统的代码真的无法查找到那些文件了,被消失了


页首
 用户资料  
 
5 楼 
 文章标题 : Re: mount出现怪问题:文件消失
帖子发表于 : 2010-06-22 0:49 
头像

注册: 2008-02-17 23:47
帖子: 22120
地址: 美丽富饶的那啥星球
送出感谢: 11
接收感谢: 84
按照你v0.png的图示,说明你的sda9根本就没挂上嘛,先df瞧瞧啦


_________________
明天就换大三八!
——8核CPU、8G内存、8T硬盘……
8卡交火,80寸大屏放8个……
IPv8的光纤要8条……

---------------------------------------------------------------------------------
[图片版]新手当自强(续)FAQ
[新手进阶]挂载、fstab、调整linux分区
[图片版]E17桌面环境配置手把手


页首
 用户资料  
 
6 楼 
 文章标题 : Re: mount出现怪问题:文件消失
帖子发表于 : 2010-06-22 1:01 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
我也不知道怎么解释了 ...


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: mount出现怪问题:文件消失
帖子发表于 : 2010-06-22 10:13 
头像

注册: 2007-10-24 20:20
帖子: 1565
地址: 北京、海淀
送出感谢: 0 次
接收感谢: 1
sniper 写道:
sudo mount -t ext4 /dev/sda9 /home/pt/Videos

目录 /home/pt/Videos 下的文件都隐藏掉,代替之看到的是 /dev/sda9 上的文件。 这是linux文件系统的一个特性。

你还可以再次挂载 其他分区到 /home/pt/Videos, 看看。一样的。 linux的挂载点可以重复迭代挂载,迭代隐藏前代的文件。

:em11
所以通常挂载点的目录要求为空。


_________________
Dell Vostro 1500, T7300/4GB/WD5000BEVT/nVidia 8400GM, Ubuntu 10.04 x86_64/VMware 7(Win7)
我的博客:http://xieshaohu.wordpress.com/


页首
 用户资料  
 
8 楼 
 文章标题 : Re: mount出现怪问题:文件消失
帖子发表于 : 2010-06-22 12:51 

注册: 2008-04-12 12:44
帖子: 980
送出感谢: 1
接收感谢: 2
5楼请注意,v0.png是没有挂载前的状态。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: mount出现怪问题:文件消失
帖子发表于 : 2010-06-22 13:14 

注册: 2008-04-12 12:44
帖子: 980
送出感谢: 1
接收感谢: 2
pt@pt-laptop:~$ sudo mount -t ext4 /dev/sda9 /home/pt/Videos
我发现,无法往sda9里面粘帖文件,怎么回事呢,现在我如何使用sda9?


页首
 用户资料  
 
10 楼 
 文章标题 : Re: mount出现怪问题:文件消失
帖子发表于 : 2010-06-22 13:26 

注册: 2008-04-12 12:44
帖子: 980
送出感谢: 1
接收感谢: 2
pt@pt-laptop:~$ sudo mount -t ext4 /dev/sda9 /home/pt/Videos
上面的命令执行后,我无法保存文件到/home/pt/Videos下面,请看附件
原因在哪里?


附件:
Screenshot-1.png
Screenshot-1.png [ 139.01 KiB | 被浏览 269 次 ]

Screenshot.png
Screenshot.png [ 200.64 KiB | 被浏览 269 次 ]

页首
 用户资料  
 
11 楼 
 文章标题 : Re: mount出现怪问题:文件消失
帖子发表于 : 2010-06-22 13:26 
头像

注册: 2009-05-09 14:42
帖子: 513
地址: 济南
送出感谢: 0 次
接收感谢: 1
以前那个umount 了吗,,,


_________________
废土狂猪 :看啥 ,没见过网管吗,再看 吃了你!


页首
 用户资料  
 
12 楼 
 文章标题 : Re: mount出现怪问题:文件消失
帖子发表于 : 2010-06-22 14:43 

注册: 2008-04-12 12:44
帖子: 980
送出感谢: 1
接收感谢: 2
/home是挂载在/sda3的,我想umount ,不行,系统正忙。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译