当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : licb6 循环问题
帖子发表于 : 2010-06-22 15:19 

注册: 2007-12-25 17:38
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
新立得软件包管理器提示:

坏掉的依赖关系:
libc6
licb6-dev
libc6-i686
locales

无法删除也无法重新安装,怎么办?? :em20

各位兄弟姐妹们帮帮忙咯~~~


页首
 用户资料  
 
2 楼 
 文章标题 : Re: licb6 循环问题
帖子发表于 : 2010-06-22 15:37 

注册: 2007-12-25 17:38
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
ubuntu7.10


页首
 用户资料  
 
3 楼 
 文章标题 : Re: licb6 循环问题
帖子发表于 : 2010-06-22 15:42 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 274
贴出全部的提示部分。

多用aptitude安装卸载软件。


_________________
● 鸣学


页首
 用户资料  
 
4 楼 
 文章标题 : Re: licb6 循环问题
帖子发表于 : 2010-06-22 15:50 

注册: 2007-12-25 17:38
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
roger@roger-laptop:~$ sudo apt-get install cramfsprogs
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
libc6: 依赖: libc-bin (= 2.10.1-0ubuntu17) 但是它将不会被安装
依赖: findutils (>= 4.4.0-2ubuntu2) 但是 4.2.31-1ubuntu2.1 正要被安装
libc6-dev: 依赖: libc6 (= 2.6.1-1ubuntu10) 但是 2.10.1-0ubuntu17 正要被安装
libc6-i686: 预依赖: libc6 (= 2.6.1-1ubuntu10) 但是 2.10.1-0ubuntu17 正要被安装
locales: 依赖: belocs-locales-bin (>= 2.4-2.2ubuntu2) 但却无法安装它
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: licb6 循环问题
帖子发表于 : 2010-06-22 15:54 
头像

注册: 2006-10-25 18:08
帖子: 1582
送出感谢: 0 次
接收感谢: 0 次
楼主,一般来讲这是跨好几个版本升级的时候才会遇到的。我建议你全新安装最新的10.04,你版本太老,官方不支持了


_________________
楼主真是一派胡言,真可谓:“两个黄鹂鸣翠柳,不知所云;一行白鹭上青天,不知所止“。本来不想和你辩论,今天气愤不过,和你理论一番。我国宪法写得清清楚楚:“一夜夫妻百日恩,七楼以上才有电梯”。这个想必你知道,既然知道,你就不能断章取义,就算是天气预报,它还有不准的时候呢!!!再者说了,那中国银行也不是你一家开的。人家马拉多纳都结婚了,你还拿着粮票顶什么用呢。真是滑天下之大稽。前些日子,全国人大刚刚开过会,郑重声明:“中国不搞多party制,存栏母猪给补贴”。多好的事呢,楞让你这号人给搅混了。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: licb6 循环问题
帖子发表于 : 2010-06-22 15:56 

注册: 2007-12-25 17:38
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
:em20 可是现在升级好像也升不了

是不是要重新安装??


页首
 用户资料  
 
7 楼 
 文章标题 : Re: licb6 循环问题
帖子发表于 : 2010-06-22 16:20 

注册: 2007-12-25 17:38
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
roger@roger-laptop:~$ sudo apt-get install -f
[sudo] password for roger:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
正在更正依赖关系... 完成
将会安装下列额外的软件包:
findutils libc-bin libc-dev-bin libc6-dev libc6-i686 locales
建议安装的软件包:
glibc-doc manpages-dev
下列【新】软件包将被安装:
libc-bin libc-dev-bin
下列的软件包将被升级:
findutils libc6-dev libc6-i686 locales
共升级了 4 个软件包,新安装了 2 个软件包,要卸载 0 个软件包,有 1028 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 0B/10.7MB 的软件包。
解压缩后会消耗掉 21.5MB 的额外空间。
您希望继续执行吗?[Y/n]y
E: Internal Error, Could not perform immediate configuration (1) on libc6


页首
 用户资料  
 
8 楼 
 文章标题 : Re: licb6 循环问题
帖子发表于 : 2010-06-22 16:25 
头像

注册: 2006-10-25 18:08
帖子: 1582
送出感谢: 0 次
接收感谢: 0 次
我几个月前手头没有新版光盘,就从7.04升级到10.04。理论上可以,过程很痛苦,手动升级libc6只是需要解决的麻烦之一。。。
装新的吧


_________________
楼主真是一派胡言,真可谓:“两个黄鹂鸣翠柳,不知所云;一行白鹭上青天,不知所止“。本来不想和你辩论,今天气愤不过,和你理论一番。我国宪法写得清清楚楚:“一夜夫妻百日恩,七楼以上才有电梯”。这个想必你知道,既然知道,你就不能断章取义,就算是天气预报,它还有不准的时候呢!!!再者说了,那中国银行也不是你一家开的。人家马拉多纳都结婚了,你还拿着粮票顶什么用呢。真是滑天下之大稽。前些日子,全国人大刚刚开过会,郑重声明:“中国不搞多party制,存栏母猪给补贴”。多好的事呢,楞让你这号人给搅混了。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: licb6 循环问题
帖子发表于 : 2010-06-22 16:36 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 274
可以试试这样。注意备份

● sudo rm /var/lib/dpkg/info/libc6*

● sudo sv /var/lib/dpkg/info/status
去掉libc6相关的信息段。

● sudo aptitude update

● sudo aptitude upgrade

aptitude 会给出各种解决冲突的方案的。你少用apt-get。

升级到1004,其实更慢,不如新安装,保留你的家目录就是。


_________________
● 鸣学


页首
 用户资料  
 
10 楼 
 文章标题 : Re: licb6 循环问题
帖子发表于 : 2010-06-22 23:04 

注册: 2007-12-25 17:38
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
eexpress兄~~~ :em20

runit也安裝不了,
提示:

正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
libc6: 依赖: libc-bin (= 2.10.1-0ubuntu17) 但是它将不会被安装
依赖: findutils (>= 4.4.0-2ubuntu2) 但是 4.2.31-1ubuntu2.1 正要被安装
libc6-dev: 依赖: libc6 (= 2.6.1-1ubuntu10) 但是 2.10.1-0ubuntu17 正要被安装
libc6-i686: 预依赖: libc6 (= 2.6.1-1ubuntu10) 但是 2.10.1-0ubuntu17 正要被安装
locales: 依赖: belocs-locales-bin (>= 2.4-2.2ubuntu2) 但却无法安装它
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)

:em20 看來只有重裝了~~


页首
 用户资料  
 
11 楼 
 文章标题 : Re: licb6 循环问题
帖子发表于 : 2010-06-23 8:33 
头像

注册: 2006-10-25 18:08
帖子: 1582
送出感谢: 0 次
接收感谢: 0 次
我敢说ee神没干过这样的跨版本升级。


_________________
楼主真是一派胡言,真可谓:“两个黄鹂鸣翠柳,不知所云;一行白鹭上青天,不知所止“。本来不想和你辩论,今天气愤不过,和你理论一番。我国宪法写得清清楚楚:“一夜夫妻百日恩,七楼以上才有电梯”。这个想必你知道,既然知道,你就不能断章取义,就算是天气预报,它还有不准的时候呢!!!再者说了,那中国银行也不是你一家开的。人家马拉多纳都结婚了,你还拿着粮票顶什么用呢。真是滑天下之大稽。前些日子,全国人大刚刚开过会,郑重声明:“中国不搞多party制,存栏母猪给补贴”。多好的事呢,楞让你这号人给搅混了。


页首
 用户资料  
 
12 楼 
 文章标题 : Re: licb6 循环问题
帖子发表于 : 2010-06-23 10:19 
头像

注册: 2006-04-12 20:05
帖子: 8495
地址: 杭州
送出感谢: 0 次
接收感谢: 8
我那文章或许有用,看看吧:
http://luy.li/2010/06/22/ubuntu_1004/


_________________
关注我的blog: ε==3


页首
 用户资料  
 
13 楼 
 文章标题 : Re: licb6 循环问题
帖子发表于 : 2010-06-23 11:36 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 274
trigger 写道:
我敢说ee神没干过这样的跨版本升级。

啥。你个胡说的家伙。

我是没重装过系统而已。跨2个版本的,还是搞过的。
:em04 :em04 :em04 :em04

lz这跨度,是大了些。kms udev hal ,这些都改了。影响比较大。


_________________
● 鸣学


页首
 用户资料  
 
14 楼 
 文章标题 : Re: licb6 循环问题
帖子发表于 : 2010-06-23 11:38 
头像

注册: 2006-10-25 18:08
帖子: 1582
送出感谢: 0 次
接收感谢: 0 次
终于找到比ee强的地方了,老衲干过7.04-10.04 :em05


_________________
楼主真是一派胡言,真可谓:“两个黄鹂鸣翠柳,不知所云;一行白鹭上青天,不知所止“。本来不想和你辩论,今天气愤不过,和你理论一番。我国宪法写得清清楚楚:“一夜夫妻百日恩,七楼以上才有电梯”。这个想必你知道,既然知道,你就不能断章取义,就算是天气预报,它还有不准的时候呢!!!再者说了,那中国银行也不是你一家开的。人家马拉多纳都结婚了,你还拿着粮票顶什么用呢。真是滑天下之大稽。前些日子,全国人大刚刚开过会,郑重声明:“中国不搞多party制,存栏母猪给补贴”。多好的事呢,楞让你这号人给搅混了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译