当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : txt乱码
帖子发表于 : 2010-07-04 11:40 
头像

注册: 2009-07-13 19:08
帖子: 125
送出感谢: 0 次
接收感谢: 0 次
从 xp 里复制来的 txt 文件乱码 怎么办。

用 fbreader 打开也是 乱码

可能是utf-8 不对,不知道怎么弄


_________________
沉默的一代绝不会是垮掉的一代!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: txt乱码
帖子发表于 : 2010-07-04 11:42 
头像

注册: 2009-07-13 19:08
帖子: 125
送出感谢: 0 次
接收感谢: 0 次
附件:
Screenshot.png
Screenshot.png [ 330.23 KiB | 被浏览 2150 次 ]



_________________
沉默的一代绝不会是垮掉的一代!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: txt乱码
帖子发表于 : 2010-07-04 11:44 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
google一下或者装leafpad来打开


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
4 楼 
 文章标题 : Re: txt乱码
帖子发表于 : 2010-07-04 11:47 
头像

注册: 2008-11-21 20:26
帖子: 36913
送出感谢: 1
接收感谢: 36
看看教学版的置顶帖


_________________
讨厌我的人可以试着点一下
浏览全部ubuntu技巧


页首
 用户资料  
 
5 楼 
 文章标题 : Re: txt乱码
帖子发表于 : 2010-07-04 12:36 
头像

注册: 2008-09-22 8:19
帖子: 698
地址: 烟台
送出感谢: 0 次
接收感谢: 1
TXT文件中文乱码,解决办法:
终端输入:gconf-editor
依次打开;apps-->gedit2-->preferences-->encodings
双击右边的 “auto_detected"-->"add"-->
输入:GB18030-->OK-->
点向上把它移动到最上边 -->OK


_________________
秋天的太阳,躲在云层后。
它不知七月,只知是秋。
它知道鲜艳花儿已褪色,
卷曲,垂首。
它知道落叶,色彩明亮。
彩色天空下一孤树,
好似在此七月裸身。
这一切,有些会消失,
我知道,这就是秋。


我的taobao充值店。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: txt乱码
帖子发表于 : 2010-07-04 12:46 
头像

注册: 2008-09-22 8:19
帖子: 698
地址: 烟台
送出感谢: 0 次
接收感谢: 1
发现一个小技巧
只要在搜索引擎里输入
代码:
txt 乱码 site:ubuntu.org.cn


就相当于论坛搜索了。
百度也可以。地址改改可以搜索其它网站,

:em09


_________________
秋天的太阳,躲在云层后。
它不知七月,只知是秋。
它知道鲜艳花儿已褪色,
卷曲,垂首。
它知道落叶,色彩明亮。
彩色天空下一孤树,
好似在此七月裸身。
这一切,有些会消失,
我知道,这就是秋。


我的taobao充值店。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: txt乱码
帖子发表于 : 2010-07-04 13:42 
头像

注册: 2008-11-21 20:26
帖子: 36913
送出感谢: 1
接收感谢: 36
pavel2006 写道:
TXT文件中文乱码,解决办法:
终端输入:gconf-editor
依次打开;apps-->gedit2-->preferences-->encodings
双击右边的 “auto_detected"-->"add"-->
输入:GB18030-->OK-->
点向上把它移动到最上边 -->OK

最后一步不要做,否则gedit不能打开空文件,不知道这个bug现在修复没


_________________
讨厌我的人可以试着点一下
浏览全部ubuntu技巧


页首
 用户资料  
 
8 楼 
 文章标题 : Re: txt乱码
帖子发表于 : 2010-07-04 15:43 
头像

注册: 2009-07-13 19:08
帖子: 125
送出感谢: 0 次
接收感谢: 0 次
pavel2006 写道:
TXT文件中文乱码,解决办法:
终端输入:gconf-editor
依次打开;apps-->gedit2-->preferences-->encodings
双击右边的 “auto_detected"-->"add"-->
输入:GB18030-->OK-->
点向上把它移动到最上边 -->OK


用了这个方法,一些 文件 正常显示中文,还有另一些 还是乱码,郁闷中。。求解

另,用openoffice 都能正常显示。


_________________
沉默的一代绝不会是垮掉的一代!


页首
 用户资料  
 
9 楼 
 文章标题 : Re: txt乱码
帖子发表于 : 2010-07-04 15:47 
头像

注册: 2008-09-13 19:17
帖子: 7789
系统: Arch Linux (x86_64)
送出感谢: 10
接收感谢: 77
如果一定要用gedit,在打开时手动选编码


_________________
博客:http://www.lainme.com


页首
 用户资料  
 
10 楼 
 文章标题 : Re: txt乱码
帖子发表于 : 2010-07-04 15:47 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
那就用openoffice存成utf-8的文本再说


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
11 楼 
 文章标题 : Re: txt乱码
帖子发表于 : 2010-07-04 15:57 
头像

注册: 2009-07-13 19:08
帖子: 125
送出感谢: 0 次
接收感谢: 0 次
lainme 写道:
如果一定要用gedit,在打开时手动选编码


额,怎么选编码?还有 在fbreader 里全是方格。。


_________________
沉默的一代绝不会是垮掉的一代!


页首
 用户资料  
 
12 楼 
 文章标题 : Re: txt乱码
帖子发表于 : 2010-07-04 16:01 
头像

注册: 2008-09-22 8:19
帖子: 698
地址: 烟台
送出感谢: 0 次
接收感谢: 1
minar 写道:
lainme 写道:
如果一定要用gedit,在打开时手动选编码


额,怎么选编码?还有 在fbreader 里全是方格。。


打开文件时候,窗口下方看到了吧。


_________________
秋天的太阳,躲在云层后。
它不知七月,只知是秋。
它知道鲜艳花儿已褪色,
卷曲,垂首。
它知道落叶,色彩明亮。
彩色天空下一孤树,
好似在此七月裸身。
这一切,有些会消失,
我知道,这就是秋。


我的taobao充值店。


页首
 用户资料  
 
13 楼 
 文章标题 : Re: txt乱码
帖子发表于 : 2010-07-04 16:06 
头像

注册: 2009-07-13 19:08
帖子: 125
送出感谢: 0 次
接收感谢: 0 次
选哪个?
附件:
Screenshot-季羡林散文集:二月兰-腾迅读书.txt (~-文档) - gedit.png
Screenshot-季羡林散文集:二月兰-腾迅读书.txt (~-文档) - gedit.png [ 169.3 KiB | 被浏览 2091 次 ]



_________________
沉默的一代绝不会是垮掉的一代!


页首
 用户资料  
 
14 楼 
 文章标题 : Re: txt乱码
帖子发表于 : 2010-07-04 16:15 
头像

注册: 2008-09-22 8:19
帖子: 698
地址: 烟台
送出感谢: 0 次
接收感谢: 1
从gedit里打开,选GB18030,这个编码试试


_________________
秋天的太阳,躲在云层后。
它不知七月,只知是秋。
它知道鲜艳花儿已褪色,
卷曲,垂首。
它知道落叶,色彩明亮。
彩色天空下一孤树,
好似在此七月裸身。
这一切,有些会消失,
我知道,这就是秋。


我的taobao充值店。


最后由 pavel2006 编辑于 2010-07-04 16:34,总共编辑了 1 次

页首
 用户资料  
 
15 楼 
 文章标题 : Re: txt乱码
帖子发表于 : 2010-07-04 16:28 
头像

注册: 2009-07-13 19:08
帖子: 125
送出感谢: 0 次
接收感谢: 0 次
谢谢楼上,可以正常打开了,fbreader乱码也解决了

【1】打开 Fbreader 菜单-preferences

【2】在 Language 选项卡里 default language 选 Chinese,default encoding set 选Unicode,default encoding 选 utf-8

【3】到 Style 选项卡里的 Family 选你喜欢的电脑里面已经安装的中文字体

【4】点击OK保存设置


还有一个问题,能不能让gedit 记住 总是用 GB18030 打开文件,否则每次都要选很烦的


_________________
沉默的一代绝不会是垮掉的一代!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译