奇怪的乱码问题(已解决)

Lucid Lynx (长期支持)
人在井天
帖子: 1081
注册时间: 2009-04-29 21:22
送出感谢: 0
接收感谢: 1 次

奇怪的乱码问题(已解决)

#1

帖子 人在井天 » 2010-08-03 12:40

这个问题困扰了我很久了。一直不得其解。

随便新建一个空白文件,在里面写入文字。过后用gedit打开看,里面的汉字全变成了乱码,而数字和英文没事。

并不是所有的这样的文件都是如此,而是时不时地有这样的情形出现。

请看下面这个文件,从文件所显示的图示来看,里面的文字是正常的。
抓图3.png
抓图3.png (2.49 KiB) 查看 547 次
但是,打开来一看,里面的文字就全变成了乱码了。

代码: 全选

鎸夌収杩欎釜璐村瓙杩涜浜嗘搷浣渉ttp://forum.ubuntu.org.cn/viewtopic.php?f=74&t=253933

浠ュ墠鏄兘澶熺湅鐨勶紝鐜板湪涔熻兘鎴愬姛鍚姩鐢靛奖鎾斁鏈猴紝浣嗘槸锛屽嵈涓嶈兘鎴愬姛鎾斁銆傚紑澶存樉绀虹殑鏄鍦ㄦ挱鏀撅紝浣嗗叾瀹炰粈涔堜篃娌℃湁鎾斁銆傚悗鏉ユ彁绀猴細
抓图4.png

而用vi打开,则正常,用Openoffice打开,也是一切正常。

代码: 全选

按照这个贴子进行了操作http://forum.ubuntu.org.cn/viewtopic.php?f=74&t=253933

以前是能够看的,现在也能成功启动电影播放机,但是,却不能成功播放。开头显示的是正
在播放,但其实什么也没有播放。后来提示:
抓图5.png
上次由 人在井天 在 2010-08-03 14:02,总共编辑 1 次。
头像
lainme
论坛版主
帖子: 7805
注册时间: 2008-09-13 19:17
系统: Arch Linux (x86_64)
送出感谢: 3 次
接收感谢: 68 次
联系:

Re: 奇怪的乱码问题

#2

帖子 lainme » 2010-08-03 12:56

会不会是对默认编码做了修改,结果有时候可以成功自动识别,有时候不能?
头像
monk
帖子: 19507
注册时间: 2010-01-28 10:45
送出感谢: 6 次
接收感谢: 33 次

Re: 奇怪的乱码问题

#3

帖子 monk » 2010-08-03 12:57

在gedit里设置 编码自动识别

*********宁静致远*********
如果我说的有什么不对,请看签名第一行
人在井天
帖子: 1081
注册时间: 2009-04-29 21:22
送出感谢: 0
接收感谢: 1 次

Re: 奇怪的乱码问题

#4

帖子 人在井天 » 2010-08-03 13:06

lainme 写了:会不会是对默认编码做了修改,结果有时候可以成功自动识别,有时候不能?
用Openoffice打开的时候,选择的编码是utf-8,语言是中文简体。而用别的方式打开,都是乱码。而用gedit打开后,直接另存为,显示的当前语系也是utf-8,由此看来,似乎不是编码方式造成的。

怀疑是由于磁盘错误导致的,但是,为什么用vi和Openoffice又能够完全正常地打开?
人在井天
帖子: 1081
注册时间: 2009-04-29 21:22
送出感谢: 0
接收感谢: 1 次

Re: 奇怪的乱码问题

#5

帖子 人在井天 » 2010-08-03 13:07

monk 写了:在gedit里设置 编码自动识别
用gedit另存为,无论选择哪种编码,结果都是乱码。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: 奇怪的乱码问题

#6

帖子 eexpress » 2010-08-03 13:13

file 00
看下
enca 00
看下

多学习下编码知识。
● 鸣学
人在井天
帖子: 1081
注册时间: 2009-04-29 21:22
送出感谢: 0
接收感谢: 1 次

Re: 奇怪的乱码问题

#7

帖子 人在井天 » 2010-08-03 13:19

eexpress 写了:file 00
看下
enca 00
看下

多学习下编码知识。

代码: 全选

$ file 00
00: UTF-8 Unicode text

代码: 全选

$ enca 00
Universal transformation format 8 bits; UTF-8
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: 奇怪的乱码问题

#8

帖子 eexpress » 2010-08-03 13:22

是嘛。就utf8的。
那是你的gedit的编码识别,被修改了。你注意看下。
vim里面,可以看到编码的。
比如 .vimrc里面写上:

代码: 全选

set statusline+=%10.{&encoding}
你在状态栏,就可以看到文件的编码。
● 鸣学
人在井天
帖子: 1081
注册时间: 2009-04-29 21:22
送出感谢: 0
接收感谢: 1 次

Re: 奇怪的乱码问题

#9

帖子 人在井天 » 2010-08-03 13:29

eexpress 写了:是嘛。就utf8的。
那是你的gedit的编码识别,被修改了。你注意看下。
vim里面,可以看到编码的。
比如 .vimrc里面写上:

代码: 全选

set statusline+=%10.{&encoding}
你在状态栏,就可以看到文件的编码。
只有.vim和.viminfo这两个文件,没有你所说的.vimrc这个文件。

对于gedit的编码识别,我只是做了这样的一个经典修改:

代码: 全选

终端输入:gconf-editor
依次打开;apps—gedit2—preferences—encodings
双击右边的“auto_detected”—”双击”—输入:gb18030 —OK —点向上把它移动到最上边—OK.
除此之外,并没有做别的修改。
抓图6.png
人在井天
帖子: 1081
注册时间: 2009-04-29 21:22
送出感谢: 0
接收感谢: 1 次

Re: 奇怪的乱码问题

#10

帖子 人在井天 » 2010-08-03 13:37

晕,我在apps—gedit2—preferences—encodings-auto_detected,把utf-8移到首位,问题就解决了。但不知这样排序,对于打开txt文件是不是带来不方便。
人在井天
帖子: 1081
注册时间: 2009-04-29 21:22
送出感谢: 0
接收感谢: 1 次

Re: 奇怪的乱码问题

#11

帖子 人在井天 » 2010-08-03 13:39

另外,不知有没有办法,在命令行下,用gedit,使用指定编码打开目标文件?
头像
link_01
帖子: 1024
注册时间: 2008-11-05 13:24
送出感谢: 0
接收感谢: 4 次

Re: 奇怪的乱码问题

#12

帖子 link_01 » 2010-08-03 13:46

gedit --help/man gedit
学会自己找水。
笔记
-------------------------------------
http://blog.163.com/wqt_1101
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: 奇怪的乱码问题

#13

帖子 eexpress » 2010-08-03 13:51

经典修改
猜都猜得到的。很傻很天真的。

系统的其他预览等,可不根据你这修改而改变。系统其他地方都是utf8。你想想吧。

.vimrc都没有。说明你的vim还没入门。有2条路给你选择:
1. vim
2. emacs

如果还有3,那就是你永远也融入不了linux。
:em02
● 鸣学
人在井天
帖子: 1081
注册时间: 2009-04-29 21:22
送出感谢: 0
接收感谢: 1 次

Re: 奇怪的乱码问题

#14

帖子 人在井天 » 2010-08-03 13:56

link_01 写了:gedit --help/man gedit
学会自己找水。
E文不太好,所以并不总是能用这种方式找到解决的办法。人必有所长,必有所短。

虽如此,还是找到了解决了办法:

代码: 全选

--encoding=编码
人在井天
帖子: 1081
注册时间: 2009-04-29 21:22
送出感谢: 0
接收感谢: 1 次

Re: 奇怪的乱码问题

#15

帖子 人在井天 » 2010-08-03 14:01

eexpress 写了:
经典修改
猜都猜得到的。很傻很天真的。

系统的其他预览等,可不根据你这修改而改变。系统其他地方都是utf8。你想想吧。

.vimrc都没有。说明你的vim还没入门。有2条路给你选择:
1. vim
2. emacs

如果还有3,那就是你永远也融入不了linux。
:em02

vi用得不多,所以没有深入研究。至于linux,普通的人也没有必要那么精通,能用就行呀。
回复

回到 “Ubuntu 10.04 LTS”