当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : deb软件包无法安装
帖子发表于 : 2010-08-14 11:09 

注册: 2010-08-14 10:48
帖子: 2
送出感谢: 0 次
接收感谢: 0 次

各位哥哥们,我的ubuntu现在无法安装deb软件包了,在ubuntu软件中心安装是这个提示:E:I wasn't able to locate file for the xinyang-office package. This might mean you need to manually fix this package. 直接双击deb软件包是这个提示:installArchives() failed
我在终端输入sudo apt-get -f install之后显示如下内容,正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
下列软件包是自动安装的并且现在不需要了:
sdparm libqt4-xmlpatterns libqt4-xml language-pack-zh-base libqt4-network
libanthy0 language-pack-gnome-zh-base
使用'apt-get autoremove'来删除它们
下列软件包将被【卸载】:
xinyang-office
升级了 0 个软件包,新安装了 0 个软件包,要卸载 1 个软件包,有 21 个软件包未被升级。
有 1 个软件包没有被完全安装或卸载。
解压缩后将会空出 41.0kB 的空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 165379 个文件和目录。)
正在删除 xinyang-office ...
/var/lib/dpkg/info/xinyang-office.postrm: 14: Syntax error: "fi" unexpected
dpkg:处理 xinyang-office (--remove)时出错:
子进程 已安装的 post-removal 脚本 返回了错误号 2
在处理时有错误发生:
xinyang-office
E: Sub-process /usr/bin/dpkg returned an error code (1)
请问如何解决啊?谢谢各位!(我的系统是从心氧ubuntu9.04升级到10.04的,然后运行了一下电脑清洁工就这样了)


页首
 用户资料  
 
2 楼 
 文章标题 : Re: deb软件包无法安装
帖子发表于 : 2010-08-14 11:56 
头像

注册: 2006-12-17 13:34
帖子: 1818
地址: 武汉
送出感谢: 1
接收感谢: 0 次
xinyang-office

这是什么??新氧-office???


_________________
人生长恨水长东;
远近高低各不同.


页首
 用户资料  
 
3 楼 
 文章标题 : Re: deb软件包无法安装
帖子发表于 : 2010-08-14 11:57 
头像

注册: 2006-12-17 13:34
帖子: 1818
地址: 武汉
送出感谢: 1
接收感谢: 0 次
升级以后是不是源没有改阿。


_________________
人生长恨水长东;
远近高低各不同.


页首
 用户资料  
 
4 楼 
 文章标题 : Re: deb软件包无法安装
帖子发表于 : 2010-08-14 12:03 
头像

注册: 2008-04-27 12:15
帖子: 1026
送出感谢: 0 次
接收感谢: 0 次
电脑清洁工的说明已经明确告诉了,让电脑像新的一样……
心氧也是一个发行版?


_________________
oneleaf 的教导记心间:《学习linux几点忠告》


页首
 用户资料  
 
5 楼 
 文章标题 : Re: deb软件包无法安装
帖子发表于 : 2010-08-14 12:07 
头像

注册: 2008-09-13 19:17
帖子: 7789
系统: Arch Linux (x86_64)
送出感谢: 10
接收感谢: 77
viewtopic.php?f=103&t=216743&start=0


_________________
博客:http://www.lainme.com


页首
 用户资料  
 
6 楼 
 文章标题 : Re: deb软件包无法安装
帖子发表于 : 2010-08-14 13:47 
头像

注册: 2009-07-18 11:33
帖子: 793
送出感谢: 1
接收感谢: 1
在论坛搜索一下,我早期发过这个帖子,后来解决掉了用purge全部删掉xinyang自定义的包即可


_________________
Men are from Mars, I am from the grave
有一次,我去应聘,考官说:“哦,什么味儿?”
我说:”啊,对不起,是我,你知道死人总是有一点味道的“


页首
 用户资料  
 
7 楼 
 文章标题 : Re: deb软件包无法安装
帖子发表于 : 2010-08-14 18:42 

注册: 2010-01-13 23:26
帖子: 3173
送出感谢: 0 次
接收感谢: 12
电脑清洁工是不能用嘀。。。


_________________
Here I am.
Ubuntu 桌面培训 - 全中文官方文档,含汉化截图,提供PDF


页首
 用户资料  
 
8 楼 
 文章标题 : Re: deb软件包无法安装
帖子发表于 : 2010-08-15 13:02 

注册: 2010-08-14 10:48
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
lainme 写道:
http://forum.ubuntu.org.cn/viewtopic.php?f=103&t=216743&start=0

这个很不错,按照这个提示解决了!谢谢啦


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译