当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu 10 安装 codebloscks 10
帖子发表于 : 2010-08-31 18:58 

注册: 2010-05-10 23:24
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
学习c语言一直没能到 linux平台来使用。经过一翻下午。终于算是搞清除了点。
安装的步骤。
首先安装wxwidget ,根据codeblocks官网说法,ubuntu 提供的wxwidget版本并非标准版,不能用于codeblocks,原文如下:
----------------------------------------------------------------------------------------------------------------------------------
Important note for Ubuntu users: To be able to use the Debian packages on Ubuntu Karmic Koala (9.10) and Lucid Lynx (10.04) you have to use the wxWidgets packages from apt.wxwidgets.org, because the packages provided by Ubuntu are not compatible with the ones from wxwidgets.org. Alternatively you can use the Ubuntu repo provided by our user pasgui.
------------------------------------------------------------------------------------------------------------------------------------
安装wxwidget的方法:参考链接 http://wiki.wxpython.org/InstallingOnUbuntuOrDebian
大概步骤:
1.先进入“系统”--》“系统管理”--》“新立德软件包管理器“,搜索curl,双击选中,之后点“应用” 如下图:
图片
2.关闭“新立德软件包管理器“,打开:应用程序”--》“附件”--》“终端”
输入 :
curl http://apt.wxwidgets.org/key.asc | sudo apt-key add -

回车。
3.进入“系统”--》“系统管理”--》“软件源”
切到“其他软件”标签,点添加 ,分别添加下面2个链接:
deb http://apt.wxwidgets.org/ lucid-wx main

deb-src http://apt.wxwidgets.org/ lucid-wx main

参考图:
图片

关闭
4. 打开”应用程序关闭
4. 打开”应用程序“--》”附件“--》”终端“ ,执行以下命令:
sudo apt-get update
sudo apt-get install python-wxgtk2.8 python-wxtools wx2.8-i18n
5. 现在开始安装codeblocks10 ,从 http://www.codeblocks.org/downloads/26 下载codeblocks
这里选择linux版本 :codebl关闭
4. 打开”应用程序“--》”附件“--》”终端“ ,执行以下命令:
sudo apt-get update
sudo apt-get install python-wxgtk2.8 python-wxtools wx2.8-i18n

5. 现在开始安装codeblocks10 ,从 http://www.codeblocks.org/downloads/26 下载codeblocks
这里选择linux版本 :codeblocks-10.05-1-debian-i386.tar.bz2ocks-10.05-1-debian-i386.tar.bz2“--》”附件“--》”终端“ ,执行以下命令:
sudo apt-get update
sudo apt-get install python-wxgtk2.8 python-wxtools wx2.8-i18n
5. 现在开始安装codeblocks10 ,从 http://www.codeblocks.org/downloads/26 下载codeblocks
这里选择linux版本 :codeblocks-10.05-1-debian-i386.tar.bz2
图片
(至于下面的codeblocks-10.05-1-debian-dbg-i386.tar.bz2,我没有试过,应该也可以)
6. 解压下载的文件,得到很多.deb文件
7.进入i386文件目录,打开”终端“,执行sudo dpkg -i *.deb
完成后,可在”应用程序“--》”编程“中找到
图片可以到
http://user.qzone.qq.com/7398904/blog/1283250652看。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: ubuntu 10 安装 codebloscks 10
帖子发表于 : 2010-08-31 19:36 
头像

注册: 2008-04-07 17:36
帖子: 4010
地址: 泰安人在阜新
送出感谢: 0 次
接收感谢: 0 次
源里不是有么。。。


_________________
宇宙数学物理 sssssssss Ubuntu 桌面培训 sssssssss 问打包的问题之前先看
和我一样的新手请看,我看过了,腰不酸了,腿不疼了,上楼也有劲了
想去IRC的点这里——一个比QQ群好N多的东西


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ubuntu 10 安装 codebloscks 10
帖子发表于 : 2010-08-31 19:39 
头像

注册: 2009-01-06 15:18
帖子: 13005
地址: 人间
送出感谢: 1
接收感谢: 24
。。。。。。 :em05 :em05 :em05 :em05


_________________
“有一种被人抛诸脑后的过去,包含一些不该遗忘的点点滴滴。欢笑之余,我将故旧拾起,才刹见自己的薄情。人世间似乎存在着某种公平,每个人都曾被抛掷在他人的遗忘中;而今你所有哽咽难宣的话语,也正是你曾为人所期盼,却永远听不见的字句。” —赫曼 赫塞


页首
 用户资料  
 
4 楼 
 文章标题 : Re: ubuntu 10 安装 codebloscks 10
帖子发表于 : 2010-08-31 22:08 

注册: 2010-05-10 23:24
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
高手们当然知道。但是新手还是模不着头脑。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译