当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 装了ubuntu10.10一个多星期了,耳机声音一直出不来,救救我啊!
帖子发表于 : 2010-11-24 20:46 

注册: 2007-04-03 10:38
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
我是linux新人啊,最近倒腾了ubuntu10.10,界面倒是挺好的。就是一直只有机箱的喇叭有声音,插上耳机后没有声音。刚装上时,打开alsamixer看,master M是被mute掉的,打开后,机箱喇叭有声音了,但是插上耳机后,耳机就没有声音(确认耳机是好的),在alsamixer里面看,有headphone的选项,但是不能上下调节。
倒腾了很久,google了很多方法都不管用。只好到这里来求助了。
我的alsa-base.conf 文件的内容如下,请各位达人帮我看看哪里有问题啊。先在这里谢谢了。

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 装了ubuntu10.10一个多星期了,耳机声音一直出不来,救救我啊!
帖子发表于 : 2010-11-24 20:53 

注册: 2007-04-03 10:38
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
晕,怎么贴图啊。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 装了ubuntu10.10一个多星期了,耳机声音一直出不来,救救我啊!
帖子发表于 : 2010-11-26 19:56 

注册: 2007-04-03 10:38
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
啊,不会没有人知道吧,是不是这个问题太简单了啊。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 装了ubuntu10.10一个多星期了,耳机声音一直出不来,救救我啊!
帖子发表于 : 2010-11-27 11:29 

注册: 2007-04-03 10:38
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
晕,还是没有人帮我啊,额。。。。。。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 装了ubuntu10.10一个多星期了,耳机声音一直出不来,救救我啊!
帖子发表于 : 2010-11-27 12:10 
头像

注册: 2009-01-06 15:18
帖子: 13005
地址: 人间
送出感谢: 1
接收感谢: 24
pcr386 写道:
晕,怎么贴图啊。


附件:
hoho.JPG
hoho.JPG [ 14.42 KiB | 被浏览 761 次 ]



_________________
“有一种被人抛诸脑后的过去,包含一些不该遗忘的点点滴滴。欢笑之余,我将故旧拾起,才刹见自己的薄情。人世间似乎存在着某种公平,每个人都曾被抛掷在他人的遗忘中;而今你所有哽咽难宣的话语,也正是你曾为人所期盼,却永远听不见的字句。” —赫曼 赫塞
页首
 用户资料  
 
6 楼 
 文章标题 : Re: 装了ubuntu10.10一个多星期了,耳机声音一直出不来,救救我啊!
帖子发表于 : 2010-11-27 12:22 
头像

注册: 2008-12-13 10:55
帖子: 1215
地址: the Earth
送出感谢: 2
接收感谢: 3
pcr386 写道:
晕,怎么贴图啊。

開始的時候看不了上傳附件,你可以點預覽,就有了,上傳之後點插入


_________________
苏东坡问佛印道:“人人皆念观世音菩萨,观世音菩萨念谁?”
佛印答道:“念观世音菩萨。”
苏东坡诧异:“为何亦念观世音菩萨?”
曰:“求人不如求己。”


dropbox 誰好奇,誰來點
勞碌一生又如何,虛度一生又如何,你過得開心嗎?人活著就要開心嘛!


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 装了ubuntu10.10一个多星期了,耳机声音一直出不来,救救我啊!
帖子发表于 : 2010-11-27 12:29 
头像

注册: 2009-05-05 20:45
帖子: 568
送出感谢: 0 次
接收感谢: 0 次
是37内核么?如果是的话就是内核的问题。


_________________
The world never lacks miracles.


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 装了ubuntu10.10一个多星期了,耳机声音一直出不来,救救我啊!
帖子发表于 : 2010-11-29 12:33 

注册: 2007-04-03 10:38
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
多谢各位,我回去试试看,现在电脑不在旁边。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 装了ubuntu10.10一个多星期了,耳机声音一直出不来,救救我啊!
帖子发表于 : 2010-11-29 12:41 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 274
此类的问题,见过的解决方案,通常是修改某配置文件的某行。
只是要根据型号去搜索。


_________________
● 鸣学


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 装了ubuntu10.10一个多星期了,耳机声音一直出不来,救救我啊!
帖子发表于 : 2010-12-02 9:14 

注册: 2007-04-03 10:38
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
应该是我的声卡设置太过于特殊了。有点晕,就是一直只有机箱的喇叭有声音,插上耳机,机箱没有声音了,耳机也没有声音。尝试过网上的很多方法,都没有用。诶。再看看把。


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 装了ubuntu10.10一个多星期了,耳机声音一直出不来,救救我啊!
帖子发表于 : 2010-12-02 9:29 

注册: 2007-04-03 10:38
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
The module options for snd-intel8x0
description: Intel 82801AA,82901AB,i810,i820,i830,i840,i845,MX440; SiS 7012; Ali 5455


看了www.alsa-project.org官方的介绍,如上.而我的主板是i865的,是不是意味着不支持呢?

正准备放弃了。诶。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译