求教,我在10.04LTS升级到10.10时出现如下错误

Lucid Lynx (长期支持)
回复
TNTnaoh
帖子: 1
注册时间: 2011-02-09 10:49
送出感谢: 0
接收感谢: 0

求教,我在10.04LTS升级到10.10时出现如下错误

#1

帖子 TNTnaoh » 2011-02-09 10:53

无法计算升级

An unresolvable problem occurred while calculating the upgrade:
E:错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。

This can be caused by:
* Upgrading to a pre-release version of Ubuntu
* Running the current pre-release version of Ubuntu
* Unofficial software packages not provided by Ubuntu

如果这些都不可用,请报告这个对于“update-manager“包的软件错误,并把目录 /var/log/dist-upgrade/ 下面的文件包含到错误报告里面。



请问各位如何解决
jtshs256
论坛版主
帖子: 22323
注册时间: 2010-07-19 21:41
系统: OS X
送出感谢: 2 次
接收感谢: 27 次

Re: 求教,我在10.04LTS升级到10.10时出现如下错误

#2

帖子 jtshs256 » 2011-02-09 10:55

viewtopic.php?f=77&t=316399
神的升级…… :em70
NO DO NO DIE
http://a/%%30%30
头像
Dim
帖子: 640
注册时间: 2009-04-06 15:03
送出感谢: 1 次
接收感谢: 0

Re: 求教,我在10.04LTS升级到10.10时出现如下错误

#3

帖子 Dim » 2011-02-09 16:12

他都说了你设置了有软件包保持不升级所以升级不了,你设置一下再试试
,
头像
速腾1994
论坛版主
帖子: 17363
注册时间: 2008-11-01 20:43
系统: Arch+gnome
送出感谢: 23 次
接收感谢: 8 次

Re: 求教,我在10.04LTS升级到10.10时出现如下错误

#4

帖子 速腾1994 » 2011-02-10 10:09

在软件源里设置
wqqafnd
帖子: 3
注册时间: 2009-04-30 17:51
送出感谢: 0
接收感谢: 0

Re: 求教,我在10.04LTS升级到10.10时出现如下错误

#5

帖子 wqqafnd » 2011-10-15 14:58

So if you've landed on this thread looking for a solution suitable for a newby, here's what worked for me without needing a command line or great knowledge:

Open "Ubuntu Software Center"

Click on "Installed Software"

Search for "nvidia"

Remove all resulting packages except for "jockey-gtk" and "jockey-common" (remember them in case you want to reinstall after the upgrade)

Try the upgrade again.

This worked to get me from Lynx to Meercat when I ran into the errors described above.

我按照这个方法操作后,错误没有了。
回复

回到 “Ubuntu 10.04 LTS”