HOWTO: Maya 6.5 under Hoary (Revised)

参与到Ubuntu的翻译中来
回复
头像
oneleaf
论坛管理员
帖子: 10208
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

HOWTO: Maya 6.5 under Hoary (Revised)

#1

帖子 oneleaf » 2005-08-12 10:59

This is a tutorial to install the 3d graphics application Alias Maya 6.5 from the .rmp files you get on the cd if you purchase it. You should copy these to your hard drive, preferably to your home folder.

This install was made in Ubuntu Hoary 386 with the 2.6.10 kernel. I have no idea if it will work on other systems.

1. Maya needs the C shell program "csh" so you need to apt-get it.
Code:

sudo apt-get install csh


2. Install the program Alien to convert your maya .rmp files to .deb.
Code:

sudo apt-get install alien


3. Use "alien -iv xxx.rpm": (i for install, v for verbose). Replace the x'es with the correct numbers of your packages.
Code:

alien -iv AWCommon-server-6.3-x.xxxx.rpm alien -iv AWCommon-6.3-x.xxxx.rpm alien -iv Maya6_5-x.x-xxx.xxxx.rpm


4. Create the following links:
Code:

sudo ln -s /usr/aw /aw cd /usr/aw/maya6.5/lib sudo ln -s libawcsprt.so.1 libawcsprt.so sudo ln -s libpcwxml.so.1 libpcwxml.so


5. Maya wants to use the directory /usr/tmp/ for storing temporary files.
Code:

sudo mkdir /usr/tmp sudo chmod 777 /usr/tmp


6. You will need to create a directory for storing the license file (usually called aw.dat), then copy the file to it.
Code:

sudo mkdir /var/flexlm


"cd" to the directory where you put your "aw.dat", then:
Code:

sudo mv aw.dat /var/flexlm


7. Run the license install script "installKey" in /usr/aw/COM/bin/ (you can do this in your window browser, in Gnome - Nautilus). Point it to /var/flexlm/aw.dat.

8. Type "/aw/maya6.5/bin/Maya6.5" to start, or use Smeg to create a shortcut in the Gnome panel.

9. As you probably will want to use the "Alt-key+mouse button" combination to pan and rotate in your viewport, open System/Preferences/Windows in the upper Gnome panel and change the Movement Key to Control or Super.

You also need to have graphics drivers (and card) with openGL support, but the drivers you get with Ubuntu will probably work. Otherwise, check the Ubuntu howtos for how to install your driver.

Good Luck!
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#2

帖子 firehare » 2005-08-12 17:46

这个我来翻好了!先认领一下!呵呵!
我心无畏,源自于我心无知。
图片
starbear
帖子: 31
注册时间: 2005-07-17 0:38
来自: WZU
送出感谢: 0
接收感谢: 0

#3

帖子 starbear » 2005-08-18 15:50

firehare兄最近很忙,兄弟我代他先把这个试着翻了,里面有几个词汇不太会翻译,如有错误请指正。

===============================================
此文档是关于安装名为Maya 6.5的3D图形程序的指南,如果买了它的CD的话,你可以从CD里得到它的.rmp文件,你需要将这些文件拷贝到硬盘上,最好是放到自己的家目录里。

此安装过程是由2.6.10内核版本的Ubuntu Hoary 386执行的。我不能确定它是否能在其他的系统下工作。

1.Maya需要“csh”这样的C shell程序,所以你需要使用apt-get来安装这个程序。

Code:

sudo apt-get install csh

2.安装Alien程序用来将maya.rmp文件转换成.deb格式。

Code:

sudo apt-get install alien

3.使用“alien -iv xxx.rpm”:(i是安装,v是详细的显示)。用正确的包版本号来替换其中的x。

Code:

alien -iv AWCommon-server-6.3-x.xxxx.rpm alien -iv AWCommon-6.3-x.xxxx.rpm alien -iv Maya6_5-x.x-xxx.xxxx.rpm

4.创建以下的连接:

Code:

sudo ln -s /usr/aw /aw cd /usr/aw/maya6.5/lib sudo ln -s libawcsprt.so.1 libawcsprt.so sudo ln -s libpcwxml.so.1 libpcwxml.so

5.Maya会使用/usr/tmp来存放一些临时文件。

Code:

sudo mkdir /usr/tmp sudo chmod 777 /usr/tmp

6.需要创建一个用来存放许可证文件(通常为aw.dat)的目录,然后把许可证文件拷进来。

Code:

sudo mkdir /var/flexlm


"cd" to the directory where you put your "aw.dat", then:
Code:

sudo mv aw.dat /var/flexlm

7.运行/usr/aw/COM/bin下的安装脚本“installKey”(可以在 Gnome - Nautilus的浏览器窗口运行),指向/var/flexlm/aw.dat。

8.可以通过输入“/aw/maya6.5/bin/Maya6.5”运行程序,也可以通过使用Smeg在Gnome面板上创建程序快捷方式。

9.如果你希望使用“Alt+鼠标”组合键来平移和旋转视角,可以通过Gnome面板菜单栏的/系统/属性/窗口(System/Preferences/Windows)来改变运动键(Movement Key)的设置。

你可能还需要能支持openGL的图形驱动(连板卡),这个驱动需要能在Ubuntu下工作。另外,在安装驱动的时候先查阅Ubuntu的howtos.

祝好运!
===============================================
独自站在这舞台,听到掌声响起来....
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#4

帖子 firehare » 2005-08-18 20:42

啊???
这个东东我已经翻译完了呀!

O!
明白了!
一定是前几天数据库数据回滚造成的!

不过StarBear翻了也一样,呵呵!
我心无畏,源自于我心无知。
图片
头像
oneleaf
论坛管理员
帖子: 10208
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

#5

帖子 oneleaf » 2005-08-22 20:03

当净其意如虚空,远离妄想及诸取,令心所向皆无碍
mosquito-liu
帖子: 170
注册时间: 2005-09-12 22:17
送出感谢: 0
接收感谢: 0

#6

帖子 mosquito-liu » 2005-09-15 11:13

不知道7.0是不是样的装法!
头像
millenniumdark
论坛版主
帖子: 4160
注册时间: 2005-07-02 14:41
系统: Ubuntu 14.04 (Kylin)
送出感谢: 43 次
接收感谢: 9 次
联系:

#7

帖子 millenniumdark » 2006-07-30 15:51

这个也比较旧了,不知道有没有用,先留着
头像
yangjinchao
帖子: 119
注册时间: 2006-04-18 21:08
送出感谢: 0
接收感谢: 0
联系:

feisty 装maya 8.5 没成功

#8

帖子 yangjinchao » 2007-06-08 20:34

feisty 装maya 没成功,安装awcommon有出错提示,于是删了/usr/bin/test和/usr/aw目录,本以为这样就卸载了awcomm,弄的现在连apt-get ,新立得都不可以用了,在网上找了半天无果,望论坛里的高人可以帮帮我
头像
arsui
帖子: 889
注册时间: 2007-05-06 2:01
来自: 特麓村->浦北->五山->罗湖
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 arsui » 2007-06-19 22:22

-----------------------
sudo apt-get remove awcommon
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: The package awcommon needs to be reinstalled, but I can't find an archive for it.
-------------------------------------

我也是遇到这个麻烦了,原先装8。5 不稳定,于是便装了7。0 但是不成功,删除之后便出现问题了~~~新立得也出错了
wywy19
帖子: 1
注册时间: 2007-09-19 19:05
送出感谢: 0
接收感谢: 0

#10

帖子 wywy19 » 2007-09-19 19:21

我 的也是 一样 的 问题 ,但是我 的 maya2008装 成功了
新立得进不去了



wangwei@wangwei-desktop:/usr/autodesk/soft$ sudo dpkg -i awcommon-server_10.80-14_i386.deb
(正在读取数据库 ... 系统当前总共安装有 133592 个文件和目录。)
正预备替换 awcommon-server 10.80-14 (使用 awcommon-server_10.80-14_i386.deb) ...
正在解压缩将用于更替的包文件 awcommon-server ...
/usr/bin/test: 无效的整数 ‘upgrade’
正在设置 awcommon-server (10.80-14) ...
Warning: Unable to locate the chkconfig utility!
This is required to add or remove the License Server as an automatically started
system daemon.
You can manually set this up or run the utility that came with you linux distribution.

wangwei@wangwei-desktop:/usr/autodesk/soft$ sudo dpkg -i awcommon_10.80-14_i386.deb(正在读取数据库 ... 系统当前总共安装有 133592 个文件和目录。)正预备替换 awcommon 10.80-14 (使用 awcommon_10.80-14_i386.deb) ...
正在解压缩将用于更替的包文件 awcommon ...
/usr/bin/test: 无效的整数 ‘upgrade’
exit: 26: Illegal number: -0
dpkg:警告 - 原先的 post-removal 脚本 退出时返回了错误号 2
dpkg - 现转而试用新软件包所带的脚本...
/usr/bin/test: 无效的整数 ‘failed-upgrade’
exit: 26: Illegal number: -0
dpkg:处理 awcommon_10.80-14_i386.deb (--install)时出错:
子进程·新的 post-removal 脚本·返回了错误号·2
/usr/bin/test: 无效的整数 ‘abort-upgrade’
exit: 26: Illegal number: -0
dpkg: 作下列清理工作时发生错误:
子进程·post-removal script·返回了错误号·2
在处理时有错误发生:
awcommon_10.80-14_i386.deb
mkkkno1
帖子: 2
注册时间: 2007-10-11 0:14
送出感谢: 0
接收感谢: 0

#11

帖子 mkkkno1 » 2007-10-11 19:59

这样做
代码:

sudo rm /var/lib/dpkg/info/awcommon.postrm
然后重新安装 awcommon
回复

回到 “软件和文档翻译”