当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : JavaAMD64
帖子发表于 : 2005-08-26 23:52 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10116
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 128
Java for amd64

For those of us using a 64 bit processor, Sun have not yet provided a Java implementation, so we have to use blackdown. Here's how.

Download Blackdowns JRE package from [ [WWW] ftp://ftp.tux.org/pub/java/JDK-1.4.2/amd64/ ] at the time of writing this, the most recent version is in "/02/" and it is "j2re-1.4.2-02-linux-amd64.bin".

Make the shell script executable

$ sudo chmod +x *amd64.bin

Move the pacakge to the desired install directory

$ sudo mv j2re-1.4.2-02-linux-amd64.bin /usr/local

Change to the wanna-be install directory

$ cd /usr/local

Extract the contents of the package

$ sudo ./j2re-1.4.2-02-linux-amd64.bin

To install the plugin:

$ sudo ln -s /usr/local/j2re1.4.2/plugin/amd64/mozilla/libjavaplugin_oji.so /usr/lib/mozilla-firefox/plugins/

Manually install the latest Java Update (Only if the previous instructions failed) (not for amd64)

The latest version of the Java 2 Platform Standard Edition is JRE 5.0 Update 4

Download [WWW] http://java.sun.com/j2se/1.5.0/download.jsp

Choose the "JRE 5.0 Update 4 includes the JVM technology" version

Linux installation instruction [WWW] http://java.sun.com/j2se/1.5.0/jre/install-linux.html

Or In A Nutshell

$ su -
# cd /usr/java
# cp <get.the.latest.java.rpm.bin> java.rpm.bin
# chmod 744 java.rpm.bin
# ./java.rpm.bin
say "yes" to licence

# cd /path/to/firefox/plugins (ie /usr/lib/firefox-1.0.6/plugins)
# ln -s /usr/java/jre1.5.0_04/plugin/i386/ns7/libjavaplugin_oji.so


https://wiki.ubuntu.com/JavaAMD64


_________________
当净其意如虚空,远离妄想及诸取,令心所向皆无碍


页首
 用户资料  
 
2 楼 
 文章标题 : JavaAMD64
帖子发表于 : 2005-08-30 0:27 
头像

注册: 2005-08-18 22:24
帖子: 105
地址: 广东省中山市
送出感谢: 0 次
接收感谢: 0 次
在 AMD64 上安装 JAVA 虚拟机

SUN 公司并没有提供一个在我们那些安装了 64 位处理器的电脑上执行 JAVA 的程序, 所以我们必须使用 Blackdown . 现在就让我们来做吧.

从 [ftp://ftp.tux.org/pub/java/JDK-1.4.2/amd64/] 下载 Blackdowns JRE 的软件包, 在写这篇文章的时候, 最新的版本是 "/02/" ,文件名是 "j2re-1.4.2-02-linux-amd64.bin".

让这个命令行脚本(shell script)可执行

$ sudo chmod +x *amd64.bin

将这个安装包移动到你想安装的目录下

$ sudo mv j2re-1.4.2-02-linux-amd64.bin /usr/local

改变当前目录到你想安装的那个目录

$ cd /usr/local

解压包中的文件

$ sudo ./j2re-1.4.2-02-linux-amd64.bin

为 mozilla-firefox 安装插件:

$ sudo ln -s /usr/local/j2re1.4.2/plugin/amd64/mozilla/libjavaplugin_oji.so /usr/lib/mozilla-firefox/plugins/

手动安装最新的 Java Update (如果前面的指导没用)(不适用于 AMD64)

最新的 JAVA 2 平台是 JRE 5.0 Update 4

下载: http://java.sun.com/j2se/1.5.0/download.jsp

选择 "JRE 5.0 Update 4 includes the JVM technology" 版本

Linux 安装指导: http://java.sun.com/j2se/1.5.0/jre/install-linux.html

或者在一个 Nutshell 中

$ su -
# cd /usr/java
# cp <get.the.latest.java.rpm.bin> java.rpm.bin
# chmod 744 java.rpm.bin
# ./java.rpm.bin
在许可协议中, 选择 "yes"

# cd /path/to/firefox/plugins (ie /usr/lib/firefox-1.0.6/plugins)
# ln -s /usr/java/jre1.5.0_04/plugin/i386/ns7/libjavaplugin_oji.so

翻译: 子衿
于2005年8月29日0:25

我英语水平不高,看到这个还比较简单,就翻翻吧,错的请改正,谢谢.....


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-08-30 16:52 
头像

注册: 2005-08-29 14:49
帖子: 1119
地址: 杭州
送出感谢: 0 次
接收感谢: 3
在 AMD64 上安装 JAVA 虚拟机
>Java for AMD64

SUN 公司并没有提供一个在我们那些安装了 64 位处理器的电脑上执行 JAVA 的程序, 所以我们必须使用 Blackdown . 现在就让我们来做吧.
>SUN公司还未向我们那些使用64位处理器的系统提供Java实现,因此我们不得不使用Blackdowns。安装步骤如下。

从 [ftp://ftp.tux.org/pub/java/JDK-1.4.2/amd64/] 下载 Blackdowns JRE 的软件包, 在写这篇文章的时候, 最新的版本是 "/02/" ,文件名是 "j2re-1.4.2-02-linux-amd64.bin".
>从[[WWW]ftp://ftp.tux.org/pub/java/JDK-1.4.2/amd64/]下载Blackdowns JRE安装包;写作此文时,最新版本位于"/02/"文件夹,包名为"j2re-1.4.2-02-linux-amd64.bin"。

让这个命令行脚本(shell script)可执行
>使如下shell脚本可执行

$ sudo chmod +x *amd64.bin

将这个安装包移动到你想安装的目录下

$ sudo mv j2re-1.4.2-02-linux-amd64.bin /usr/local

改变当前目录到你想安装的那个目录

$ cd /usr/local

解压包中的文件

$ sudo ./j2re-1.4.2-02-linux-amd64.bin

为 mozilla-firefox 安装插件:

$ sudo ln -s /usr/local/j2re1.4.2/plugin/amd64/mozilla/libjavaplugin_oji.so /usr/lib/mozilla-firefox/plugins/

手动安装最新的 Java Update (如果前面的指导没用)(不适用于 AMD64)

最新的 JAVA 2 平台是 JRE 5.0 Update 4

下载: http://java.sun.com/j2se/1.5.0/download.jsp

选择 "JRE 5.0 Update 4 includes the JVM technology" 版本

Linux 安装指导: http://java.sun.com/j2se/1.5.0/jre/install-linux.html

或者在一个 Nutshell 中
>或者简言之,如下:

$ su-
# cd /usr/java
# cp <get.the.latest.java.rpm.bin> java.rpm.bin
# chmod 744 java.rpm.bin
# ./java.rpm.bin
在许可协议中, 选择 "yes"
>选择"yes"确认许可协议

# cd /path/to/firefox/plugins (ie /usr/lib/firefox-1.0.6/plugins)
# ln -s /usr/java/jre1.5.0_04/plugin/i386/ns7/libjavaplugin_oji.so

修正:leal based on [翻译: 子衿 于2005年8月29日0:25]


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-08-31 18:23 
头像

注册: 2005-08-18 22:24
帖子: 105
地址: 广东省中山市
送出感谢: 0 次
接收感谢: 0 次
谢谢leal的修正


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-09-07 20:33 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10116
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 128
http://www.ubuntu.org.cn/support/docume ... howto_view


_________________
当净其意如虚空,远离妄想及诸取,令心所向皆无碍


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-07-30 18:13 
头像

注册: 2005-07-02 14:41
帖子: 4133
系统: Ubuntu 14.04 (Kylin)
送出感谢: 53
接收感谢: 11
过时
英文变化太大了
作废
https://help.ubuntu.com/community/Java


_________________
https://weakish.github.io


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译