当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : HOWTO: 在程序声音出问题时修正系统声音
帖子发表于 : 2005-04-19 15:52 
头像

注册: 2005-03-26 9:38
帖子: 521
送出感谢: 0 次
接收感谢: 0 次
This fix is painfully simple, but has worked for me several times, I hope it helps some of you having this problem too:

i) If you cant hear sounds in other programs (ie: media players, video, etc) then this is not the howto for you ... there are many other posts on how to get sounds in programs working, this post is how to get system (event) sounds to work when the other sounds work.

ii) This is tested using ALSA for all of your sound server settings ... if you havent rebooted since choosing ALSA for your sound server run 'sudo killall esd' before proceeding. (You can choose ALSA as your sound server in System > Preferences > Multimedia Sysem Selector - Set both Sync and Source to ALSA).

1) Click on System > Preferences > Sound
2) Uncheck "Enable Sound Server Startup"
3) Log out of Gnome
4) Log back into Gnome
5) Go back to System > Preferences > Sound
6) Check "Enable Sound Server Startup"
7) Test, if all went well your system sounds should now work.

It appears that although the 'sound server startup' option is checked, it isn't really enabled. The above has fixed the problem for me numerous times.

The same fix appears to work in KDE (kubuntu) as well:

1) Goto System > Settings
2) Click on 'Sound & Multimedia'
3) Click on 'System Notifications'
4) Click on 'Player Settings' Button
5) Select 'Use External Player' and type 'aplay' in the box.
6) Click 'OK' for both screens
7) Test it this way (my experiance is that sounds are choppy this way and get cut off)
8) If you heard sounds at step 7 continue on to the following steps
9) Repeat steps 3-4
10) Choose 'Use the KDE Sound System'
11) Click OK twice and test (At this point all sounds worked correctly for me in KDE)

Let me know if these instructions helped.


页首
 用户资料  
 
2 楼 
 文章标题 : HOWTO:在程序声音出问题时修正系统声音
帖子发表于 : 2005-04-25 5:09 
头像

注册: 2005-04-06 21:15
帖子: 2200
地址: 安徽黄山
送出感谢: 0 次
接收感谢: 0 次
这个修正有点费事,但是对于我它能在好几种情况下正常工作,如果你碰到类似的情况,希望对你有所帮助:
i)如果你能在其它的程序里听到声音(比如:媒体播放器,电影等等),你不需要这个how to...因为有更多的帖子告诉你怎么让程序的声音能正常工作,这个帖子是告诉你如何在其它程序有声音的情况下让系统(事件)能够发出声音。

ii)这是一个测试过的使用ALSA作为你的所有的声音服务器的设置...如果你不想在设ALSA作为你的声音服务器后重启可以先运行‘sudo killadd esd’。(你可以把ALSA作为你的声音服务器通过 系统>首选项>多媒体系统选择器-把输入输出都设成ALSA)。
1)点击 系统>首选项>音效
2)不要选“启用音效服务器”
3)退出 Gnome
4)重新登录到 Gnome
5)再定位到 系统>首选项>音效
6)选择 “启用音效服务器”
7)测试,如果返回的信息正常你的系统声音就能正常工作了。

如果只是通过点击‘启用音效服务器’,并不能真的打开它。上述内容能修正我在很多情况下碰到的问题。

在KDE(kubuntu)下相同的效果的修正办法:

1)点击 控制中心
2)选上 ‘声音和多媒体’
3)选上 ‘系统通知’
4)点击 ‘播放器设置’按钮
5)设置 ‘使用外部播放器程序’并且方式是‘自动装入’
6)在所有的窗口点击 ‘确定’
7)测试声音(我的情况是听到断断续续的声音而且声音被切断了一样)
8)如果你听到了像步骤7一样的声音则继续下面的步骤
9)重复步骤 3-4
10)选择 ‘使用KDE声音系统’
11)点两次确定然后再测试(到这里时我的KDE环境里的声音已经全部能够工作正常了)

如果这个办法可行请让我知道。


_________________
生命不息,灌水不止,我师父是白娘子.另热烈庆祝本人blog访问量突破2w大关.
被高手bs,向小白显摆.


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-05-01 15:29 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10110
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 127
http://www.ubuntu.org.cn/docs/UserDocum ... ument_view


_________________
当净其意如虚空,远离妄想及诸取,令心所向皆无碍


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-07-31 22:32 
头像

注册: 2005-07-02 14:41
帖子: 4133
系统: Ubuntu 14.04 (Kylin)
送出感谢: 53
接收感谢: 11
我猜这个过时了


_________________
https://weakish.github.io


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译