当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 我可以直接从Debian升级到Ubuntu吗?
帖子发表于 : 2005-03-31 21:35 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10110
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 127
Yes, you can upgrade directly from Debian Woody to Ubuntu 4.10 (Warty Warthog). See http://www.ubuntulinux.org/wiki/WartyUpgradeNotes for notes and caveats about the upgrade process.

WartyUpgradeNotes

* Send this page to somebody
* Print this page

last edited 2 days ago by Matt Zimmerman

This page is a place to collect notes about additional actions which need to be performed for an optimal upgrade to Warty.

See also: HoaryUpgradeNotes, https://www.ubuntulinux.org/support/doc ... rade-sarge
Upgrading From WartyWarthog pre-releases

1.

Add initial user to scanner group:

sudo adduser $(getent passwd 1000 | cut -d: -f1) scanner

Upgrading From Debian

1.

Switch your /etc/apt/sources.list to the ubuntu servers:

deb http://archive.ubuntu.com/ubuntu/ warty main restricted universe
deb-src http://archive.ubuntu.com/ubuntu/ warty main restricted universe

deb http://security.ubuntu.com/ubuntu/ warty-security main restricted
deb-src http://security.ubuntu.com/ubuntu/ warty-security main restricted

2.

Add desktop users to standard groups:

# for group in adm audio cdrom dialout floppy video lpadmin plugdev scanner; do
adduser $(getent passwd 1000 | cut -d: -f1) $group
done

*

This $(...) construction looks scary, but it just determines the login name of the user who installed Ubuntu. You can replace the whole $(...) with the login name, if you are more comfortable with this. Also, repeat the process for all users who shall get access to local peripheral devices (scanners, CD-ROMs?, etc.)
3.

Set up the standard sudo configuration, if desired:

# firstuser=$(getent passwd 1000 | cut -d: -f1); echo "$firstuser ALL=(ALL) ALL" >> /etc/sudoers

*

This is necessary in order to run system configuration applications from the desktop.
4.

Upgrade from unsupported packages to their supported counterparts:
*

apache is superseded by apache2
*

php4 is superseded by libapache2-mod-php4
*

dhcp-client and dhcp-server are superseded by dhcp3-client and dhcp3-server
*

exim is superseded by postfix
5.

Add modules to /etc/modules if necessary
*

See eg https://bugzilla.ubuntu.com/show_bug.cgi?id=1763 . I had to add ide-cd and psmouse to get my cd and synaptics touchpad working.

All Upgrades

1.

Install ubuntu-base and ubuntu-desktop to obtain updated standard desktop package selection:

sudo apt-get install ubuntu-base ubuntu-desktop

*

NOTE: (only applicable to Debian upgrades) this will install udev, which will cause your system to manage /dev with udev, rather than with devfs or statically. This may require manual adjustments on your part, particularly if you have created custom device nodes or symlinks. It would be nice if there were a UdevMigration? document.
2.

Upgrade to latest Ubuntu kernel:

sudo apt-get install linux-686

*

Install linux-<arch> metapackage to receive the latest kernel and automatic kernel upgrades. Replace linux-686 as follows:
o

i386 systems should use linux-386, linux-k7, linux-k7-smp, linux-686 or linux-686-smp
o

powerpc systems should use linux-powerpc
o

amd64 systems should use linux-amd64-generic, linux-amd64-k8, linux-amd64-k8-smp or linux-amd64-xeon

http://www.ubuntulinux.org/support/docu ... rade-woody
http://www.ubuntulinux.org/wiki/WartyUpgradeNotes


最后由 oneleaf 编辑于 2005-04-13 23:33,总共编辑了 1 次


_________________
评价: 3.85% auv1107
 
页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-04-13 22:47 

注册: 2005-04-13 20:51
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
这是我第一次翻译
翻译的不正确之处和不好之处还请指正!
:)




当然,你能从Debian Woody直接升级到Ubuntu 4.10 (Warty Warthog)。
可以察看 http://www.ubuntulinux.org/wiki/WartyUpgradeNotes
获得升级过程的信息

也可以察看Hoary的升级信息

https://www.ubuntulinux.org/support/doc ... rade-sarge


如果你是从WartyWarthog pre-releases升级则第一步是执行下面这一步:

1.


将initial user加到scanner group:

#sudo adduser $(getent passwd 1000 | cut -d: -f1) scanner


如果你是从 Debian升级则第一步是执行下面这一步:

1.


将ubuntu的服务器加入到你的/etc/apt/sources.list :

deb http://archive.ubuntu.com/ubuntu/ warty main restricted universe
deb-src http://archive.ubuntu.com/ubuntu/ warty main restricted universe

deb http://security.ubuntu.com/ubuntu/ warty-security main restricted
deb-src http://security.ubuntu.com/ubuntu/ warty-security main restricted

2. 第二步

将desktop users加到standard groups,命令如下:

# for group in adm audio cdrom dialout floppy video lpadmin plugdev scanner; do
adduser $(getent passwd 1000 | cut -d: -f1) $group
done


*这个 “$(...)” 语句让人觉得莫名其妙,但它只是用来确定Ubuntu的安装者的登陆用户名。如果你不习惯的话,你可以用你的登陆用户名来代替整个“$(...)”。同时,你也要重复条语句将所有用到这些外围设备(如:扫描仪、CD-ROMs等)的用户添加到这些groups。

3. 第三步

设置standard sudo配置,如果要求的话,命令如下:

# firstuser=$(getent passwd 1000 | cut -d: -f1); echo "$firstuser ALL=(ALL) ALL" >> /etc/sudoers


*为了能在桌面运行系统设置程序这一步是必须的。

4. 第四步

将不支持的packages升级到被支持的packages:

*
如:apache被apache2 取代
php4被libapache2-mod-php4 取代
dhcp-client和dhcp-server分别被dhcp3-client 和 dhcp3-server 取代
exim被postfix取代


5. 第五步


将必需的modules添加到/etc/modules

*
可以察看https://bugzilla.ubuntu.com/show_bug.cgi?id=1763
我不得不添加ide-cd和psmouse的modules,使我的cd和synaptics touchpad能够运行

下面的步骤是必须执行的

1.

安装ubuntu-base 和 ubuntu-desktop来获得经过更新的standard desktop package:


#sudo apt-get install ubuntu-base ubuntu-desktop

*
注意:(这只是用于Debian的升级)这个命令将会安装udev,这将会使你的系统通过udev来管理/dev,而不是通过devfs管理或者是静态的管理。这需要进行手动的调整,特别是你创建过自己的device nodes 或者symlinks。


2.


升级到最新的Ubuntu kernel:

#sudo apt-get install linux-686

*

安装 linux-<arch> metapackage来获得最新的kernel和kernel的升级。
根据以下情况来代替上面命令中的linux-686:

*
i386 systems:用inux-386, linux-k7, linux-k7-smp, linux-686 or linux-686-smp

powerpc systems: 用linux-powerpc

amd64 systems: 用 linux-amd64-generic, linux-amd64-k8, linux-amd64-k8-smp or linux-amd64-xeon


http://www.ubuntulinux.org/support/docu ... rade-woody
http://www.ubuntulinux.org/wiki/WartyUpgradeNotes


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-04-13 23:38 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10110
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 127
http://www.ubuntu.org.cn/docs/folder.20 ... ument_view


_________________
当净其意如虚空,远离妄想及诸取,令心所向皆无碍


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-08-01 4:33 
头像

注册: 2005-07-02 14:41
帖子: 4133
系统: Ubuntu 14.04 (Kylin)
送出感谢: 53
接收感谢: 11
应该已经移到wiki上了


_________________
https://weakish.github.io


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译