当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 受限制的格式
帖子发表于 : 2005-05-22 22:22 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10116
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 128
Disclaimer

Packages distributed in officious repositories are not supported by Debian, and probably not by Ubuntu either. Please don't file bugs caused by the use of third party pacakges. Thanks.
Purpose

This article describes how to add support to a Ubuntu system for (1) non-Free multimedia formats and (2) Java programs. It includes information on installing required packages for the following media formats: Macromedia Flash, MP3, AAC, WMA, DVD, Divx/Xvid, MPEG-4, and Realmedia (Realplayer). Information on Windows Codecs for additional proprietary formats is also included.

PLEASE READ SECTIONS 1, 2, and 3 regardless of what you are looking for.

Section 1 describes why non-Free formats are not included in the Ubuntu installation, Section 2 describes which software repositories need to be added to the Synaptic Package Manager so that you can install the formats yourself, and Section 3 explains how to change sound settings to fix a common issue w/third party plugins on Ubuntu.
Contents:

1.

Overview
2.

How to add Repositories
3.

Sound and third party software
4.

Java
5.

Macromedia Flash
6.

MP3
7.

AAC and iTunes Music Store
8.

DVD
9.

DivX / XviD, WMA, and miscellaneous proprietary formats
10.

Real Player

1. Overview

As noted in the Ubuntu FAQ, support for some popular formats is not included in the Ubuntu distribution because there are legal restrictions on their distribution or usage. While we make no effort to restrict the choice of users to use such formats, we prefer to support Free software and Free formats. This page is intended as a central resource for information about dealing with non-Free formats and tools - including reasons for non-inclusion, alternative formats or implementations, and, as a last resort, information on using non-Free formats and tools.
2. How to add Repositories

Some of the following fixes involve adding repositories. For this reason instructions for adding repositories are here. Instructions on how to add these repositories can be found in the AddingRepositoriesHowto: http://www.ubuntulinux.org/wiki/AddingR ... riesHowto/
2.1 UNIVERSE/MULTIVERSE

To add these sources using Synaptic, click the Settings-Repositories menu item. You should then see a list of package sources in use on your system.
If you are using Hoary

If you see a source called Ubuntu 5.04 "Hoary Hedgehog", select that one and click the Edit button. Then, on the "Sections" line, there will be a list of repositories. Finally, add the names of the sources (universe and/or multiverse - but possibly including main/restricted if you haven't added these yet) you want to the end of this line and press OK.

If you don't see a source called Ubuntu 5.04 "Hoary Hedgehog", click the Add button. Select Ubuntu 5.04 "Hoary Hedgehog" from the drop-down list, check the repositories you want (universe and/or multiverse - but possibly including main/restricted if you haven't added these yet), and press OK. You should now be set to use Universe and/or Multiverse - just update your package lists by clicking "Reload" in Synaptic and the packages from the sources you selected will be available to install.
If you are using Warty

Add a repository using the following properties and then reload the package list:

URI: http://archive.ubuntu.com/ubuntu/
Distribution: warty
Section(s): (put the sections you want here, separated by spaces - i.e. main restricted universe multiverse)

2.2 MARILLAT:

Marillat is added in much the same way, with a few variations because of it being separate from Ubuntu.

Since Marillat is designed for Debian, sometimes Marillat packages get in the way of Ubuntu packages. To keep this from happening, add the following to /etc/apt/preferences (create this file if it doesn't exist):

Package: *
Pin: release a=unstable
Pin-Priority: 1

If you are using Hoary

Start by installing the Marillat gpg key per the instructions in AptAuthenticationInstructionsForHoary - this will prevent you from receiving authentication errors when you install packages from this source. Then, in the Synaptic repositories dialog box, click Add and then Custom. In the dialog box, type in the following APT line:

deb ftp://ftp.nerim.net/debian-marillat unstable main

Click OK and you should be good to go - just reload the package list.
If you are using Warty

Add a repository using the following properties and then reload the package list:

URI: ftp://ftp.nerim.net/debian-marillat/
Distribution: testing
Section(s): main

2.3 CRIMSUN:

(necessary for Warty only)

Add a repository using the following properties and then reload the package list:

URI: http://sh.nu/~crimsun/
Distribution: ./
Section(s): (leave blank)

3. Sound and third party software

Ubuntu uses a program called esd to allow multiple applications to access the sound card at one time. However, many third party applications not in Ubuntu main aren't designed to use esd to access the card. On some sound cards, this causes these applications to not produce sound. To work around this problem, esd must be configured to release the sound card when it is not using it. To do this, edit /etc/esound/esd.conf and change the line that begins with spawn_options to begin with default_options. Finally, change the -as 5 to -as 2.

Note: this problem only occurs on the Ubuntu Hoary release and newer. Kubuntu and Ubuntu Warty are not affected by this.
4. Java

Although the Java API itself is open, the only certified Linux implementations of Java with wide compatibility are derived from Sun's implementation. All of these implementations carry non-Free licensing terms.

The Kaffe project and the GNU Classpath project are working on Free implementations of Java, but they are not yet comparable to the Sun-based implementations in performance, completeness, or compatibility.

There are detailed instructions for installing Sun's Java available. Daniel Robitaille has instructions on installing IBM Java on Ubuntu x86.
5. Macromedia Flash

There is a free player for this ( GPLFlash?), however it does not support many modern Flash applications. Macromedia has a player that supports up-to-date Flash applications, but it is considered "non-free" and as such is not included in the main Ubuntu archive. However, it can be installed from multiverse (see below for details), or by visiting the official Macromedia Flash Player for Linux page and following their simple instructions.

Install (from MULTIVERSE) the following package:

*

flashplugin-nonfree

This will install Flash and the plugins needed to view it in Firefox and Mozilla.
6. MP3 and Windows Media Audio
6.1 MP3 Playback:

MP3 is patent-encumbered, for both encoding and decoding, these patents are being actively enforced.

Ogg Vorbis is a flexible and Free lossy audio codec with a proven track record. This format is now supported by some DVD player or some portable player (like usb key).

However, you can still play your MP3s with rhythmbox, amaroK or XMMS.

RhythmBox? is installed by default on an Ubuntu distribution. It's an Windows Media Player-like with supports to link with iPod and a library system.

For playing MP3s with Rhythmbox or amaroK, you must install the gstreamer0.8-mad package. This package is in the universe repository (see section 2 above).

For install XMMS (Winamp-like), you must install the xmms package. It's in the Hoary install cd. Note : you must choose the eSound output plugin in the options of XMMS (XMMS freeze if you use ALSA with Hoary).
6.2 MP3 Encoding:

For encode MP3s, you can use Sound Juicer (installed by default) with LAME. LAME is an MP3 encoder. Sound Juicer is a program which use gstreamer (the following installation should work with other programs which use gstreamer).

First, you must install the gstreamer0.8-lame package (available in the MARILLAT repository for Hoary).

Second, you install the lame package (available in the Hoary multiverse repository).

After that, you launch the command : gnome-audio-profiles-properties and you create a new profile (call it something like "MP3" or "LAME".

Then, edit this profile and set GStreamer? Pipeline to audio/x-raw-int,rate=44100,channels=2 ! lame name=enc.

Optionally, you can add bitrate=<some bitrate> to the end of this line if you want a specific bitrate other than the default of 128.

Finally, set File Extension to mp3, and click the Active checkbox and then OK.

Before the first use of Sound Juicer; launch the command : gst-register-0.8. Now, you should be able to rip MP3s.

For other programs (non GStreamer?), it is sufficient to install the "lame" package (MULTIVERSE repository). For example, grip (gnome cd ripping program) and kaudiocreator (KDE cd ripping program) works fine with just the "lame" package. Just set your ripper to use LAME and you should be ready to go.
7. AAC and iTunes Music Store
7.1 AAC Decoding

The default audio format used by Apple's iTunes and iPod is AAC. This is a variant of the MPEG standard, and as such has patent issues. However, you can listen to AAC files in rhythmbox or amaroK by installing gstreamer0.8-faad (from MARILLAT). Note that for this particular package, you will have to install it by doing "sudo apt-get -t unstable install gstreamer0.8-faad" at the command line to avoid version conflicts. You will need this for listening to any AAC file, including those bought from the iTunes Music Store (see below for more info on using the music store on Linux).
7.2 AAC Encoding:

FAAC can be used to encode AACs?, although this is somewhat experimental compared to MP3 encoding at this point.. For encoding programs which use gstreamer, there is a gstreamer plugin called gstreamer0.8-faac (install from MARILLAT). Again, you will have to install this by doing "sudo apt-get -t unstable install gstreamer0.8-faac" at the command line to avoid version conflicts. However, this currently is problematic, and does not produce usable AAC files, though this may change in the future.

For other programs, you may be able to utilize FAAC directly to encode to AACs? - just install the "faac" package. You can make iPod-compatible AACs? this way, but this requires some additional configuration in your CD ripping utility.
7.3 iTunes Music Store

Apple's iTunes Music Store sells music online with a large selection of artists. Songs are in 128K AAC format, and cost varies by country. Apple only has Mac and Windows clients, but it also can be used on Linux. There are two different methods by which this can be done.

First of all, you can use CodeWeavers? CrossOver? Office (available at http://www.codeweavers.com) to install the Windows version of iTunes on Ubuntu. This will allow you to buy iTunes songs on Linux and listen to them. However, the main caveats of this approach is that 1) it costs money 2) it is not a fully Linux-native solution. Also, if you purchase any songs on iTunes using CrossOver? Office and want to burn them to CD or transfer to an iPod, or if you have purchased songs on a Windows/Mac machine and want to either listen to or burn them, you will have to use hymn (available in MARILLAT). Hymn is a free program which will enable iTunes songs to be played by anything that supports AAC format (or MP3/OGG if you convert them). Note that this may be legally questionable in your jurisdiction, because it gets around Apple's DRM included in iTunes songs.

As an alternative to using CrossOver?, there is a new, Free program called PyMusique? which allows basic usage of the iTunes Music Store on Linux. This works better than using iTunes on CrossOver?, but PyMusique? has less features than the official iTunes client at this point and may be in violation of the iTunes Music Store terms of service. To use this on Ubuntu, first install gstreamer0.8-faad (from MARILLAT) and libmcrypt4 (from UNIVERSE). Then, go to http://fuware.nanocrew.net/pymusique/ or a mirror (google "pymusique 0.4" for mirrors) and download the pymusique, python2.4-mcrypt, python2.4-vlc, and python2.4-mp4ff packages. Finally, install all the packages you downloaded from the above website. You can now launch PyMusique? from the Applications-Internet menu, and purchase songs (although you may have to restart your system for this to work).
8. DVD-Video

Non encrypted DVDs should play, however be aware that mpeg2 is somewhat patent encumbered and is not shipped on the CDs (though is in 'main')

Full DVD-Video support requires support of the Content Scrambling System (CSS). Though the encryption is weak, using libdvdcss to avoid this is classed as a 'circumvention device' and is such illegal in the United States and some other Jurisdictions.

However, as you can read at the DeCSS? information page, in most European countries, DVD backup is legal. In fact, you can backup anything that you own in, eg. Norway, Sweden, etc.

If you do not require compatibility with a DVD player, consider encoding your videos in Ogg Theora.

if you would like full DVD support, you can install the following packages:

libdvdcss2 (from MARILLAT)
xine-ui (from UNIVERSE)

After installing these packages, you can use Xine (on the Applications-Sound & Video menu) to play DVDs?.

If DVD playback is jerky or you notice optical data transfer (i.e burning a CD/DVD) is slower than it should be then you need to enable DMA transfer for that drive by editing the file:

/etc/hdparm.conf

You will need to know the device name of your DVD drive (e.g /dev/hdc) and then enable DMA with the 'dma = on' command. Then, either reboot or run the following command:

sudo /sbin/hdparm -d 1 /dev/hdc

(where your DVD drive is hdc)

You should now be able to play DVD's smoothly with the correct software.
9. DivX / XviD, other MPEG-4 variants, and miscellaneous proprietary video formats

These formats are patent-encumbered. If you do not require compatibility with MPEG-4 players, consider Ogg Theora

**Note:** these are unsupported and may be illegal in your jurisdiction, we in no way endorse the use of these packages.
9.1 Mplayer:

MPlayer? is a movie player for Linux (runs on many other Unices, and non-x86 CPUs?, see the documentation). It plays most MPEG, VOB, AVI, Ogg/OGM, VIVO, ASF/WMA/WMV, QT/MOV/MP4, FLI, RM, NuppelVideo?, YUV4MPEG, FILM, RoQ?, PVA files, supported by many native, XAnim?, and Win32 DLL codecs. You can watch VideoCD?, SVCD, DVD, 3ivx, DivX? 3/4/5 and even WMV movies, too (without the avifile library).

Homepage.

There are several versions of mplayer available. The following repositories contain mplayer packages:

CRIMSUN, MULTIVERSE, MARILLAT

*

For Warty, you will need to add the MARILLAT, CRIMSUN, and MULTIVERSE repositories. For Hoary, you will need to add the MARILLAT and MULTIVERSE repositories.

Choose between the various packages as follows:

Depending on your cpu: 386s and 486s should use mplayer-386; Intel Pentiums and newer should use mplayer-586; AMD Athlons and newer may use mplayer-k6 (find your cpu using "uname -m" in a Terminal).

The following packages may optionally be installed:

*

mplayer-fonts mozilla-mplayer mplayer-doc (optional)

The "mixer" setting may need to be changed to avoid errors during playback. Right click on the MPlayer? screen, select Preferences and then select the Audio tab. Select OSS (or your mixer if you use a different one) from the types and OK everything (accepting the default mixer location etc).
9.2 Windows Codecs:

These codecs are extremely useful. The following formats are contained therein:

*

ATI VCR-2 video codec.
*

Cinepak video codec
*

DivX? ;-) video codec, ver. 3.11
*

DivX? ;-) video codec, ver. 4.x
*

Indeo Video 3.2/4.1/5.0/4.1 quick/5.0 quick codecs.
*

Intel 263 video codec.
*

Microsoft MPEG-4 video codec, beta version 3.0.0.2700
*

Morgan Multimedia Motion JPEG video codec.
*

QuickTime?
*

RealAudio?
*

RealVideo? 8
*

RealVideo? 9
*

Windows Media Video 9
*

And more

Install:

*

w32codecs (MARILLAT)

For information on how to add these codecs for use with totem, please see this page: AddingCodecsToTotemHowTo
9.3. Other codecs

Not all mpgs are created equal. If you are getting sound but no videe with some mpgs, you probably need the ffmpeg libraries.

gstreamer0.8-ffmpeg (from UNIVERSE)

10. Real Player

Realplayer is good for listening to BBC Radio, among otherthings. You are required to manually download Realplayer from here. Once it is downloaded, move it to your home folder (if its not there already), then open up a terminal and type

chmod u+x RealPlayer10GOLD.bin
sudo ./RealPlayer10GOLD.bin

You are then prompted for an installation directory. I chose

/opt/realplayer

Answer yes to creating symbolic links, and let it use the default directory.

Realplayer should now be in your Gnome menu, under the Sound&Video section.

To install the firefox plugins, run realplayer from the gnome menu. You will be asked to agree to a licence (this is free as in beer, not free as in speech). The you will be asked if you want to check for updates and configure mozilla helpers, check both and click ok. Now head over to http://www.囗囗囗囗囗囗囗囗囗/radio/ and you should be able to listen.
10.1 Real Player for PPC

To install Realplayer on PPC, download the Experimental build installer from Helix

make the file executable (chmod 770) and execute (./realplayer-xxxxxx.bin)

Answer the questions and Realplayer should work by executing /path-to-Realplayer-directory/realplayer. To make life easier add an alias in your .bashrc (ie alias = '/path-to-Realplayer-directory/./realplayer&') or create a soft link to /usr/local/bin (sudo ln -s /path-to-Realplayer-directory/realplayer /usr/local/bin/).
10.2 Real Player issues on Hoary

1. If realplayer doesn't immediately work, go to the realplayer install directory and remove the swf plugins. For some reason, it works perfectly most of the time after you do this. If you still have problems, it may be the way that your soundcard handles esd. Go on to 2. (Keith Bassett)

I don't know if this is what was supposed to be part 2, but Google dug up a thread at the Helix community forum, and this fixed the problem for me. In /etc/esound/esd.conf, change the auto_spawn item from its default setting of 0 to 1. (MartinManey)


_________________
当净其意如虚空,远离妄想及诸取,令心所向皆无碍


最后由 oneleaf 编辑于 2005-06-01 9:44,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : 受限制的格式
帖子发表于 : 2005-05-28 23:57 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
=======首次翻译linux文章,语句可能有不通,请提出,予以更正!=========


免责

非官方软件库发布的软件包不被Debian支持,大概也不被Ubuntu支持。请不要提交由使用第三方软件包所致的Bugs。谢谢。



目的

这篇文章叙述如何使Ubuntu系统支持:
(1)非自由多媒体格式;(2)Java程序。包括安装以下媒体格式所需软件包的信息:Macromedia Flash, MP3, AAC, WMA, DVD, Divx/Xvid, MPEG-4, and Realmedia (Realplayer)。也包括Windows编译码器附加的专利格式的信息。

不管你想要寻找什么,都请你阅读第1,2和3部分。


第1部分描述为什么非自由格式不包含在Ubuntu的安装中,第2部分描述哪些软件库需要加到新立得软件包管理器中,以便你能够自己安装格式,第3部分解释怎样通过改变声音设定,在Ubuntu上安装一个公开发布的第三方插件。


内容:
1.概述
2.怎么添加软件库
3.声音和第三方软件
4.Java
5.Macromedia Flash
6.MP3
7.AAC and iTunes Music Store
8.DVD
9.DivX / XviD, WMA,和各种专利格式
10.Real Player

1.概述
在Ubuntu常见问题已经注明,由于发布和使用上的法律限制,Ubuntu发行版不包括对一些流行格式的支持。我们乐于支持自由软件和自由格式,但我们也不去限制用户选择使用这样的格式。这一页是有关处理非自由格式和工具信息的集中资源,它包括不包含的原因,供选择的格式或者实施,最后是关于使用非自由格式和工具的信息。


2.怎么添加软件库
以下是一些添加软件库前的准备。为此,用到添加软件库的指令。关于怎样添加软件库的指令可以在AddingRepositoriesHowto找到:
http://www.ubuntulinux.org/wiki/AddingR ... riesHowto/


2.1"universe" 组件/"multiverse" 组件
用“新立得”去添加这些源,点击菜单中的“设置”---“软件库”,你会看到在你系统中使用着的软件源列表。



如果你正在使用Hoary

如果你看到一个名叫Ubuntu 5.04 "Hoary Hedgehog"的源,选中并点击“编辑”按钮。然后,在“节”行会有软件源的列表。最后,添加源的名字(universe 和/或 multiverse──但可能包括main/restricted,假如你还没添加)。完成这行,按“确定”


如果你没看到叫Ubuntu 5.04 "Hoary Hedgehog"的源,点击“添加”按钮,从下拉菜单选择Ubuntu 5.04 "Hoary Hedgehog",核对你想要的软件库(universe 和/或 multiverse──但可能包括main/restricted,假如你还没添加),然后“确定”。你应该立即想要使用Universe 和/或 Multiverse──只要在新立得点击“刷新”,就更新了你的软件包列表,而且你所选择源里的软件包都可以安装了。



如果你正在使用Warty

使用以下properties,然后刷新软件包列表:
URI:http://archive.ubuntu.com/ubuntu/
发行版:Warty
节:(输入你要的节,用空格分隔。如:main restricted universe multiverse)



2.2MARILLAT:

Marillat 添加方法几乎一样,有一点点变动,这是为了与Ubuntu区分。因为Marillat是为Debian设计的,有时Marillat软件包会与Ubuntu软件包冲突。为了避免发生这种情况,添加以下内容到 /etc/apt/preferences (如果没此文件就建立一个):
代码:
Package: *
Pin: release a=unstable
Pin-Priority: 1




2.3Crimsun:
(仅Warty需要)

使用下面的properties添加一个软件库,然后刷新刷新软件包列表:
URI: http://sh.nu/~crimsun/
发行版: ./
节(s): (留空)


3. 声音和第三方软件
Ubuntu通过一个名叫esd的程序来使几个应用程序同时访问声卡。然而,许多不包含在Ubuntu main组件里的第三方程序没被设计成使用esd来访问声卡。这样会导致这些应用程序在一些声卡无法发出声音。为了解决此问题,必须设置esd,使它不在使用声卡时释放声卡。为此,编辑 /etc/esound/esd.conf ,把由spawn_options开头这一行改为由default_options开头。最后,把 -as 5改为 -as 2。

注意:这问题只出现在Ubuntu Hoary以及更新版本。Kubuntu和Ubuntu Warty不受此问题影响。


4. Java
虽然Java应用编程接口本身是开放的,但唯一被证明了的能广泛兼容Java的linux实施,是源自Sun的实施。全部这些实施意味着非自由的许可条款。

Kaffe计划和GNU Classpath计划正致力于Java的自由实施,但在性能、完整性或兼容性上仍比不上以Sun为基础的实施。

这里可得到安装Sun's Java的详细用法说明。Daniel Robitaille有在Ubuntu x86安装IBM Java的用法说明。


5. Macromedia Flash
已经有一个这方面的自由播放器(GPLFlash),但是,它不支持许多现代的Flash应用。Macromedia拥有的播放器支持更新到最新的Flash应用,但考虑到它是“非自由”的,所以没包含在main Ubuntu档案中。可是,它可以从multiverse组件安装(更详细的请看下面),或者访问官方的Macromedia Flash Player for Linux页面,然后按他们简单的指示去做。

安装(从multiverse组件)以下软件包:
*
flashplugin-nonfree

这将安装Flash和用Firefox和Mozilla观看Flash所需的插件。


6. MP3 and Windows Media Audio

6.1 MP3 重放:
MP3的编码和解码都有专利限制,这些专利是积极强制的。

Ogg Vorbis是一个灵活、自由、值得信赖的有损压缩音频格式。现在,一些DVD播放器或者便携式播放器(如usb key)都支持这格式。

然而,你仍然可以用rhythmbox、amaroK或XMMS播放你的MP3。



RhythmBox在Ubuntu发行版中是默认安装的。它类似Windows Media Player,支持连接iPod和库系统。

想要用Rhythmbox或amaroK播放MP3,你必须安装gstreamer0.8-mad软件包。这软件包在universe库里(请看上面的第2部分)。

想要安装XMMS(类似于Winamp),你必须安装xmms软件包。它在Hoary安装CD里。注意:你必须在XMMS的选项中选择eSound输出插件(如果你在Hoary中使用ALSA,XMMS会失去响应)。



6.2 MP3编码:
想要编码MP3,你可以使用Sound Juicer(默认已经安装)和LAME。LAME是一种MP3编码器。Sound Juicer是一个使用gstreamer的程序(接下来的安装将对其他使用gstreamer的程序起作用)。

第一,你要安装gstreamer0.8-lame软件包(在Hoary的MARILLAT软件库可以得到)。

第二,你得安装lame软件包(在Hoary的multiverse软件库可以得到)。


之后,你开始操作:gnome-audio-profiles-properties,并且建立一个新的profile(命名为如“MP3”或“LAME”)。

然后,编辑这个prfile,并设置GStreamer Pipeline 为audio/x-raw-int,rate=44100,channels=2 ! lame name=enc。


随意地,除了默认的128,如果你想要一个特别的码率,你可以添加 bitrate=<某一 bitrate> 到这一行的最后。

最后,设定文件扩展名为mp3,点击激活选项,然后确定。



在首次使用Sound Juicer,执行命令:gst-register-0.8 现在,你应该可以提取MP3了。

对于其他程序(不是GStreamer),安装“lame”软件包(MULTIVERSE软件库)已经足够了。例如,只需要这“lame”软件包,grip(gnome的CD提取程序)和kaudiocreator(KDE CD提取程序)就可以很好地工作。仅仅设定你的提取工具使用LAME,你就一切就绪了。



7. AAC and iTunes Music Store

7.1 AAC 解码
Apple的iTunes和iPod默认使用的音频格式是AAC。它是MPEG规范的一个变体,同样地有发行专利。然而,通过安装gstreamer0.8-faad(来自MARILLAT)你可以使用rhythmbox或amaroK来听AAC。注意,对于这一特殊的软件包,为了避免版本冲突,你将必须在命令行输入"sudo apt-get -t unstable install gstreamer0.8-faad"来安装。为了欣赏任何AAC文件,包括从iTunes Music Store(更多在linux上使用music store的信息请看下面)购买的,你将需要以下所述的。


7.2 AAC 编码:
FACC可以用来编码AACs,尽管在这一点上与MP3的编码相比有点实验性的。对于使用gstreamer的编码程序,这里有一个名叫gstreamer0.8-faac的gstreamer插件(从MARILLAT安装)。再一次,为了避免版本冲突,你只能通过在命令行输入"sudo apt-get -t unstable install gstreamer0.8-faac"来安装。然而,目前这是有问题的,而且不能制出可用的AAC文件,尽管这在将来可能会改变。

而另外的程序,你也许可以利用FACC直接编码成AAC——仅仅安装“faac”软件包。用这方法,你可以制作与iPod兼容的AAC,但需要在你的CD抓轨工具中作一些额外的配置。



7.3 iTunes Music Store
苹果公司的iTunes Music Store通过一个大型的艺术家选集在线销售音乐。歌曲格式是128K AAC,而且价钱因国家而异。苹果只有Mac和Windows用户,但它同样可以在linux上使用。这里有两种不同的方法来实现。


首先,你可以利用CodeWeavers CrossOver Office (可以从http://www.codeweavers.com 得到)在Ubuntu上安装Windows版本的iTunes。这样就允许你在linux下购买和欣赏iTunes歌曲。然而,这方法的主要告诫有:1)花费金钱 2)这不是一个完全linux赋有的解决方法。如果你在使用CrossOver Office的iPod上购买任何歌曲和想要刻录成CD或传送到一个iPod,或者如果你在Windows/Mac机器上购买了歌曲并同样想欣赏或刻录,你都不得不使用hymn(可在MARILLAT获得)。Hymn是一个自由程序,它可使iTunes歌曲在任何支持AAC格式(或MP3/OGG,假如你转换了)的东西上播放。注意,在你的权限上可能存在法律问题,因为它得到苹果的DRM(Digital Radiometer 数字辐射计)包含在iTunes歌曲内。



除了使用CrossOver,这里有一个全新的自由的程序叫PyMusique,它满足在linux上iTunes Music Store的基本应用。这比在CrossOver上使用iTunes工作得更好。但在这一点上,PyMusique拥有的特征要比官方iTunes客户少,并且也许会违反iTunes Music Store的服务条款。为了在Ubuntu上使用它,首先安装gstreamer0.8-faad(来自MARILLAT)和libmcrypt4(来自UNIVERSE)。然后来到http://fuware.nanocrew.net/pymusique/ or a mirror (google搜索 "pymusique 0.4" for mirrors),下载pymusique,python2.4-mcrypt, python2.4-vlc 和 python2.4-mp4ff 软件包。最后,安装所有从上面网站下载的软件包。你现在可以从“应用程序──Internet”菜单上运行PyMusique,和购买歌曲(尽管你也许应该重启你的系统来让它工作)。



8.DVD视频

非加密DVD应该可以播放,可是意识到mpeg2多少受专利所累,它没有纳入CDs(尽管它在‘main’中)。

完全DVD视频支持需要Content Scrambling System (CSS)的支持。虽然加密显得无力,但使用libdvdcss来防止已经被划分为一个“欺骗装置”,而这在美国和一些管辖区是不合法的。

可是,在大多数欧洲国家,如同你能阅读DeCSS信息页面一样,DVD备份是合法的。事实上,在比如挪威,瑞典等等,你可以备份任何你自己的东西。



如果你不需要一个DVD播放器的兼容性,可考虑用Ogg Theora来编码你的视频。

如果你喜欢完全的DVD支持,你可以安装以下的软件包:

libdvdcss2 (来自 MARILLAT)
xine-ui (来自 UNIVERSE)

安装完这些软件包后,你可以使用Xine(在菜单“应用程序──影音”)去播放DVD。



如果DVD重放不平稳,或你留意到光学数据转移(例如刻录CD/DVD)时比正常的慢,那么你需要打开那驱动器的DMA传递。编辑文件:

/etc/hdparm.conf

你需要知道你的DVD驱动器的设备名称(例如/dev/hdc),然后使用'dma = on'打开DMA。然后要么重启,要么运行以下命令:
代码:
sudo /sbin/hdparm -d 1 /dev/hdc

(你的DVD驱动器是hdc)

你现在应该可以使用合适的软件,流畅地播放DVD了。



9. DivX / XviD, 其他 MPEG-4 变体, 和各种专利的视频格式

这些格式是有专利限制的。如果你不需要MPEG-4播放器的兼容性,考虑Ogg Theora。

**注意:**这些是未得到支持的,并且也许在你的管辖区是违法的。我们决不支持使用这些软件包。

9.1 Mplayer:
Mplayer是一个linux下的电影播放器(可以在许多其他Unices和非x86 CPU上运行,请阅读文档)。它能播放大多数MPEG,VOB, AVI, Ogg/OGM, VIVO, ASF/WMA/WMV, QT/MOV/MP4, FLI, RM, Nuppel视频, YUV4MPEG, FILM, RoQ, PVA文件,被许多native, XAnim, and Win32 DLL codecs所支持。你可以观看VideoCD,SVCD, DVD, 3ivx, DivX 3/4/5,甚至WMV影片(缺少avi文件的程序库)



主页

这里可得到几个版本的mplayer。以下的软件库包含mplayer包:

CRIMSUN, MULTIVERSE, MARILLAT


*
对于Warty,你将要添加MARILLAT, CRIMSUN,和MULTIVERSE的软件库。对于Hoary,你将要添加MARILLAT和 MULTIVERSE软件库。



依据以下内容在多种软件包作出选择:

根据你的CPU:386和 486的 应该使用 mplayer-386; Intel奔腾以及更新的应该使用mplayer-586;AMD Athlon以及更新的应该使用mplayer-k6(在终端使用"uname -m"来查看你的cpu)。

以下的软件包可选择安装:

*
mplayer-fonts mozilla-mplayer mplayer-doc (可选择的)

"混音器"的设置或许需要改变,以免在重放时出错。在MPlayer窗口右击,选择“参数选择(Preferences)”,然后选择“音频(Audio)”标签。在类型(types)选择OSS(或你自己的混音器,如果你想用不同的),一直确定下去(接受默认混音器设置等等)。



9.2 Windows 编码译码器

这些编码译码器非常有用,以下格式被包含其中:
*

ATI VCR-2 video codec.
*

Cinepak video codec
*

DivX? Wink video codec, ver. 3.11
*

DivX? Wink video codec, ver. 4.x
*

Indeo Video 3.2/4.1/5.0/4.1 quick/5.0 quick codecs.
*

Intel 263 video codec.
*

Microsoft MPEG-4 video codec, beta version 3.0.0.2700
*

Morgan Multimedia Motion JPEG video codec.
*

QuickTime?
*

RealAudio?
*

RealVideo? 8
*

RealVideo? 9
*

Windows Media Video 9
*
以及更多

安装:
*
w32codecs (MARILLAT)
有关如何添加这些编码译码器来供totem使用的信息,请阅读这页面:AddingCodecsToTotemHowTo



9.3. 其它编码译码器
不是所有的mpgs都被合适地建立。如果你一些mpgs有声音但没影像,你或许需要ffmpeg库:
gstreamer0.8-ffmpeg (来自 UNIVERSE)



10. Real Player
Realplayer尤其适用于收听BBC广播。你必须手动从这下载Realplayer。一下载完,把它移动到你的主文件夹(如果它不是已经在那),然后打开一个终端输入:
代码:
chmod u+x RealPlayer10GOLD.bin
sudo ./RealPlayer10GOLD.bin


然后你将被提示选择一个安装目录。我选择了/opt/realplayer
回答yes,建立一个符号链接,并让它使用默认目录。

Realplayer现在应该在你的Gnome菜单,在影音菜单下。



为了安装firefox插件,由gnome菜单运行realplayer。它将询问你同意协议(按照beer则自由,按照speech则非自由)。然后会询问你是否想检查更新和配置mozilla助手,两个都选中并确定。现在前往 http://www.囗囗囗囗囗囗囗囗囗/radio/ ,你应该能够收听了。

10.1 Real Player for PPC(POCKET PC)

为了在PPC安装Realplayer,从Helix下载Experimental build安装程序

使文件可执行(chmod 770),并执行(./realplayer-xxxxxx.bin)

Answer the questions and Realplayer should work by executing /path-to-Realplayer-directory/realplayer. To make life easier add an alias in your .bashrc (ie alias = '/path-to-Realplayer-directory/./realplayer&') or create a soft link to /usr/local/bin (sudo ln -s /path-to-Realplayer-directory/realplayer /usr/local/bin/).

回答那些问题,Realplayer应该通过执行/path-to-Realplayer-directory/realplayer来运行。为了使生活更简单,在你的 .bashrc 添加一个alias(例如 alias = '/path-to-Realplayer-directory/./realplayer&'),或者建立一个软链接到 /usr/local/bin (sudo ln -s /path-to-Realplayer-directory/realplayer /usr/local/bin/)


10.2 Real Player 发行于 Hoary
1.如果realplayer不能立即工作,前往realplayer安装目录,移走swf 插件。不知怎么回事,在你做了这个之后,大部分时间它都工作得极佳。如果你仍然有问题,让你的声卡处理esd也许是解决的方法。请前往2。(Keith Bassett)

我不知道这是否就是第2部分所认为的,但Google搜索,在Helix社区论坛发现一条线索,并且它为我解决了问题。在/etc/esound/esd.conf 里,把auto_spawn项中默认的0改为1。(MartinManey)

========定稿,也许有错,请更正=========================


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-06-01 9:44 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10116
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 128
http://www.ubuntu.org.cn/docs/UserDocum ... ument_view


_________________
当净其意如虚空,远离妄想及诸取,令心所向皆无碍


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-06-01 11:00 
头像

注册: 2005-04-10 16:54
帖子: 2625
地址: 温州大学
送出感谢: 0 次
接收感谢: 1
好东东呀!

我正好有个朋友送给我的iPod,还没拆封呢,就看到了这篇文章!
省了好多网上查找的时间,
多谢 多谢!!


_________________
我心无畏,源自于我心无知。
图片


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-06-01 11:02 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
firehare 写道:
好东东呀!

我正好有个朋友送给我的iPod,还没拆封呢,就看到了这篇文章!
省了好多网上查找的时间,
多谢 多谢!!


使用过程中,发现有什么地方文章是翻错的或意思搞偏了的,希望回贴指出。谢了。


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-07-31 18:36 
头像

注册: 2005-07-02 14:41
帖子: 4133
系统: Ubuntu 14.04 (Kylin)
送出感谢: 53
接收感谢: 11
firehare 写道:
好东东呀!

我正好有个朋友送给我的iPod,还没拆封呢,就看到了这篇文章!
省了好多网上查找的时间,
多谢 多谢!!


我的shuffle坏了,唉,才一年半啊


_________________
https://weakish.github.io


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译