当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 如何安装ATI/nvidia/SmartLink modem?
帖子发表于 : 2005-04-01 10:20 
论坛管理员

注册: 2005-03-27 0:06
帖子: 10111
系统: Ubuntu 12.04
送出感谢: 7
接收感谢: 128
Install the ATI (fglrx) Driver if any of these are true:

*

You know you own a "Radeon" card
*

When you first turn the computer on an ATI logo appears in the top left corner
*

You know your card model begins with "7", "8", "9", or "X".
*

cat /proc/pci reveals a card with "ATI" in it

Install the NVIDIA Driver if any of these are true:

*

You know you own a "Ge-Force" or a "Quadro" graphics card.
*

When you first turn the computer on it says something about NVIDIA in the top left of the screen.
*

You know your card model begins with "4", "FX", or "6".
*

cat /proc/pci reveals a card with "NVIDIA" in it

ATI (fglrx) Graphics Card

Note: Currently, ATI Drivers for AMD64 are only available in Hoary
If you use Warty (Ubuntu version 4.10)

1.

Install the following package for Warty:

sudo apt-get install fglrx-driver

2.

echo fglrx | sudo tee -a /etc/modules
*

This command won't have any effect until you reboot. To load the kernel module immediately, run sudo depmod -a ; sudo modprobe fglrx, but this will only work if you have already rebooted since upgrading the kernel. If it doesn't work, perform the next step (below) and then reboot.
3.

Edit /etc/X11/XF86Config-4 and change "ati" to "fglrx", perhaps with a command like:
*

sudo sed -i -e 's/"ati"/"fglrx"/'/etc/X11/XF86Config-4. Alternatively, just use your favourite text editor, or use sudo dpkg-reconfigure xserver-xfree86 and select "fglrx" instead of "ati".

For Hoary (Ubuntu version 5.04)

1.

Install the xorg-driver-fglrx package:

sudo apt-get install xorg-driver-fglrx

2.

echo fglrx | sudo tee -a /etc/modules
*

This command won't have any effect until you reboot. To load the kernel module immediately, run sudo depmod -a ; sudo modprobe fglrx, but this will only work if you have already rebooted since upgrading the kernel. If it doesn't work, perform the next step (below) and then reboot.
3.

Edit /etc/X11/xorg.conf and change "ati" to "fglrx", perhaps with a command like: sudo sed -i -e 's/"ati"/"fglrx"/' /etc/X11/xorg.conf. Alternatively, just use your favourite text editor, or use sudo dpkg-reconfigure xserver-xorg and select "fglrx" instead of "ati".

Notes

Note (optional): If you are going to compile 3d applications, you will want to install the fglrx-driver-dev package

Note (optional): You might want to install the fglrx-control package, which provides a control panel to configure graphics card options such as dual-head display (two monitors).

One also needs to move the nvidia module (/lib/modules/kernel_version/kernel/drivers/video/nvidia.ko) from the directory. Something was loading it and it was taking over the AGP port. This condition can be see by running fireglcontrol and seeing Mesa Indirect as the OpenGL? driver instead of the ATI driver. This results in a major reduction in speed when going throught the MESA drivers. (SL)

On my NFORCE2 board, I had to modify my /etc/X11/XF86config-4 to finally get rid of the '..MESA...' in the OpenGL? section of fireglcontrol. In the device section of the grafic card I added the following line:

*

Option "UseInternalAGPGART?" "no"

This option does not appear to work with other boards.

The needed nvidia_agp module was started automatically (I think hwscan is starting it). Use 'lsmod | grep "nvidia"' to check if it is there. (TAK)

EXTREMELY IMPORTANT : REBOOT!! (I had a hell of a time cursing my PC, got frustrated, turned it off, and the next day it worked perfectly after booting up)
NVIDIA Graphics Card

Note: requires linux-restricted modules >= 2.6.8.1.1-3

1.

sudo apt-get install nvidia-glx
2.

sudo nvidia-glx-config enable

Note: If you wish to use these drivers and run the XMMS music player, you should be aware of this bug

Note: You can get around this bug by installing libmik.

Note (optional): If you are going to compile 3d applications, you will want to install the nvidia-glx-dev package

Note (optional): the nvidia-settings package provides a control panel to configure graphics card options such as gamma correction.
Notes

Edit: That script worked for me perfectly, but keep sure to have the right version of linux-restricted-modules installed (it must match the version of the running kernel).

Edit: The above script worked perfectly on a fresh Warty install, from ISO dated Sep 15. No additional changes needed.(OM)

Edit: Here are notes on how I (WW) got the nvidia drivers to work.

1.

After I installed Ubuntu, the package linux-restricted-modules was already installed. I have version 2.6.8.1.0-2 installed, which does not appear to be >= 2.6.8.1.1-3, but it works.
2.

As above, run the command sudo apt-get install nvidia-glx (or use Synaptic to install it). This installs the "nvidia" driver.
3.

Run the command sudo dpkg-reconfigure xserver-xfree86. Select the nvidia driver in the first screen. Go through the rest of the screens, keeping all the defaults, until you get to the modules. Disable GLCore?. Also, the glx module should be enabled (and it probably already is). Finish the configuration by again choosing all the defaults. You have now updated /etc/X11/XF86Config-4.
4.

As root (i.e. with sudo), use your favorite editor to edit the file /etc/modules. Add a line that contains just the word "nvidia" (without the quotes). This will cause the nvidia module to be loaded the next time you reboot.
5.

To load the module now, enter the command sudo modprobe nvidia.
6.

Now all you have to do is restart X so that the changes take effect. (It might be a good idea to exit any other applications that you have running.) I could swear that I did this by just hitting ctrl-alt-backspace. This should stop X, then you'll get the nvidia splash screen, and then a new login screen. On the IRC channel, someone else said you must enter the command sudo /etc/init.d/gdm stop, and then sudo /etc/init.d/gdm start in order for the changes to take effect.

I (WW) think that's it. Note that I didn't use nvidia-glx-config, which might automate some of the steps that I listed.

Edit: I tried to follow the above steps and found that some are unnecessary or don't work. Here's what I did:

1. Run the command 'sudo apt-get install nvidia-glx'.

2. Run the command 'sudo dpkg-reconfigure xserver-xfree86'. Select the nvidia driver in the first screen. (The first time I did this, I didn't see the nvidia option. But I was tired. If it's really not there, run the command 'sudo modprobe nvidia' and try again.) Go through the rest of the screens, keeping all the defaults, until you get to the modules. Disable GLCore? and dri. glx should be enabled. (Every other site I have read says dri should NOT be enabled, but I followed WW's directions above and it seems to work.) Finish the configuration by again choosing all the defaults.

3. Edit /etc/modules, and add 'nvidia' (without the quotes) on its own line.

4. Run the command 'sudo modprobe nvidia' if you haven't already.

5. Hit ctrl-alt-backspace to restart the X server. You should see the nvidia splash screen.
SmartLink? modem

Note:

This modem is very common on laptop motherboards. It looks something like this when you type "lspci" in a terminal:

0000:00:1f.6 Modem: Intel Corp. 82801DB (ICH4) AC'97 Modem Controller (rev 03)
Modifying your sources

In order to install this driver (and other non-free drivers that Ubuntu does not support), you will need to edit the file

/etc/apt/sources.list

with your favourite editor under "root" and activate the "multiverse" repository by changing the lines that look like this:

deb http://archive.ubuntu.com/ubuntu/ warty main restricted universe
deb-src http://archive.ubuntu.com/ubuntu/ warty main restricted universe

to look like this:

deb http://archive.ubuntu.com/ubuntu/ warty main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ warty main restricted universe multiverse

Notes

1.

Unlike the above drivers, this driver is provided by Ubuntu in the multiverse repository and unlike drivers from the restricted repository is basically untouched by the Ubuntu development team. Hence you have to do a bit more work to get this one to go. And if you have trouble with it, the fault lies more with Debian than with Ubuntu, but is somewhat up in the air, since noone has the code.
2.

Every time you update your operating system core (called "the kernel"), you're going to have to run through the "Compiling the driver" procedure below again.

Preliminaries

These are steps you will only have to run through the first time you build this driver, we're just making sure you have all the installed packages you need. If any of these packages are already installed, that's fine, but if not, use Synaptic, aptitude or apt-get to install them.

Make sure you have the most up-to-date kernel available unless there's some reason why you want to run a specific kernel. Install the following package:

1.

linux-ARCH (where ARCH is one of 686, 686-smp, k7 or k7-smp if you use Intel, powerpc for PPC...)

Also, you're going to be compiling this driver, and Ubuntu doesn't install the necessary programs for you to do this by default. So first we need to install several packages:

1.

build-essential
2.

linux-headers-2.6-ARCH
3.

fakeroot

These will pull in some other packages too.

You also need to install the source of the SmartLink? driver itself:

1.

sl-modem-daemon
2.

sl-modem-source

You can install all packages listed above at the same time.
Compiling the driver

Run the following steps in a console. Note that whatever directory you're working in will be filled with files. It doesn't matter exactly where this is done as long as you have write access in the directory.

1.

tar -xjf /usr/src/sl-modem.tar.bz2 [this command unpacks all the files we will use into the current directory]?
2.

cd modules/sl-modem/debian [change to a particular directory where the instructions for building the module are, because we need to fix them to work with Ubuntu rather than Debian
3.

Edit the control.modules.in file in this directory. In this file, there is a line reading:
*

Depends: kernel-image-_KVERS_

*

Change this line to read:
o

Depends: linux-image-_KVERS_

1.

cd ..
2.

fakeroot debian/rules kdist KVERS=`uname -r` KSRC=/usr/src/linux-headers-`uname -r` [this does the actual building of the driver against the current running kernel, it has a lot of output]?
3.

cd ..
4.

sudo dpkg -i sl-modem-modules-*.deb [this sometimes freezes, canceling it with Ctrl+C and trying again will eventually work]?

Getting the modem to work

This driver seems rather finicky. Basically, if it works, a file called /dev/ttySL0 will exist. If it doesn't work, running sudo /etc/init.d/sl-modem-daemon restart may help, as might running modprobe slamr, but it seems somewhat random. A reboot may help too.

http://www.ubuntulinux.org/wiki/BinaryDriverHowto


_________________
当净其意如虚空,远离妄想及诸取,令心所向皆无碍


最后由 oneleaf 编辑于 2005-04-12 8:43,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : 译文如下。
帖子发表于 : 2005-04-11 6:13 

注册: 2005-04-09 15:02
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
译者:i3dmaster

如果下面任一条件成立的话, 可以安装ATI(fglrx)驱动:




你知道你有"Radeon"的显卡。

当你第一次打开电脑时, ATI的标识出现在屏幕的左上角。

你知道你的显卡的型号开始于"7", "8", "9", 或是"X".
*
cat /proc/pci 文件发现有"ATI"字样。


如果下面任一条件成立的话, 可以安装NVIDIA驱动:



你知道你的卡是"Ge-Force"或是"Quadro"。

当你第一次打开电脑时,屏幕左上角显示关于NVIDIA的信息。

你知道你的卡的型号开始于"4", "FX", 或是"6".
*
cat /proc/pci 文件发现有"NVIDIA"字样。


ATI(fglrx) 显卡

注明: 目前, ATI AMD64 的驱动只在Hoary中有
如果你用Warty(Ubuntu版本4.10)

1.
为Warty安装下列包:

sudo apt-get install fglrx-driver

2.
echo fglrx | sudo tee -a /etc/modules
*

这条命令只有在重启有才有效果。如果要立即装载内核模块,运行sudo depmod -a ; sudo modprobe fglrx, 不过着也是要在内核升级重启后才有效。如果还是不行,执行下列步骤然后重启。
3.

编辑/etc/X11/XF86Config-4,将"ati"改成"fglrx", 比如类似下面这个命令:


sudo sed -i -e 's/"ati"/"fglrx"/'/etc/X11/XF86Config-4. 还有一种方法就是用你常用的编辑器或者sudo dpkg- reconfigure xserver-xfree86然后选"fglrx"而不是"ati".

对于Hoary(Ubuntu版本5.04)

1.

安装 xorg-driver-fglrx 包:

sudo apt-get install xorg-driver-fglrx

2.

echo fglrx | sudo tee -a /etc/modules
*

这条命令只有在重启有才有效果。如果要立即装载内核模块,运行sudo depmod -a ; sudo modprobe fglrx, 不过着也是要在内核升级重启后才有效。如果还是不行,执行下列步骤然后重启。
3.

编辑/etc/X11/XF86Config-4,将"ati"改成"fglrx", 比如类似下面这个命令:sudo sed -i -e 's/"ati"/"fglrx"/'/etc/X11/ XF86Config-4. 还有一种方法就是用你常用的编辑器, 或者sudo dpkg-reconfigure xserver-xorg然后选"fglrx"而不是"ati".


注明

注明(可选): 如果你需要编译3d应用程序,建议你安装fglrx-driver-dev包。

注明(可选): 你还可以装上fglrx-control包, 这个包提供一个控制中心可以对你的显卡选项进行配置,比如双头显示(两台显示器)。

还有就是需要从目录中去除nvidia的模块(/lib/modules/kernel_version/kernel/drivers/video/nvidia. ko)。看起来某个程序装载了它,这样它就占用了AGP的口。这种情况下,你运行fireglcontrol时看到Mesa Indirect作为OpenGL驱动而不是ATI的驱动。当使用MESA drivers时会造成大量的速度损失。

在我的NFORCE2主板上, 我还得修改我的/etc/X11/XF86config-4文件来最终删除掉fireglcontrol中OpenGL部分的'..MESA... '. 在显卡的驱动部分, 我加入了下列配置:

*

Option "UseInternalAGPGART?" "no"

但这个配置在其他的主板上好像不好使。

nvidia_agp模块是需要的并自动装载了(我想是hwscan装载的)。 用'lsmod | grep "nvidia"'来检查是否装载成功了。(TAK)

极其重要: 重启!!!(我的电脑开始时完全就不行(就像下了咒似的),非常奇怪,后来第二天重启后就没事了。)


NVIDIA 显卡

注明: 需要 linux-restricted modules >= 2.6.8.1.1-3

1.

sudo apt-get install nvidia-glx

2.

sudo nvidia-glx-config enable


注明: 如果你用这些驱动运行XMMS播放器, 你得知道这个程序毛病(bug)

注明: 安装libmik倒是可以让你不受这个毛病的困扰。

注明(可选):如果你要编译3d应用, 你要安装nvidia-glx-dev包。

注明(可选): nvidia-settings包提供一个控制中心来配置你的显卡例如gamma值调节。
注明

编辑:那个脚本运行的不错, 不过你要清楚你安装了正确版本的linux-restricted- modules(必须于你运行内核的版本匹配)。

编辑: 上面的脚本在干净安装的Warty中运行很好, Warty的ISO日期为九月15号。不需要其他什么修改。(OM)

编辑: 下面是我(WW)怎样配置我的nvidia驱动的一些注释。

1.

在安装完ubuntu之后, 包linux-restricted-modules已经安装完成了。 我这的版本是2.6.8.1.0-2, 看样子不是>= 2.6.8.1. 1-3, 不过反正也能用。
2.

就像上面一样,运行sudo apt-get install nvidia-glx(或用Synaptic安装),这样"nvidia"的驱动就装上了。
3.

运行sudo dpkg-reconfigure xserver-xfree86。 在第一屏上选择nvidia驱动. 然后继续其他的屏,选择所有缺省配置,直到你看到模块选项。去除GLCore(不选择)。同时,应该选择glx模块(其实应该是 选上的)。然后选择所有缺省值完成配置。现在, 你得到一个新的/etc/X11/XF86Config-4。
4.

作为root(例如sudo可以使你以root运行程序), 用你熟悉的编辑器编辑/etc/ modules文件。加入只有"nvidia"(不带引号)的一行。这样nvidia的模块将在下次启动是装载。
5.

如果你想即时装载nvidia模块, 运行这个命令"sudo modprobe nvidia"。
6.

现在你需要做的就是重启X(我想最好在这之前你关闭所有运行的程序)。很简单, 我所做的就是ctrl-alt- backspace。X将会重启, 你还可以看到nvidia的启动画面,然后是登录画面。irc上有些人说你必须要sudo /etc/init.d/gdm stop 然后 sudo /etc/init.d/gdm start 使配置生效。

我(WW)想差不多了吧。注意我没有用nvidia-glx-config, 也许这个可以自动配置一些我上面的步骤。

编辑: 我尝试着执行了上面的步骤, 发现有些是不必要的或是没什么用。下面是我的一些记录:

1. 运行'sudo apt-get install nvidia-glx'。
2. 运行'sudo dpkg-reconfigure xserver-xfree86'. 在第一屏时选择nvidia驱动。(第一次时我没有看到nvidia的选项。不过我是真累了。如果真是没有这个选项, 运行'sudo modprobe nvidia'然后再试试。) 然后继续其他的屏,选择所有缺省配置,直到你看到模块选项。去除GLCore(不选择)和 dri. glx应该是已选上了。(我看了其他所有的网站都说要不选择dri,但我按照WW上面的方法好像也不错)最后就是选择所有的缺省完成配置。

3.编辑/etc/modules文件, 在自己那行加上'nvidia'(没有引号)。

4.如果你还没有运行这个命令,那么运行'sudo modprobe nvidia'.

5.按ctrl-alt-backspace重启X。你将看到nvidia的标识画面。

SmartLink?调制解调器。

注明:

这个解调器在笔记本中很长见。当你运行"lspci"是,你会看到象这样的东西:

0000:00:1f.6 Modem: Intel Corp. 82801DB (ICH4) AC'97 Modem Controller (rev 03)

修改你的apt源。

为了可以看装这个驱动,(和其他一些ubuntu不支持的, 不免费的驱动)在root下用你熟悉的编辑器编辑这个文件:

/etc/apt/sources.list

象下面这样增加"multiverse"源:

从:
deb http://archive.ubuntu.com/ubuntu/ warty main restricted universe
deb-src http://archive.ubuntu.com/ubuntu/ warty main restricted universe

修改为:

deb http://archive.ubuntu.com/ubuntu/ warty main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ warty main restricted universe multiverse

注明

1.

不象上面的驱动, 这个驱动程序放在了ubuntu的multiverse源里. 这也和ubuntu限制程序(restricted)源不一样。限制源的程序,ubuntu开发组是不支持的。这样你要多做一点工作才能将它搞定。当然如果你还是有问题, 错误一般出在debian身上而不是ubuntu, 但有时也是那说, 因为noone掌握着源码。
2.

每次你升级系统代码(叫"内核")时, 你都要过一遍下面"Compiling the driver"(编译驱动)的过程。

Preliminaries (最初配置)

这些步骤你只需要在第一次编译驱动时执行。 我们只是想确定你确实装载了所有需要的包。如果你已经安装了,非常好, 如果没有, 那么就用Synaptic,aptitude或是apt-get来安装吧。

除非你有自己特殊的原因要运行在某个内核,不然请确定你的内核是最新的。安装下列包:

1.

linux-ARCH(如果是intel,powerpc 或是PPC..., ARCH是686, 686-smp, k7或k7-smp其中之一)

还有就是ubuntu缺省没有安装编译程序所必须的几个包, 你自己得先安装他们:

1.

build-essential

2.

linux-headers-2.6-ARCH

3.

fakeroot

这些程序的安装也会带进其他的一些倚赖包。

你还得自己安装一些SmartLink驱动:

1.

sl-modem-daemon

2.

sl-modem-source

当然, 你可以一次性的安装上面所有的包。

编译驱动

在字符终端下执行下列步骤。 注意在你工作的目录下会产生不少文件。在哪个目录下编译倒并不重要, 只要你对目录可写就行了。

1.

tar -xjf /usr/src/sl-modem.tar.bz2 [这个命令将所有文件解压到当前目录]

2.

cd modules/sl-modem/debian [改变当前目录到指定的编译目录。原因是我们要使它在ubuntu下而不是debian下运行。]

3.

在目录下编辑control.modules.in文件。在这个文件中, 有类似这样一行:
*

Depends: kernel-image-_KVERS_

*


改成下面这样:

Depends: linux-image-_KVERS_

1.

cd ..
2.

fakeroot debian/rules kdist KVERS=`uname -r` KSRC=/usr/src/linux-headers-`uname -r` [这个命令执行根据运行内核环境而编译的驱动,有不少输出。]
3.

cd ..
4.

sudo dpkg -i sl-modem-modules-*.deb [这个命令有时会出问题僵在那, 用Ctrl+C取消它然后再试,最终会ok的。]

让模块运行

这个驱动的却有点讨厌。基本上, 如果能用, 那么文件/dev/ttySL0将存在。如果不行, 运行sudo /etc/init.d/sl-modem- daemon也许能有点帮助。 或是modprobe slamr,但好像都不多见。重启吧,也许有用。

http://www.ubuntulinux.org/wiki/BinaryDriverHowto


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-04-12 1:44 
头像

注册: 2005-04-06 21:15
帖子: 2200
地址: 安徽黄山
送出感谢: 0 次
接收感谢: 0 次
有人装好了ati驱动的和我说一声,我好也试试看,我以前没有注意到

还有就是需要从目录中去除nvidia的模块 (/lib/modules/kernel_version/kernel/drivers/video/nvidia. ko)。看起来某个程序装载了它,这样它就占用了AGP的口。这种情况下,你运行fireglcontrol时看到Mesa Indirect作为OpenGL驱动而不是ATI的驱动。当使用MESA drivers时会造成大量的速度损失。

这一段,很可能我就是被这个卡到了,损失了大量的性能,不过我没胆试了,哪位提供下经验。


_________________
生命不息,灌水不止,我师父是白娘子.另热烈庆祝本人blog访问量突破2w大关.
被高手bs,向小白显摆.


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-04-19 1:35 

注册: 2005-04-19 1:27
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
我的显卡是ati,按照上面的步骤做完后,system--preferences--screen resolution不能用了,出现如下提示 :
"The X Server does not support the XRandR extension. Runtime resolution changes to the display size are not available."
请高手解答


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-08-01 1:08 
头像

注册: 2005-07-02 14:41
帖子: 4133
系统: Ubuntu 14.04 (Kylin)
送出感谢: 53
接收感谢: 11
这个有没有过时?先放着


_________________
https://weakish.github.io


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译