当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 软件包依赖出现问题,无法安装和卸载任何软件了,求助!
帖子发表于 : 2012-05-26 12:07 
头像

注册: 2009-06-29 16:23
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
下面的回显来自终端
=====================
您可能需要运行“apt-get -f install”来纠正下列错误:
下列软件包有未满足的依赖关系:
gnome-session-fallback : 依赖: gnome-panel (>= 3.0) 但是它将不会被安装
推荐: cups-pk-helper 但是它将不会被安装
libssl1.0.0 : 破坏: libssl1.0.0:i386 (!= 1.0.1-4ubuntu5.2) 但是 1.0.1-4ubuntu3 正要被安装
libssl1.0.0:i386 : 破坏: libssl1.0.0 (!= 1.0.1-4ubuntu3) 但是 1.0.1-4ubuntu5.2 正要被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
=====================

leon@ubuntu:~$ sudo apt-get install -f
[sudo] password for leon:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
正在更正依赖关系... 完成
将会安装下列额外的软件包:
libssl1.0.0:i386
下列软件包将被升级:
libssl1.0.0:i386
升级了 1 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 201 个软件包未被升级。
有 2 个软件包没有被完全安装或卸载。
需要下载 0 B/1,002 kB 的软件包。
解压缩后会消耗掉 0 B 的额外空间。
您希望继续执行吗?[Y/n]y
E: Internal Error, No file name for libssl1.0.0

不解决这个问题连新立得都无法使用,安装或者卸载软件都显示
E: Internal Error, No file name for libssl1.0.0

求助!!


_________________
Linux初学者一枚


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 软件包依赖出现问题,无法安装和卸载任何软件了,求助!
帖子发表于 : 2012-05-26 15:20 
头像

注册: 2011-06-07 14:20
帖子: 3866
系统: Mint18
送出感谢: 17
接收感谢: 65
更新源或者换源,不行就卸载掉gnome-session-fallback


_________________
wiki: ubuntu 技巧


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 软件包依赖出现问题,无法安装和卸载任何软件了,求助!
帖子发表于 : 2012-05-26 16:04 
头像

注册: 2009-06-29 16:23
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
b33e 写道:
更新源或者换源,不行就卸载掉gnome-session-fallback


不是的,前面那一段只是个例子,因为在我安装那个之前就已经是那样了。现在少了这个叫 libssl1.0.0 的文件,任何软件都无法安装和卸载。


_________________
Linux初学者一枚


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 软件包依赖出现问题,无法安装和卸载任何软件了,求助!
帖子发表于 : 2012-05-26 16:31 
头像

注册: 2011-06-07 14:20
帖子: 3866
系统: Mint18
送出感谢: 17
接收感谢: 65
是你没明白我说的吧


_________________
wiki: ubuntu 技巧


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 软件包依赖出现问题,无法安装和卸载任何软件了,求助!
帖子发表于 : 2012-07-25 14:28 

注册: 2012-07-25 11:36
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
kevinyzd 写道:
b33e 写道:
更新源或者换源,不行就卸载掉gnome-session-fallback


不是的,前面那一段只是个例子,因为在我安装那个之前就已经是那样了。现在少了这个叫 libssl1.0.0 的文件,任何软件都无法安装和卸载。


请问你的问题解决了吗。我现在也遇到了同样的问题,在ubuntu12.04下


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 软件包依赖出现问题,无法安装和卸载任何软件了,求助!
帖子发表于 : 2012-07-25 14:31 
头像

注册: 2007-09-16 8:29
帖子: 14253
送出感谢: 172
接收感谢: 273
http://forum.ubuntu.org.cn/viewtopic.php?f=77&t=349483
上面的链接和你的情况不同。链接里只是不能安装、卸载,新立得还能进去。


_________________
闻到死太贵, 麦克价更高。 有了笨笨兔, 二者皆可抛。
+ 我的六轮折腾
+ 折腾6轮的结果(对40余种WM的测试和分析,多种DE和WM并存的方案)
+ 折腾的中间成果:可以独立运行的一个Wharf(图标化的启动菜单)
+ 强烈推荐----折腾的终极成果:一个自己开发的DE环境
+ 签名空闲链接位置招租


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 软件包依赖出现问题,无法安装和卸载任何软件了,求助!
帖子发表于 : 2015-02-08 20:55 

注册: 2015-02-08 20:51
帖子: 1
系统: ubuntu14.04
送出感谢: 0 次
接收感谢: 0 次
对于依赖的包版本低于系统已装的包版本,可在包名后加上“/trusty”,在一并执行apt-get,可解决。
http://askubuntu.com/questions/462094/u ... pendencies


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译