在T430安装Ubuntu12.04, 关机时有破音(Fedora18也有这个问题)

Precise Pangolin (长期支持)
回复
头像
dos5gw
帖子: 39
注册时间: 2010-03-18 8:44
来自: 四海
送出感谢: 0
接收感谢: 0

在T430安装Ubuntu12.04, 关机时有破音(Fedora18也有这个问题)

#1

帖子 dos5gw » 2013-03-01 8:40

T430上新装了Ubuntu, 放弃Fedora了(虽然公司软件研发统一用的fedora)
目测一切正常运转, 除了一个让人蛋疼的小问题:
关机的时候, 笔记本会发出"bo"的一声, 好象是从音箱发出的, 类似于突然断电后电流冲击印象的声音, 平时声音一切正常, 听音乐没有破音
有人说是硬盘归位的声音, 不过我听着不像是硬盘里发出来的.

之前用Fedora 17/18, 也都有一样的问题, 关机会出现"bo"的一声, Win7就没有=.=


搜到一个帖子,viewtopic.php?f=86&t=245751
给出的解决方法是修改/etc/modprobe.d/alsa-base.conf, 不过我的alsa-base.conf里本来就没有options snd-hda-intel power_save 这个参数....

代码: 全选

$ lspci |grep Audio
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
艾泽拉斯探险队 *Corpora
头像
dos5gw
帖子: 39
注册时间: 2010-03-18 8:44
来自: 四海
送出感谢: 0
接收感谢: 0

Re: 在T430安装Ubuntu12.04, 关机时有破音(Fedora18也有这个问题)

#2

帖子 dos5gw » 2013-03-02 9:30

发现一个很有意思的帖子,
Is it this same sound like sound after this commend:


关机时的爆音有点类似下面的:
终端输入:

代码: 全选

aplay -d 1 /dev/zero
上次由 dos5gw 在 2013-03-10 18:02,总共编辑 1 次。
艾泽拉斯探险队 *Corpora
tmdtmdd
帖子: 2
注册时间: 2013-03-05 12:01
系统: ubuntu12.04
送出感谢: 0
接收感谢: 0

Re: 在T430安装Ubuntu12.04, 关机时有破音(Fedora18也有这个问题)

#3

帖子 tmdtmdd » 2013-03-05 12:03

我也是T430 装了 没遇到唉 学习了
头像
dos5gw
帖子: 39
注册时间: 2010-03-18 8:44
来自: 四海
送出感谢: 0
接收感谢: 0

Re: 在T430安装Ubuntu12.04, 关机时有破音(Fedora18也有这个问题)

#4

帖子 dos5gw » 2013-03-10 18:01

已解决, 编辑/usr/lib/pm-utils/power.d/intel-audio-powersave

找到INTEL_AUDIO_POWERSAVE=${INTEL_AUDIO_POWERSAVE:-true}这一行, 注释掉
加入:
INTEL_AUDIO_POWERSAVE=true
艾泽拉斯探险队 *Corpora
shotim
帖子: 100
注册时间: 2011-10-16 13:36
送出感谢: 11 次
接收感谢: 3 次

Re: 在T430安装Ubuntu12.04, 关机时有破音(Fedora18也有这个问题)

#5

帖子 shotim » 2013-03-11 20:54

前几天wineQQ点了视频聊天,结果崩溃了,半个小时才关掉机,就像死了机,硬盘灯不灭。在后来重启后,就出现关机破音了,以前用过别的版本,多次装过系统,这样的问题经常遇到过。但是照楼主的办法还是没解决。
头像
dos5gw
帖子: 39
注册时间: 2010-03-18 8:44
来自: 四海
送出感谢: 0
接收感谢: 0

Re: 在T430安装Ubuntu12.04, 关机时有破音(Fedora18也有这个问题)

#6

帖子 dos5gw » 2013-03-14 9:29

shotim 写了:前几天wineQQ点了视频聊天,结果崩溃了,半个小时才关掉机,就像死了机,硬盘灯不灭。在后来重启后,就出现关机破音了,以前用过别的版本,多次装过系统,这样的问题经常遇到过。但是照楼主的办法还是没解决。
现在发现是Win7下偶尔有, LInux上每次关机出的概率大一点,,,
你的BIOS是什么版本? 我的2.5.1
也是T430吗?
艾泽拉斯探险队 *Corpora
头像
dos5gw
帖子: 39
注册时间: 2010-03-18 8:44
来自: 四海
送出感谢: 0
接收感谢: 0

Re: 在T430安装Ubuntu12.04, 关机时有破音(Fedora18也有这个问题)

#7

帖子 dos5gw » 2013-03-14 9:30

tmdtmdd 写了:我也是T430 装了 没遇到唉 学习了
请问你的BIOS的版本?
艾泽拉斯探险队 *Corpora
shotim
帖子: 100
注册时间: 2011-10-16 13:36
送出感谢: 11 次
接收感谢: 3 次

Re: 在T430安装Ubuntu12.04, 关机时有破音(Fedora18也有这个问题)

#8

帖子 shotim » 2013-03-14 22:01

我的是G450,现在才有的,我同时还装了kubuntu,三个系统,kubuntu没问题,以前ubuntu也是没有的,记得第一次装雨林木风的时候,这个问题很明显,开关机都一样,几个小时就卸了。
头像
dos5gw
帖子: 39
注册时间: 2010-03-18 8:44
来自: 四海
送出感谢: 0
接收感谢: 0

Re: 在T430安装Ubuntu12.04, 关机时有破音(Fedora18也有这个问题)

#9

帖子 dos5gw » 2013-03-14 22:27

shotim 写了:我的是G450,现在才有的,我同时还装了kubuntu,三个系统,kubuntu没问题,以前ubuntu也是没有的,记得第一次装雨林木风的时候,这个问题很明显,开关机都一样,几个小时就卸了。
aplay -l 看你的声卡是啥型号啊...
艾泽拉斯探险队 *Corpora
shotim
帖子: 100
注册时间: 2011-10-16 13:36
送出感谢: 11 次
接收感谢: 3 次

Re: 在T430安装Ubuntu12.04, 关机时有破音(Fedora18也有这个问题)

#10

帖子 shotim » 2013-03-15 12:34

shotim@shotim-Lenovo-G450:~$ aplay -l
**** PLAYBACK 硬體裝置清單 ****
card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
子设备: 1/1
子设备 #0: subdevice #0
card 0: Intel [HDA Intel], device 1: Conexant Digital [Conexant Digital]
子设备: 1/1
子设备 #0: subdevice #0
shotim@shotim-Lenovo-G450:~$
我记得上次崩溃后关机时,屏幕显示了很多东西,好像就有音频之类的东西,但是晃得快了点,没看仔细,当时也觉得不妙,不过开机后没发现问题,关机是才发现“彭”的一下。我想系统有些配置被更改了。
头像
dos5gw
帖子: 39
注册时间: 2010-03-18 8:44
来自: 四海
送出感谢: 0
接收感谢: 0

Re: 在T430安装Ubuntu12.04, 关机时有破音(Fedora18也有这个问题)

#11

帖子 dos5gw » 2013-03-15 21:46

shotim 写了:shotim@shotim-Lenovo-G450:~$ aplay -l
**** PLAYBACK 硬體裝置清單 ****
card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
子设备: 1/1
子设备 #0: subdevice #0
card 0: Intel [HDA Intel], device 1: Conexant Digital [Conexant Digital]
子设备: 1/1
子设备 #0: subdevice #0
shotim@shotim-Lenovo-G450:~$
我记得上次崩溃后关机时,屏幕显示了很多东西,好像就有音频之类的东西,但是晃得快了点,没看仔细,当时也觉得不妙,不过开机后没发现问题,关机是才发现“彭”的一下。我想系统有些配置被更改了。
唉,,,,你的也是HDA Intel...
艾泽拉斯探险队 *Corpora
回复

回到 “Ubuntu 12.04 LTS”