我的virtualbox 为什么不能启动(已解决)?

Precise Pangolin (长期支持)
回复
头像
Trilobita
帖子: 251
注册时间: 2011-04-23 19:27
送出感谢: 3 次
接收感谢: 0

我的virtualbox 为什么不能启动(已解决)?

#1

帖子 Trilobita » 2013-04-14 21:37

我新装的12.04和virtualbox,虚拟机启动时提示如下
2013-04.jpg
2013-04-14.jpg
搜索了一下本坛,有如下解决方法

sudo apt-get install dkms build-essential linux-headers-$(uname -r)
sudo /etc/init.d/vboxdrv setup
但我执行第二条时提示

~$ sudo /etc/init.d/vboxdrv setup
sudo: /etc/init.d/vboxdrv:找不到命令
为什么?请高人指教
上次由 Trilobita 在 2013-04-20 20:55,总共编辑 1 次。
头像
Trilobita
帖子: 251
注册时间: 2011-04-23 19:27
送出感谢: 3 次
接收感谢: 0

Re: 我的virtualbox 为什么不能启动?

#3

帖子 Trilobita » 2013-04-14 21:56

确定,我进/etc/etc/init.d/目录,没有vboxdrv setup文件,有一个virtualbox文件,试着执行了一下
显示
~$ sudo /etc/init.d/virtualbox
Usage: /etc/init.d/virtualbox {start|stop|stop_vms|restart|force-reload|status}
头像
Trilobita
帖子: 251
注册时间: 2011-04-23 19:27
送出感谢: 3 次
接收感谢: 0

Re: 我的virtualbox 为什么不能启动?

#4

帖子 Trilobita » 2013-04-14 22:02

又找了一下,压根没有提示说的/dev/vboxdrv这个目录啊,我可是从ubuntu官网下的12.04 iso文件安装,用软件中心安的virtualbox,有什么问题吗?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: 我的virtualbox 为什么不能启动?

#5

帖子 eexpress » 2013-04-14 22:06

版本不同了。看下面。

代码: 全选

sudo modprobe vboxdrv
现在virtualbox和kvm和谐共存了。按照道理,没必要设置任何东西切换了。

你咋搞出来的哦。
● 鸣学
头像
Trilobita
帖子: 251
注册时间: 2011-04-23 19:27
送出感谢: 3 次
接收感谢: 0

Re: 我的virtualbox 为什么不能启动?

#6

帖子 Trilobita » 2013-04-14 22:13

大神,我按照执行了

~$ sudo modprobe vboxdrv
FATAL: Module vboxdrv not found.

如上贴,我没有/dev/vboxdrv这个目录啊,是不是不对?
头像
Trilobita
帖子: 251
注册时间: 2011-04-23 19:27
送出感谢: 3 次
接收感谢: 0

Re: 我的virtualbox 为什么不能启动?

#7

帖子 Trilobita » 2013-04-14 22:16

什么是kvm? :em04
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: 我的virtualbox 为什么不能启动?

#8

帖子 eexpress » 2013-04-14 22:17

● sudo modprobe vbo<TAB>
vboxdrv vboxnetadp vboxnetflt vboxpci

你自己对比下。
● 鸣学
头像
Trilobita
帖子: 251
注册时间: 2011-04-23 19:27
送出感谢: 3 次
接收感谢: 0

Re: 我的virtualbox 为什么不能启动?

#9

帖子 Trilobita » 2013-04-14 22:27

执行如下
sudo modprobe vbo
.bash_history .gvfs/ VirtualBox VMs/
bin/ .ICEauthority .Xauthority
.cache/ .local/ .xsession-errors
.compiz-1/ .mission-control/ .xsession-errors.old
.config/ .mozilla/ 视频/
.dbus/ .nv/ 图片/
.dmrc pic/ 网页/
.fontconfig/ .pki/ 文档/
.gconf/ Programs/ 下载/
.gegl-0.0/ .pulse/ 新建项目.flv
.gimp-2.6/ .pulse-cookie 新建项目.ogv
.gnome2/ .sunpinyin/ 音乐/
.gstreamer-0.10/ .thumbnails/ 桌面/
.gtk-bookmarks .VirtualBox/
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: 我的virtualbox 为什么不能启动?

#10

帖子 eexpress » 2013-04-14 22:32

@@@@ 你这系统搞得蛮乱了。bash_complete应该都坏了。

你新建一个帐号,进去测试下,看各种情况正常不。
● 鸣学
头像
Trilobita
帖子: 251
注册时间: 2011-04-23 19:27
送出感谢: 3 次
接收感谢: 0

Re: 我的virtualbox 为什么不能启动?

#11

帖子 Trilobita » 2013-04-14 22:36

我这系统是新装的 :em20 ,彻底删除再装一次 :em18
头像
Trilobita
帖子: 251
注册时间: 2011-04-23 19:27
送出感谢: 3 次
接收感谢: 0

Re: 我的virtualbox 为什么不能启动(已解决)?

#12

帖子 Trilobita » 2013-04-20 20:58

又重装了一遍,还是依旧 :em20 ,启动“更新管理器”,统统选上,下了四百M之后,奇迹出现了,居然可以正常启动了, :em05 :em11
呜呼,我为此装了有四遍啊 :em06
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: 我的virtualbox 为什么不能启动(已解决)?

#13

帖子 eexpress » 2013-04-20 21:11

你新系统,没更新过的?统统选上?选的啥?
下次记得新系统,先洗刷刷。 :em04
● 鸣学
回复

回到 “Ubuntu 12.04 LTS”