[已解决]开机动画花屏,关机时却正常,是怎么回事呢?

回复
头像
无 痕
帖子: 21
注册时间: 2009-10-24 17:49
送出感谢: 4 次
接收感谢: 0

[已解决]开机动画花屏,关机时却正常,是怎么回事呢?

#1

帖子 无 痕 » 2014-05-24 1:07

用U盘安装了ubuntukylin,加上win7双系统,由win7引导的ubuntu。显卡驱动用的默认开源的,开机动画一直是条纹状的花屏,看不清Logo,但每次关机时动画却正常。进入系统没什么问题,但老是看花屏让人不舒服,求教有没有什么方法?
上次由 无 痕 在 2014-05-30 21:26,总共编辑 1 次。
poloshiao
论坛版主
帖子: 18169
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1924 次

Re: 开机动画花屏,关机时却正常,是怎么回事呢?

#2

帖子 poloshiao » 2014-05-24 10:32

把下面指令 複製 貼進終端機 執行
sudo lshw -numeric -class video
把結果直接複製貼上來
想要瞭解你的顯卡硬件及已安裝驅動的資訊
头像
无 痕
帖子: 21
注册时间: 2009-10-24 17:49
送出感谢: 4 次
接收感谢: 0

Re: 开机动画花屏,关机时却正常,是怎么回事呢?

#3

帖子 无 痕 » 2014-05-24 13:46

poloshiao 写了:把下面指令 複製 貼進終端機 執行
sudo lshw -numeric -class video
把結果直接複製貼上來
想要瞭解你的顯卡硬件及已安裝驅動的資訊
*-display
description: VGA compatible controller
product: GT216M [GeForce GT 240M] [10DE:A34]
vendor: NVIDIA Corporation [10DE]
physical id: 0
bus info: pci@0000:01:00.0
version: a2
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nouveau latency=0
resources: irq:48 memory:cc000000-ccffffff memory:d0000000-dfffffff memory:ce000000-cfffffff ioport:2000(size=128) memory:cd000000-cd07ffff

我试着在系统设置里变更为闭源已测试的nivida驱动,现在开关机画面都有了,可是开机时会有英文提示错误,不过似乎不影响使用。
poloshiao
论坛版主
帖子: 18169
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1924 次

Re: 开机动画花屏,关机时却正常,是怎么回事呢?

#4

帖子 poloshiao » 2014-05-24 17:57

product: GT216M [GeForce GT 240M] [10DE:A34]
configuration: driver=nouveau latency=0
目前使用 開源驅動 nouveau
http://nouveau.freedesktop.org/wiki/CodeNames/
對於 GT216M [GeForce GT 240M] 的支援 見
NV50 family (Tesla)

但是 對於 3D 支援 可能閉源驅動 略勝一些
對於你的動畫問題 可以試試
http://www.nvidia.cn/download/driverRes ... x/75062/cn
产品支持列表
GeForce 200M Series (Notebooks):
GeForce GT 240M
版本: 331.67

優先安裝 Ubuntu 套件庫 的
nvidia-graphics-drivers-331

nvidia-graphics-drivers-331-updates
安裝方法 參考
https://help.ubuntu.com/community/Binar ... wto/Nvidia

只有 上面的
nvidia-graphics-drivers-331

nvidia-graphics-drivers-331-updates
不合乎你的需求 再考慮 從 nVidia 直接下載 驅動安裝程式來安裝
版本: 331.67
安裝方法
https://help.ubuntu.com/community/NvidiaManual
这些用户感谢了作者 poloshiao 于这个帖子:
无 痕 (2014-05-25 12:29)
评价: 3.7%
头像
无 痕
帖子: 21
注册时间: 2009-10-24 17:49
送出感谢: 4 次
接收感谢: 0

Re: 开机动画花屏,关机时却正常,是怎么回事呢?

#5

帖子 无 痕 » 2014-05-25 12:28

poloshiao 写了:
product: GT216M [GeForce GT 240M] [10DE:A34]
configuration: driver=nouveau latency=0
目前使用 開源驅動 nouveau
安装了推荐的闭源nvidia331.38tested驱动,现在开机动画正常了,谢谢。
不过为什么我再用 sudo lshw -numeric -class video查询时,依然显示
configuration: driver-nouveau latency=0

还有奇怪的是,开机在左上角闪动后会在黑屏上方闪过一个红色的f然后再到开机动画。
poloshiao
论坛版主
帖子: 18169
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1924 次

Re: 开机动画花屏,关机时却正常,是怎么回事呢?

#6

帖子 poloshiao » 2014-05-25 13:29

为什么我再用 sudo lshw -numeric -class video查询时,依然显示
configuration: driver-nouveau latency=0
1. 需要把 nouveau 列入開機載入黑名單
gksudo gedit /etc/modprobe.d/blacklist.conf
blacklist nouveau
如果是第一次使用 gksudo
需要先安裝 gksu 套件
2. 然後 重新開機
從終端機
lsmod | grep nouveau
如果沒有 表示阻擋載入成功
开机在左上角闪动后会在黑屏上方闪过一个红色的f然后再到开机动画。
完成 1,2 以後 看看有沒有改進
头像
无 痕
帖子: 21
注册时间: 2009-10-24 17:49
送出感谢: 4 次
接收感谢: 0

Re: 开机动画花屏,关机时却正常,是怎么回事呢?

#7

帖子 无 痕 » 2014-05-25 15:19

poloshiao 写了: 完成 1,2 以後 看看有沒有改進
终端里查到driver=nvidia
阻挡载入也成功。
不过开机动画没有了,变成了控制台出现闪一下进入登录画面 :em06
开机启动有nvidia的logo
poloshiao
论坛版主
帖子: 18169
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1924 次

Re: 开机动画花屏,关机时却正常,是怎么回事呢?

#8

帖子 poloshiao » 2014-05-25 22:45

1. gksudo nvidia-settings
每個設定項目 確認一下
然後 重新開機
2. 第一次 使用 gksudo 需要先安裝 gksu 套件
头像
无 痕
帖子: 21
注册时间: 2009-10-24 17:49
送出感谢: 4 次
接收感谢: 0

Re: 开机动画花屏,关机时却正常,是怎么回事呢?

#9

帖子 无 痕 » 2014-05-25 23:38

poloshiao 写了:1. gksudo nvidia-settings
每個設定項目 確認一下
然後 重新開機
2. 第一次 使用 gksudo 需要先安裝 gksu 套件
** (gksudo:3742): CRITICAL **: fcntl error

** (gksudo:3742): WARNING **: Lock taken by pid: -1. Exiting.
poloshiao
论坛版主
帖子: 18169
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1924 次

Re: 开机动画花屏,关机时却正常,是怎么回事呢?

#10

帖子 poloshiao » 2014-05-26 6:30

http://askubuntu.com/questions/457935/c ... su-anymore
rm ~/.gksu.lock

rm ~/.gksudo.lock

然後 再來一次
如果還是同樣的錯誤訊息
請再貼文

補充
gksu, gksudo 因為跟 gnome 3 不太相容 打算 以 pkexec 取代
但是 pkexec 還沒準備好 取代 gksu, gksudo
所以 有點 青黃不接
头像
无 痕
帖子: 21
注册时间: 2009-10-24 17:49
送出感谢: 4 次
接收感谢: 0

Re: 开机动画花屏,关机时却正常,是怎么回事呢?

#11

帖子 无 痕 » 2014-05-26 22:39

poloshiao 写了: rm ~/.gksu.lock
使用这个命令后可以打开设置界面,不过再次打开仍然会报同样错误,需再次使用以上命令方可进入。
1.jpg
2.jpg
这个要怎么设置呢?
poloshiao
论坛版主
帖子: 18169
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1924 次

Re: 开机动画花屏,关机时却正常,是怎么回事呢?

#12

帖子 poloshiao » 2014-05-27 0:13

每個可以打勾 可以輸入方框 ... 都檢查看看
剛開始 盡量使用 預設值
只有你確定的地方再修改
修改以後 要重開機 才生效

記住某些數字
例如 版本 331.38
头像
无 痕
帖子: 21
注册时间: 2009-10-24 17:49
送出感谢: 4 次
接收感谢: 0

Re: 开机动画花屏,关机时却正常,是怎么回事呢?

#13

帖子 无 痕 » 2014-05-29 19:57

经过多次努力,终于解决了这个头疼的问题。
就个人看帖子的粗浅理解,现在ubuntu的启动这块似乎是由内核kms直接控制的,而闭源驱动在这一块儿是受限的,导致在闭源驱动后启动/关机变成了字符界面。查看了下/lib/plymouth/themes文件夹,有default.plymouth和text.plymouth两个文件以及对应的ubuntukylin-logo和ubuntukylin-text两个文件夹,默认是logo画面启动,但在某些情况下就会以字符界面启动,看来多半是因为闭源驱动受限,没有正常图形界面启动,因而变成字符启动画面。
在一篇文章里找到的解决方法:
1、安装v86d和hwinfo包,下面我们要用到

$ sudo apt-get install v86d hwinfo

2、查看自己显卡支持的分辨率

$ sudo hwinfo --framebuffer

3、修改/etc/default/grub文件,使用uvesafb的framebuffer来启动

$ sudo gedit /etc/default/grub

把下面的两行
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

#GRUB_GFXMODE=640×480
修改为:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1366x768-24,mtrr=3,scroll=ywrap"

GRUB_GFXMODE=1366x768

ps:其中的nomodeset禁用内核kms,个人见解
这个要根据第2步所查到的显卡所支持的最大分辨率(当然也可以是其他支持的分辨率)来修改,注意要把前面的#去掉。

4、修改/etc/initramfs-tools/modules文件

$ sudo gedit /etc/initramfs-tools/modules
添加下面这行:
uvesafb mode_option=1366x768-24 mtrr=3 scroll=ywrap

ps:这一步的修改与上一步中的第1处修改关联一致

5、运行下面的命令,启用framebuffer

$ echo FRAMEBUFFER=y | sudo tee /etc/initramfs-tools/conf.d/splash

6、运行下面的命令,更新grub配置以及initramfs镜像文件

$ sudo update-grub
$ sudo update-initramfs -u

7、重启

$ sudo reboot

hwinfo命令我没能成功安装,所以跳过了1.2步,如果对自己的显卡了解的话其实也没必要。以上方法个人亲测成功,希望也能对大家有所帮助。
原文地址:http://blog.chinaunix.net/uid-26495963-id-3064462.html
原帖中还有关于修改后影响控制台的问题的解决方案以及GRUB界面分辨率调整方法,这部分内容在论坛里也有,就不帖了,感兴趣可以自己去看。
回复

回到 “UbuntuKylin”