当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 求助无法安装媒体播放器
帖子发表于 : 2017-03-12 4:52 

注册: 2010-01-16 12:40
帖子: 42
送出感谢: 2
接收感谢: 0 次
如题,使用的系统是linux mint 18.1 cinnamon 64-bit。其他都好,自己钻研琢磨,就是安装视频播放器,smplayer vlc都不成功。总是提示“E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。” 在网上查了下,说的都是ubuntu系统里,修改软件源的,但是这个系统不一样 没办法照着这个修改啊。而且系统自带的视频播放器基本播放不了视频,我点击安装附加解码器,一样提示“E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。”
求大神解救,到底该怎么办啊


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 求助无法安装媒体播放器
帖子发表于 : 2017-03-12 8:52 
头像

注册: 2007-12-14 13:40
帖子: 49862
地址: 志虚国乌由市
系统: Winbuntu
送出感谢: 29
接收感谢: 412
请把完整出错信息贴上来


_________________
冷轩信

渠月 · QY

本人只会灌水,不负责回答问题

无聊可以点一下→ http://u.nu/ubuntu


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 求助无法安装媒体播放器
帖子发表于 : 2017-03-12 16:13 

注册: 2009-08-04 16:33
帖子: 16735
送出感谢: 21
接收感谢: 1816
引用:
总是提示“E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

1. 把下面的指令 複製 貼進終端機 執行
1-1. sudo dpkg --configure -a
1-2. sudo apt-get update
1-3. sudo apt-get upgrade
如果有錯誤訊息 把錯誤訊息 全部複製 貼上來 同時 提供
1-4. sudo cat /etc/apt/sources.list
1-5. sudo ls -Al /etc/apt/sources.list.d
把結果 複製 貼上來

2. 如果沒有錯誤訊息 繼續安裝 smplayer vlc 看看


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 求助无法安装媒体播放器
帖子发表于 : 2017-03-12 21:35 

注册: 2010-01-16 12:40
帖子: 42
送出感谢: 2
接收感谢: 0 次
poloshiao 写道:
引用:
总是提示“E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

1. 把下面的指令 複製 貼進終端機 執行
1-1. sudo dpkg --configure -a
1-2. sudo apt-get update
1-3. sudo apt-get upgrade
如果有錯誤訊息 把錯誤訊息 全部複製 貼上來 同時 提供
1-4. sudo cat /etc/apt/sources.list
1-5. sudo ls -Al /etc/apt/sources.list.d
把結果 複製 貼上來

2. 如果沒有錯誤訊息 繼續安裝 smplayer vlc 看看

运行 sudo dpkg --configure -a 后直接完成,没有任何提示,然后安装smplayer和vlc仍然失败。下面是全部代码
代码:
sudo apt-get install smplayer
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
 smplayer : 依赖: mplayer 或
                    mplayer-nogui 但无法安装它 或
                    mpv (>= 0.6.2)
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。


sudo apt-get install vlc
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
vlc : 依赖: vlc-nox (= 2.2.1-5) 但是它将不会被安装
依赖: libavcodec-ffmpeg56 (>= 7:2.4) 但是它将不会被安装 或
libavcodec-ffmpeg-extra56 (>= 7:2.4) 但是它将不会被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

同时 sudo cat /etc/apt/sources.list
#deb cdrom:[Linux Mint 18.1 _Serena_ - Release amd64 20161213]/ xenial contrib main non-free

sudo ls -Al /etc/apt/sources.list.d
total 20
-rw-r--r-- 1 root root 132 3月 12 05:23 hzwhuang-ss-qt5-xenial.list
-rw-r--r-- 1 root root 494 3月 12 04:16 official-package-repositories.list
-rw-r--r-- 1 root root 126 3月 12 03:59 rvm-smplayer-xenial.list
-rw-r--r-- 1 root root 65 3月 12 04:13 sogoupinyin.list
-rw-r--r-- 1 root root 173 3月 12 05:17 vivaldi.list


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 求助无法安装媒体播放器
帖子发表于 : 2017-03-12 21:40 

注册: 2010-01-16 12:40
帖子: 42
送出感谢: 2
接收感谢: 0 次
另外,我想装个ss,添加源后运行同样报错
代码:
sudo apt-get install shadowsocks-qt5
[sudo] password for qiang:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
 shadowsocks-qt5 : 依赖: libqtshadowsocks (>= 1.10.0) 但是它将不会被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

这个我在ubuntu安装是一遍过的


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 求助无法安装媒体播放器
帖子发表于 : 2017-03-12 21:51 
头像

注册: 2007-12-14 13:40
帖子: 49862
地址: 志虚国乌由市
系统: Winbuntu
送出感谢: 29
接收感谢: 412
引用:
sudo cat /etc/apt/sources.list
#deb cdrom:[Linux Mint 18.1 _Serena_ - Release amd64 20161213]/ xenial contrib main non-free

/etc/apt/sources.list文件里只有这一行?
只有这一行能装软件才有问题


_________________
冷轩信

渠月 · QY

本人只会灌水,不负责回答问题

无聊可以点一下→ http://u.nu/ubuntu


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 求助无法安装媒体播放器
帖子发表于 : 2017-03-12 21:57 

注册: 2010-01-16 12:40
帖子: 42
送出感谢: 2
接收感谢: 0 次
qy117121 写道:
引用:
sudo cat /etc/apt/sources.list
#deb cdrom:[Linux Mint 18.1 _Serena_ - Release amd64 20161213]/ xenial contrib main non-free

/etc/apt/sources.list文件里只有这一行?
只有这一行能装软件才有问题

是的,只有这一行。那这个情况该怎么办啊


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 求助无法安装媒体播放器
帖子发表于 : 2017-03-12 22:01 
头像

注册: 2007-12-14 13:40
帖子: 49862
地址: 志虚国乌由市
系统: Winbuntu
送出感谢: 29
接收感谢: 412
设置软件源啊 ,有软件中心吧
打开 Software Manager ,点击 Edit ⇒ Software Sources ;
在 Download from 中选择 Other ;
选择 China ⇒ mirrors.ustc.edu.cn ;
点击 Choose Server ;

http://mirrors.ustc.edu.cn/help/linuxmint.html


_________________
冷轩信

渠月 · QY

本人只会灌水,不负责回答问题

无聊可以点一下→ http://u.nu/ubuntu


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 求助无法安装媒体播放器
帖子发表于 : 2017-03-12 23:44 

注册: 2010-01-16 12:40
帖子: 42
送出感谢: 2
接收感谢: 0 次
qy117121 写道:
设置软件源啊 ,有软件中心吧
打开 Software Manager ,点击 Edit ⇒ Software Sources ;
在 Download from 中选择 Other ;
选择 China ⇒ mirrors.ustc.edu.cn ;
点击 Choose Server ;

http://mirrors.ustc.edu.cn/help/linuxmint.html

好了,mint的软件源设置是长这个样子的图片
上面说的源 我刚装好系统的时候就设置了。不过当时是自动嗅探,选择最快的源,我不知道是不是因为上下两个不一致。实际上换上那个源以后我还更新系统了来着,过程正常。晚上太晚了,我换回了默认源,又更新了些软件,然后smplayer也可以正常安装了。剩下的明天再折腾看看,我得睡了……


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 求助无法安装媒体播放器
帖子发表于 : 2017-03-13 7:09 

注册: 2010-01-16 12:40
帖子: 42
送出感谢: 2
接收感谢: 0 次
qy117121, 那个顺便问一下。昨天更新系统的时候,貌似是提示是否替换个什么文件来着,我没仔细看,就选择替换了。然后Windows的磁盘就无法挂载了。提示这个来着图片。但是,u盘什么的插上了还是直接挂载,然后另一个ubuntu的分区,也是点击下就直接挂载了。 还有 fdisk -l的结果
代码:
fdisk -l
fdisk: cannot open /dev/ram0: Permission denied
fdisk: cannot open /dev/ram1: Permission denied
fdisk: cannot open /dev/ram2: Permission denied
fdisk: cannot open /dev/ram3: Permission denied
fdisk: cannot open /dev/ram4: Permission denied
fdisk: cannot open /dev/ram5: Permission denied
fdisk: cannot open /dev/ram6: Permission denied
fdisk: cannot open /dev/ram7: Permission denied
fdisk: cannot open /dev/ram8: Permission denied
fdisk: cannot open /dev/ram9: Permission denied
fdisk: cannot open /dev/ram10: Permission denied
fdisk: cannot open /dev/ram11: Permission denied
fdisk: cannot open /dev/ram12: Permission denied
fdisk: cannot open /dev/ram13: Permission denied
fdisk: cannot open /dev/ram14: Permission denied
fdisk: cannot open /dev/ram15: Permission denied
fdisk: cannot open /dev/sda: Permission denied
fdisk: cannot open /dev/sdb: Permission denied
fdisk: cannot open /dev/mapper/fedora_bogon-swap: Permission denied
fdisk: cannot open /dev/mapper/fedora_bogon-root: Permission denied
fdisk: cannot open /dev/sdc: Permission denied

大侠知道怎么破么。。


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 求助无法安装媒体播放器
帖子发表于 : 2017-03-13 9:52 
头像

注册: 2007-12-14 13:40
帖子: 49862
地址: 志虚国乌由市
系统: Winbuntu
送出感谢: 29
接收感谢: 412
Win10快速关机选项,关掉就好了


_________________
冷轩信

渠月 · QY

本人只会灌水,不负责回答问题

无聊可以点一下→ http://u.nu/ubuntu


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 求助无法安装媒体播放器
帖子发表于 : 2017-03-13 10:56 

注册: 2009-08-04 16:33
帖子: 16735
送出感谢: 21
接收感谢: 1816
引用:
在网上查了下,说的都是ubuntu系统里,修改软件源的,但是这个系统不一样 没办法照着这个修改啊。

Linux Mint 雖然基於 Ubuntu 但是 建議只有使用 Update Manager 來 更新/升級/維護 你已安裝的系統及套件
避免使用 Ubuntu / Debian 的方法
這樣才不會損壞 Linux-Mint 獨特的 preference 與 dependency 設定關係

https://www.linuxmint.com/documentation ... h_18.0.pdf
Official User Guide
Linux Mint 18
Cinnamon Edition
P43
only one of them is recommended
Using the Update Manager


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 求助无法安装媒体播放器
帖子发表于 : 2017-03-14 0:30 

注册: 2010-01-16 12:40
帖子: 42
送出感谢: 2
接收感谢: 0 次
poloshiao 写道:
引用:
在网上查了下,说的都是ubuntu系统里,修改软件源的,但是这个系统不一样 没办法照着这个修改啊。

Linux Mint 雖然基於 Ubuntu 但是 建議只有使用 Update Manager 來 更新/升級/維護 你已安裝的系統及套件
避免使用 Ubuntu / Debian 的方法
這樣才不會損壞 Linux-Mint 獨特的 preference 與 dependency 設定關係

https://www.linuxmint.com/documentation ... h_18.0.pdf
Official User Guide
Linux Mint 18
Cinnamon Edition
P43
only one of them is recommended
Using the Update Manager

意思是只用系统升级管理器,不要自己用命令 update upgrade么?


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 求助无法安装媒体播放器
帖子发表于 : 2017-03-14 0:39 

注册: 2009-08-04 16:33
帖子: 16735
送出感谢: 21
接收感谢: 1816
引用:
意思是只用系统升级管理器,不要自己用命令 update upgrade么?

對 不推薦


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 求助无法安装媒体播放器
帖子发表于 : 2017-03-14 14:37 

注册: 2010-01-16 12:40
帖子: 42
送出感谢: 2
接收感谢: 0 次
poloshiao 写道:
引用:
意思是只用系统升级管理器,不要自己用命令 update upgrade么?

對 不推薦

好的 谢谢

通过我的 Nexus 6P 上的 Tapatalk发言


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译