当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 16.04.1 server无法识别到网卡,但recovery mode上enable network两次后可以
帖子发表于 : 2017-04-08 17:18 

注册: 2009-03-30 11:31
帖子: 52
送出感谢: 4
接收感谢: 0 次
平台是intel 8350的。
安装的16.04.1 64 server版本。
正常模式进去,无法识别网卡。
但通过recovery mode进去,选择两次enable network后(一次不行),recovery mode进入系统后,可以识别到网卡,能正常用。
但再次正常进去,仍然无法识别网卡。
好奇怪。
谢谢各位!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 16.04.1 server无法识别到网卡,但recovery mode上enable network两次后可以
帖子发表于 : 2017-04-08 17:58 

注册: 2009-03-30 11:31
帖子: 52
送出感谢: 4
接收感谢: 0 次
在安装的过程中,就无法识别到网卡设备。
反复试过,也无法识别。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 16.04.1 server无法识别到网卡,但recovery mode上enable network两次后可以
帖子发表于 : 2017-04-08 20:34 
头像

注册: 2011-03-20 13:12
帖子: 4552
地址: 山东省寿光县
系统: Debian
送出感谢: 106
接收感谢: 1009
0. 说明"网卡设备"时无线网卡还是有线网卡。
1. 在“正常模式进去,无法识别网卡”的情况下,执行以下指令设法将结果全部复制贴上来。
代码:
uname -a
cat /sys/class/dmi/id/{sys_vendor,product_name}
cat /sys/bus/sdio/devices/*/*
sudo lshw -numeric -C net
sudo rfkill list all


_________________
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 16.04.1 server无法识别到网卡,但recovery mode上enable network两次后可以
帖子发表于 : 2017-04-10 10:03 

注册: 2009-03-30 11:31
帖子: 52
送出感谢: 4
接收感谢: 0 次
这是一部分:


附件:
2.jpg
2.jpg [ 2.6 MiB | 被浏览 1565 次 ]

页首
 用户资料  
 
5 楼 
 文章标题 : Re: 16.04.1 server无法识别到网卡,但recovery mode上enable network两次后可以
帖子发表于 : 2017-04-10 10:14 

注册: 2009-03-30 11:31
帖子: 52
送出感谢: 4
接收感谢: 0 次
重新贴一下,前面的回复,可能图片太大


附件:
5.png
5.png [ 1.38 MiB | 被浏览 1556 次 ]

页首
 用户资料  
 
6 楼 
 文章标题 : Re: 16.04.1 server无法识别到网卡,但recovery mode上enable network两次后可以
帖子发表于 : 2017-04-10 10:15 

注册: 2009-03-30 11:31
帖子: 52
送出感谢: 4
接收感谢: 0 次
第二部分命令:


附件:
4.png
4.png [ 744.09 KiB | 被浏览 1550 次 ]

页首
 用户资料  
 
7 楼 
 文章标题 : Re: 16.04.1 server无法识别到网卡,但recovery mode上enable network两次后可以
帖子发表于 : 2017-04-10 10:45 

注册: 2009-03-30 11:31
帖子: 52
送出感谢: 4
接收感谢: 0 次
是有线网卡。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 16.04.1 server无法识别到网卡,但recovery mode上enable network两次后可以
帖子发表于 : 2017-04-10 11:14 

注册: 2009-03-30 11:31
帖子: 52
送出感谢: 4
接收感谢: 0 次
我在recovery mode中修复两次network之后,进入系统,发现有线网卡的名字叫:enx00e04c36c59d,在这种模式下,网卡正常,能ping www.baidu.com,但我在正常模式下进入系统,手动设置网卡ip,子网掩码,路由,可以ping通内网的其它IP,路由,但是ping不通www.baidu.com.


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 16.04.1 server无法识别到网卡,但recovery mode上enable network两次后可以
帖子发表于 : 2017-04-10 11:36 

注册: 2009-03-30 11:31
帖子: 52
送出感谢: 4
接收感谢: 0 次
再补充:手动设置后,能ping通外网的IP,应该是没有设置DNS。
但是,一个网卡的名字:enx00e04c36c59d ,太奇葩。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译