写入/etc/rc.local,屏保唤醒后没生效,如何让它一直作用?

Ubuntu手机、平板等ARM设备支持
回复
wanggaoqiu
帖子: 52
注册时间: 2009-03-30 11:31
送出感谢: 4 次
接收感谢: 0

写入/etc/rc.local,屏保唤醒后没生效,如何让它一直作用?

#1

帖子 wanggaoqiu » 2017-04-26 10:55

把加载蓝牙的命令写入此文件中,
系统一段时间,屏保,再输入密码进入系统后,竟然蓝牙又没了。也就是写入/etc/rc.local里的命令没生效。
如何破,让此文件一直生效?
谢谢!
wanggaoqiu
帖子: 52
注册时间: 2009-03-30 11:31
送出感谢: 4 次
接收感谢: 0

Re: 写入/etc/rc.local,屏保唤醒后没生效,如何让它一直作用?

#2

帖子 wanggaoqiu » 2017-04-26 11:00

大部分是好的。
发现偶尔一次,竟然没作用。
头像
vickycq
论坛版主
帖子: 4552
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 994 次
联系:

Re: 写入/etc/rc.local,屏保唤醒后没生效,如何让它一直作用?

#3

帖子 vickycq » 2017-04-26 13:10

wanggaoqiu 写了:也就是写入/etc/rc.local里的命令没生效。
如果您运行 15.04 及以上的 Ubuntu 操作系统,/etc/rc.local 会在系统启动时进入预设 target 的末尾被执行一次。与“屏保唤醒”没有关系
wanggaoqiu 写了:大部分是好的。
可能原因 并不是每次“屏保”都会导致蓝牙失效
wanggaoqiu 写了:系统一段时间,屏保,再输入密码进入系统后
在这段时间内电脑处于何种状态?(仅屏保/待机/休眠?)
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
头像
dwl301
帖子: 1074
注册时间: 2007-04-14 11:17
送出感谢: 0
接收感谢: 3 次

Re: 写入/etc/rc.local,屏保唤醒后没生效,如何让它一直作用?

#4

帖子 dwl301 » 2017-04-26 15:48

rc.local仅在开机启动的时候执行一次。。。
MSI GE60 2OE-455XCN
Intel Core i7-4810MQ
NVIDIA GeForce GTX 765M / 2G GDDR5
2x8GB DDRIII(L) 1600MHz
PLEXTOR 256G MSATA (PX-256M6M)
SATA 750G 7200RPM
SATA 1T 7200RPM
15.6" FHD 1920×1080
wanggaoqiu
帖子: 52
注册时间: 2009-03-30 11:31
送出感谢: 4 次
接收感谢: 0

Re: 写入/etc/rc.local,屏保唤醒后没生效,如何让它一直作用?

#5

帖子 wanggaoqiu » 2017-04-26 17:51

就是输入密码进入系统后,什么也没做,大概五分钟后,黑屏,然后再次输入密码进去,发现蓝牙没有了。

以前也发现一次,设置IP,有一次重启进入到系统,竟然没生效(呵呵,与本次不一样)。
wanggaoqiu
帖子: 52
注册时间: 2009-03-30 11:31
送出感谢: 4 次
接收感谢: 0

Re: 写入/etc/rc.local,屏保唤醒后没生效,如何让它一直作用?

#6

帖子 wanggaoqiu » 2017-04-26 17:52

系统是:14.04.4
头像
vickycq
论坛版主
帖子: 4552
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 994 次
联系:

Re: 写入/etc/rc.local,屏保唤醒后没生效,如何让它一直作用?

#7

帖子 vickycq » 2017-04-26 17:55

wanggaoqiu 写了:就是输入密码进入系统后,什么也没做,大概五分钟后,黑屏
黑屏后,电脑处于何种状态?(仅屏保/待机/休眠?)
查看电源管理器的设定。
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
wanggaoqiu
帖子: 52
注册时间: 2009-03-30 11:31
送出感谢: 4 次
接收感谢: 0

Re: 写入/etc/rc.local,屏保唤醒后没生效,如何让它一直作用?

#8

帖子 wanggaoqiu » 2017-04-27 10:49

昨晚啥也没干,让它待机一晚。
今天来,机器正常。
但重启机器后,蓝牙又消失了。
反复折腾几次,都消失。
最后,再重启,又好了。
好奇怪。

电源设置这里:
suspend when inactive for : Don't suspend
when the lid is closed : Suspend (这里显示不可选,但默认是它)

现在我这项改为:when the lid is closed : Do nothing

/etc/rc.local中加入的命令为如下:
rmmod /lib/modules/$(uname -r)/kernel/drivers/bluetooth/rtk_bt_usb.ko
rmmod /lib/modules/$(uname -r)/kernel/drivers/bluetooth/hci_uart.ko

insmod /lib/modules/$(uname -r)/kernel/drivers/bluetooth/rtk_bt_usb.ko
insmod /lib/modules/$(uname -r)/kernel/drivers/bluetooth/hci_uart.ko

sleep 1
for((i=1;i<30;i++))
do
echo "try the $i time"
var2=`ps -A | grep "rtk_hciattach" | cut -c 2-5`
sudo kill -9 $var2
sudo rmmod enable_rtl8723bs_bt
sudo insmod /lib/modules/$(uname -r)/kernel/drivers/bluetooth/enable_rtl8723bs_bt.ko
sudo rtk_hciattach -n -s 115200 ttyS4 rtk_h5 > hciattach.txt 2>&1 &
sleep 5
var1=`hciconfig -a| grep "Manufacturer"`
if [ -z "$var1" ] ; then
echo "start BT failed"
else
break
fi
done

rfkill block bluetooth
sleep 1
rfkill unblock bluetooth
回复

回到 “手机和平板”