当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装sougou输入法的问题
帖子发表于 : 2017-06-05 14:59 

注册: 2011-05-01 20:18
帖子: 92
送出感谢: 2
接收感谢: 0 次
各位好,
我想问下为什么我的sougou输入法装不上,我用如下命令:
sudo gdebi sogoupinyin_2.1.0.0086_amd64.deb

Reading package lists... Done
Building dependency tree
Reading state information... Done
Building data structures... Done
Building data structures... Done
This package is uninstallable
Dependency is not satisfiable: block-sogou-dkms

总是提示缺少这个block*的东西,请问如何解决?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 安装sougou输入法的问题
帖子发表于 : 2017-06-05 15:10 
头像

注册: 2007-12-14 13:40
帖子: 49730
地址: 志虚国乌由市
系统: Winbuntu
送出感谢: 29
接收感谢: 407
看了下依赖里应该是没有这个block-sogou-dkms的啊,或者下载下面的deb安装了试试
http://packages.deepin.com/deepin/pool/ ... ogou-dkms/


_________________
冷轩信

渠月 · QY

本人只会灌水,不负责回答问题


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 安装sougou输入法的问题
帖子发表于 : 2017-06-05 15:45 
头像

注册: 2011-03-20 13:12
帖子: 4151
地址: 山东省寿光县
系统: Debian
送出感谢: 100
接收感谢: 918
你从哪下的 deb 包。官方的 deb 包可没有这种依赖。


_________________
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户的加入


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 安装sougou输入法的问题
帖子发表于 : 2017-06-05 16:21 
头像

注册: 2007-11-25 13:29
帖子: 7077
地址: 新疆博乐
系统: 14.04/16.04/Fedroa22
送出感谢: 35
接收感谢: 94
直接在文件夹里右键打开方式gdebi,自动安装依赖,fcitx安装好了没


_________________
===新手请看===
Ubuntu 安装 | Ubuntu12.04/14.04/16.04 桌面操作指南
··Ubuntu16.04 安装图文教程(超简单)
····有时间就静下心来——折腾:)


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 安装sougou输入法的问题
帖子发表于 : 2017-06-08 16:34 

注册: 2011-05-01 20:18
帖子: 92
送出感谢: 2
接收感谢: 0 次
按照2楼的说法安装了这个dkms,出现如下问题,fcitx我应该装好了。
luhang@swarm:~/Downloads$ sudo gdebi sogoupinyin_2.1.0.0086_amd64.deb
[sudo] password for luhang:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Building data structures... Done
Building data structures... Done
This package is uninstallable
Dependency is not satisfiable: libfcitx-config4 (>= 4.2.7)

apt-get install libfcitx-config4又提示没有这个软件包,是不是在其他软件包里包含这个?


最后由 sh42 编辑于 2017-06-08 16:42,总共编辑了 2 次

页首
 用户资料  
 
6 楼 
 文章标题 : Re: 安装sougou输入法的问题
帖子发表于 : 2017-06-08 16:35 

注册: 2011-05-01 20:18
帖子: 92
送出感谢: 2
接收感谢: 0 次
sougou官网下载的


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 安装sougou输入法的问题
帖子发表于 : 2017-06-08 16:52 
头像

注册: 2011-03-20 13:12
帖子: 4151
地址: 山东省寿光县
系统: Debian
送出感谢: 100
接收感谢: 918
sh42 写道:
sougou官网下载的

确定吗?明明没有的。
http://pinyin.sogou.com/linux/

另外你用的是 Ubuntu 吗,什么版本


_________________
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户的加入


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 安装sougou输入法的问题
帖子发表于 : 2017-06-08 17:17 

注册: 2011-05-01 20:18
帖子: 92
送出感谢: 2
接收感谢: 0 次
vickycq 写道:
sh42 写道:
sougou官网下载的

确定吗?明明没有的。
http://pinyin.sogou.com/linux/

另外你用的是 Ubuntu 吗,什么版本


我用的xubuntu 14.04,我下的就是这个链接里的。后来发现应该是软件包的依赖没对,以前都没这个问题。。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 安装sougou输入法的问题
帖子发表于 : 2017-06-08 17:20 

注册: 2011-05-01 20:18
帖子: 92
送出感谢: 2
接收感谢: 0 次
我的版本是14.04,fcitx的版本是4.2.8.3,不知道为什么sogou要求必须4.2.9.1,这是16.04的版本


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 安装sougou输入法的问题
帖子发表于 : 2017-06-09 3:26 
头像

注册: 2012-11-14 9:34
帖子: 465
系统: UM 16.04.2/17.04
送出感谢: 1
接收感谢: 33
sh42 写道:
我的版本是14.04,fcitx的版本是4.2.8.3,不知道为什么sogou要求必须4.2.9.1,这是16.04的版本


这么重要的工具,为什么要用闭源的软件呢?

这并不是“开源” vs “闭源” 的问题,而是,根据我们过去广泛使用搜狗的经验,问题常常(more than several times)莫名其妙的发生,尤其是在系统更新以后。(因为安全性的考量,系统必须经常跟新,Windows系统也是一样。一更新,就祈祷搜狗不会出事。)

“不管白猫黑猫,能捉到老鼠就是好猫”。我个人对闭源软件,绝对没有理念上的排斥。事实上,如果Linux桌面要能够被广泛的接受,闭源软件必须成为Linux系统里一个很重要的元件。

我个人认为,闭源的大宗应用软件像搜狗,wps等,最大的问题是,这些公司对Linux社群并不当作一回事*。从投资观点来看,他们必须先占个位子(presence),以后如果政府决定大量启用Linux系统时,就可以“发”了。

最小的投资,以争取以后可能最大的报酬,我非常支持搜狗及wps的做法。一般人使用搜狗,当然不会也不必去管这些“大人”的事,不过我们使用Linux桌面的宗旨,主要是尽一份力量,累积一些“有用的“使用者经验,希望能帮助以后的推广(不是为了推广而推广,而是深信Linux桌面对一般民众及公司企业,比Windows要好多了)。

闭源的大宗应用软件像搜狗,wps等,也许比较容易被从Windows转过来的使用者接受,但因为这些无法控制的稳定性的问题,推广起来会影响到我们的“信用”;this is a big "No No"。

另外,开源的大宗应用软件像ibus-pinyin及LibreOffice等,经过这么多年来持续的社区化经营,已有他们特殊的强点。Linux版的搜狗及wps跟他们的Windows版比起来,品质上相差非常大,Linux桌面永远会是次等公民(secondary citizen)。没有政府的领导或公司的IP人员会愿意建议使用次等产品的。

其实,如果我们能同心协力支持像ibus及LibreOffice等的开源大宗应用软件,让Linux桌面能被广泛接受,对搜狗及wps也会有好处。毕竟,如果能成功的话,Linux桌面这个市场实在太大了。

借题发挥,罗嗦几句,请不要介意。 :Cool

* 搜狗及wps的确跟UbuntuKylin有一些正式的合作关系(麒麟团队把这个当作他们最大的卖点)。不过我们在使用搜狗时,每次碰到问题还是要到这个论坛来寻求帮助。So much for the "正式的合作关系"。


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 安装sougou输入法的问题
帖子发表于 : 2017-06-09 10:43 

注册: 2011-05-01 20:18
帖子: 92
送出感谢: 2
接收感谢: 0 次
这个问题搞清楚了,如果还想用14.04+sougou的话,需要安装0082版本,0086是为16.04打造的。装0082没有任何依赖问题,希望后来的朋友引以为鉴


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译