台式机安装过Ubuntu14.04后无线网卡驱动安装不了,无法上网

Trusty Tahr (长期支持)
回复
老司机带带我
帖子: 8
注册时间: 2016-08-12 21:50
系统: WIN10
送出感谢: 0
接收感谢: 0

台式机安装过Ubuntu14.04后无线网卡驱动安装不了,无法上网

#1

帖子 老司机带带我 » 2016-08-12 22:01

老司机能给个解决办法吗?我用的网卡是MERCURY,型号是MW150UH,我觉得是没有装无线网卡驱动的原因,可是这个网卡驱动文件是exe格式的,Ubuntu系统装不了,现在台式机没法上网也别说下载wine来读取exe文件了,现在不知道该怎么办咯 :Cry
poloshiao
论坛版主
帖子: 18126
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1934 次

Re: 台式机安装过Ubuntu14.04后无线网卡驱动安装不了,无法上网

#2

帖子 poloshiao » 2016-08-13 4:36

可是这个网卡驱动文件是exe格式的
參閱
https://help.ubuntu.com/community/WifiD ... diswrapper
Ndiswrapper is a Linux module which allows Ubuntu to use the Windows driver for wireless cards.
头像
vickycq
论坛版主
帖子: 4507
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 994 次
联系:

Re: 台式机安装过Ubuntu14.04后无线网卡驱动安装不了,无法上网

#3

帖子 vickycq » 2016-08-13 7:11

老司机带带我 写了:我用的网卡是MERCURY,型号是MW150UH,我觉得是没有装无线网卡驱动的原因
插入网卡执行以下命令将结果全部复制贴上来

代码: 全选

lsusb
sudo lshw -C net
老司机带带我 写了:可是这个网卡驱动文件是exe格式的,Ubuntu系统装不了
方向路线错误。
老司机带带我 写了:下载wine来读取exe文件
不适用于驱动程序。
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
老司机带带我
帖子: 8
注册时间: 2016-08-12 21:50
系统: WIN10
送出感谢: 0
接收感谢: 0

Re: 台式机安装过Ubuntu14.04后无线网卡驱动安装不了,无法上网

#4

帖子 老司机带带我 » 2016-08-14 12:19

poloshiao 写了:
可是这个网卡驱动文件是exe格式的
參閱
https://help.ubuntu.com/community/WifiD ... diswrapper
Ndiswrapper is a Linux module which allows Ubuntu to use the Windows driver for wireless cards.
大哥全是英文看不懂啊
老司机带带我
帖子: 8
注册时间: 2016-08-12 21:50
系统: WIN10
送出感谢: 0
接收感谢: 0

Re: 台式机安装过Ubuntu14.04后无线网卡驱动安装不了,无法上网

#5

帖子 老司机带带我 » 2016-08-14 12:27

vickycq 写了:
老司机带带我 写了:我用的网卡是MERCURY,型号是MW150UH,我觉得是没有装无线网卡驱动的原因
插入网卡执行以下命令将结果全部复制贴上来

代码: 全选

lsusb
sudo lshw -C net
老司机带带我 写了:可是这个网卡驱动文件是exe格式的,Ubuntu系统装不了
方向路线错误。
老司机带带我 写了:下载wine来读取exe文件
不适用于驱动程序。
lol@lol-Lenovo-Product:~$ lsusb
Bus 002 Device 002: ID 8087:8000 Intel Corp.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 17ef:6019 Lenovo
Bus 003 Device 002: ID 148f:2878 Ralink Technology, Corp.
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
lol@lol-Lenovo-Product:~$ sudo lshw -C net
[sudo] password for lol:
*-network
description: Ethernet interface
product: Ethernet Connection I217-LM
vendor: Intel Corporation
physical id: 19
bus info: pci@0000:00:19.0
logical name: eth0
version: 04
serial: 6c:0b:84:6c:cb:0e
capacity: 1Gbit/s
width: 32 bits
clock: 33MHz
capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=2.3.2-k firmware=0.12-4 latency=0 link=no multicast=yes port=twisted pair
resources: irq:43 memory:f7100000-f711ffff memory:f7139000-f7139fff ioport:f040(size=32)
lol@lol-Lenovo-Product:~$
头像
vickycq
论坛版主
帖子: 4507
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 994 次
联系:

Re: 台式机安装过Ubuntu14.04后无线网卡驱动安装不了,无法上网

#6

帖子 vickycq » 2016-08-14 14:32

老司机带带我 写了:Bus 003 Device 002: ID 148f:2878 Ralink Technology, Corp.
按以下顺序执行
1. 打开一个终端
2. 插入网卡后等待15秒
3. 执行以下指令将结果全部复制贴上来

代码: 全选

dmesg | tail -n 40
usb-devices
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
老司机带带我
帖子: 8
注册时间: 2016-08-12 21:50
系统: WIN10
送出感谢: 0
接收感谢: 0

Re: 台式机安装过Ubuntu14.04后无线网卡驱动安装不了,无法上网

#7

帖子 老司机带带我 » 2016-08-14 14:42

vickycq 写了:
老司机带带我 写了:Bus 003 Device 002: ID 148f:2878 Ralink Technology, Corp.
按以下顺序执行
1. 打开一个终端
2. 插入网卡后等待15秒
3. 执行以下指令将结果全部复制贴上来

代码: 全选

dmesg | tail -n 40
usb-devices
大哥换QQ聊吧,这论坛上发好吃力,QQ私信给我吧跪谢
头像
vickycq
论坛版主
帖子: 4507
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 994 次
联系:

Re: 台式机安装过Ubuntu14.04后无线网卡驱动安装不了,无法上网

#8

帖子 vickycq » 2016-08-14 14:55

老司机带带我 写了:大哥换QQ聊吧,这论坛上发好吃力,QQ私信给我吧跪谢
抱歉,个人不方便使用 QQ。建议使用论坛,方便其它有相同问题的网友。自己付出一些精力也算回馈社区。
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
老司机带带我
帖子: 8
注册时间: 2016-08-12 21:50
系统: WIN10
送出感谢: 0
接收感谢: 0

Re: 台式机安装过Ubuntu14.04后无线网卡驱动安装不了,无法上网

#9

帖子 老司机带带我 » 2016-08-14 15:00

vickycq 写了:
老司机带带我 写了:大哥换QQ聊吧,这论坛上发好吃力,QQ私信给我吧跪谢
抱歉,个人不方便使用 QQ。建议使用论坛,方便其它有相同问题的网友。自己付出一些精力也算回馈社区。
lol@lol-Lenovo-Product:~$ dmesg | tail -n 40
[ 9.619455] Bluetooth: Core ver 2.17
[ 9.619466] NET: Registered protocol family 31
[ 9.619467] Bluetooth: HCI device and connection manager initialized
[ 9.619473] Bluetooth: HCI socket layer initialized
[ 9.619475] Bluetooth: L2CAP socket layer initialized
[ 9.619477] Bluetooth: SCO socket layer initialized
[ 9.623478] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 9.623480] Bluetooth: BNEP filters: protocol multicast
[ 9.623486] Bluetooth: BNEP socket layer initialized
[ 9.623759] Bluetooth: RFCOMM TTY layer initialized
[ 9.623763] Bluetooth: RFCOMM socket layer initialized
[ 9.623766] Bluetooth: RFCOMM ver 1.11
[ 9.723697] init: cups main process (726) killed by HUP signal
[ 9.723704] init: cups main process ended, respawning
[ 10.964304] e1000e 0000:00:19.0: irq 43 for MSI/MSI-X
[ 11.067453] e1000e 0000:00:19.0: irq 43 for MSI/MSI-X
[ 11.067543] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 11.067716] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 11.384664] init: plymouth-upstart-bridge main process ended, respawning
[ 11.407799] init: plymouth-upstart-bridge main process ended, respawning
[ 39.732557] audit_printk_skb: 168 callbacks suppressed
[ 39.732559] type=1400 audit(1471157712.594:68): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/cups/backend/cups-pdf" pid=1465 comm="apparmor_parser"
[ 39.732563] type=1400 audit(1471157712.594:69): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/sbin/cupsd" pid=1465 comm="apparmor_parser"
[ 39.732780] type=1400 audit(1471157712.594:70): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/sbin/cupsd" pid=1465 comm="apparmor_parser"
[ 55.023115] ISO 9660 Extensions: Microsoft Joliet Level 3
[ 55.046042] ISOFS: changing to secondary root
[ 73.762526] usb 3-8: USB disconnect, device number 2
[ 92.325936] usb 3-8: new high-speed USB device number 4 using xhci_hcd
[ 92.342542] usb 3-8: New USB device found, idVendor=148f, idProduct=2878
[ 92.342552] usb 3-8: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 92.342557] usb 3-8: Product: \xffffffd0\xffffff89\xffffff89
[ 92.342561] usb 3-8: Manufacturer: \xffffffd0\xffffff89\xffffff89
[ 92.343114] usb-storage 3-8:1.0: USB Mass Storage device detected
[ 92.344715] scsi6 : usb-storage 3-8:1.0
[ 93.342232] scsi 6:0:0:0: CD-ROM MediaTek Flash autorun 0.01 PQ: 0 ANSI: 0 CCS
[ 93.343093] sr1: scsi3-mmc drive: 52x/52x cd/rw xa/form2 cdda tray
[ 93.343352] sr 6:0:0:0: Attached scsi CD-ROM sr1
[ 93.343505] sr 6:0:0:0: Attached scsi generic sg2 type 5
[ 93.699900] ISO 9660 Extensions: Microsoft Joliet Level 3
[ 93.709473] ISOFS: changing to secondary root
lol@lol-Lenovo-Product:~$ usb-devices

T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=480 MxCh= 3
D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=1d6b ProdID=0002 Rev=03.13
S: Manufacturer=Linux 3.13.0-24-generic ehci_hcd
S: Product=EHCI Host Controller
S: SerialNumber=0000:00:1a.0
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub

T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=480 MxCh= 6
D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS=64 #Cfgs= 1
P: Vendor=8087 ProdID=8008 Rev=00.04
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub

T: Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=480 MxCh= 3
D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=1d6b ProdID=0002 Rev=03.13
S: Manufacturer=Linux 3.13.0-24-generic ehci_hcd
S: Product=EHCI Host Controller
S: SerialNumber=0000:00:1d.0
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub

T: Bus=02 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=480 MxCh= 8
D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS=64 #Cfgs= 1
P: Vendor=8087 ProdID=8000 Rev=00.04
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub

T: Bus=03 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=480 MxCh=15
D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS=64 #Cfgs= 1
P: Vendor=1d6b ProdID=0002 Rev=03.13
S: Manufacturer=Linux 3.13.0-24-generic xhci_hcd
S: Product=xHCI Host Controller
S: SerialNumber=0000:00:14.0
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub

T: Bus=03 Lev=01 Prnt=01 Port=07 Cnt=01 Dev#= 4 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=148f ProdID=2878 Rev=00.01
S: Manufacturer=袎
S: Product=袎
C: #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=32mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage

T: Bus=03 Lev=01 Prnt=01 Port=08 Cnt=02 Dev#= 3 Spd=1.5 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=17ef ProdID=6019 Rev=01.00
S: Manufacturer=PixArt
S: Product=Lenovo USB Optical Mouse
C: #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr=100mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=03(HID ) Sub=01 Prot=02 Driver=usbhid

T: Bus=04 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=5000 MxCh= 6
D: Ver= 3.00 Cls=09(hub ) Sub=00 Prot=03 MxPS= 9 #Cfgs= 1
P: Vendor=1d6b ProdID=0003 Rev=03.13
S: Manufacturer=Linux 3.13.0-24-generic xhci_hcd
S: Product=xHCI Host Controller
S: SerialNumber=0000:00:14.0
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
lol@lol-Lenovo-Product:~$
头像
vickycq
论坛版主
帖子: 4507
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 994 次
联系:

Re: 台式机安装过Ubuntu14.04后无线网卡驱动安装不了,无法上网

#10

帖子 vickycq » 2016-08-14 15:17

老司机带带我 写了:dmesg | tail -n 40
[ 92.342542] usb 3-8: New USB device found, idVendor=148f, idProduct=2878
[ 92.343114] usb-storage 3-8:1.0: USB Mass Storage device detected
[ 93.342232] scsi 6:0:0:0: CD-ROM MediaTek Flash autorun 0.01 PQ: 0 ANSI: 0 CCS
[ 93.343352] sr 6:0:0:0: Attached scsi CD-ROM sr1
设备处于 USB-CDROM 模式,被识别为光盘。
老司机带带我 写了:usb-devices
T: Bus=03 Lev=01 Prnt=01 Port=07 Cnt=01 Dev#= 4 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=148f ProdID=2878 Rev=00.01
S: Manufacturer=袎
S: Product=袎
C: #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=32mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
进一步印证设备处于 USB-CDROM 模式。


大致步骤:
1. 使用 usb-modeswitch 将设备切换到无线网卡模式;
2. 截至现在,此设备 148f:2878 未在 drivers/net/wireless/ralink/rt2x00/rt2800usb.c 中列出。因此需要自行寻找合适驱动程序。

可能存在的问题:
1. 无法使用 usb-modeswitch 将设备切换到无线网卡模式;
2. 经查,官方驱动 2010_0709_RT2870_Linux_STA_v2.4.0.1.tar.bz2 中亦未列出 148f:2878。即使手动添加此 ID,由于官方驱动已有 4~6 年未更新,能否在较新的内核(3.13~4.4)上编译通过?还要画一个大大的问号。

综上,较好的办法是重新购买一块驱动情况经过验证的 USB 无线网卡。对于 Ralink,可选择 RT5370 方案,基本可以即插即用。

参考
https://www.mail-archive.com/users@rt2x ... 00362.html
https://ubuntuforums.org/showthread.php?t=2152658
https://ubuntuforums.org/showthread.php ... 423&page=3
https://wikidevi.com/wiki/Rt2800usb
https://wireless.wiki.kernel.org/en/use ... sb/devices
https://github.com/torvalds/linux/blob/ ... t2800usb.c
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
老司机带带我
帖子: 8
注册时间: 2016-08-12 21:50
系统: WIN10
送出感谢: 0
接收感谢: 0

Re: 台式机安装过Ubuntu14.04后无线网卡驱动安装不了,无法上网

#11

帖子 老司机带带我 » 2016-08-14 15:30

vickycq 写了:
老司机带带我 写了:dmesg | tail -n 40
[ 92.342542] usb 3-8: New USB device found, idVendor=148f, idProduct=2878
[ 92.343114] usb-storage 3-8:1.0: USB Mass Storage device detected
[ 93.342232] scsi 6:0:0:0: CD-ROM MediaTek Flash autorun 0.01 PQ: 0 ANSI: 0 CCS
[ 93.343352] sr 6:0:0:0: Attached scsi CD-ROM sr1
设备处于 USB-CDROM 模式,被识别为光盘。
老司机带带我 写了:usb-devices
T: Bus=03 Lev=01 Prnt=01 Port=07 Cnt=01 Dev#= 4 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=148f ProdID=2878 Rev=00.01
S: Manufacturer=袎
S: Product=袎
C: #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=32mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
进一步印证设备处于 USB-CDROM 模式。


大致步骤:
1. 使用 usb-modeswitch 将设备切换到无线网卡模式;
2. 截至现在,此设备 148f:2878 未在 drivers/net/wireless/ralink/rt2x00/rt2800usb.c 中列出。因此需要自行寻找合适驱动程序。

可能存在的问题:
1. 无法使用 usb-modeswitch 将设备切换到无线网卡模式;
2. 经查,官方驱动 2010_0709_RT2870_Linux_STA_v2.4.0.1.tar.bz2 中亦未列出 148f:2878。即使手动添加此 ID,由于官方驱动已有 4~6 年未更新,能否在较新的内核(3.13~4.4)上编译通过?还要画一个大大的问号。

综上,较好的办法是重新购买一块驱动情况经过验证的 USB 无线网卡。对于 Ralink,可选择 RT5370 方案,基本可以即插即用。

参考
https://www.mail-archive.com/users@rt2x ... 00362.html
https://ubuntuforums.org/showthread.php?t=2152658
https://ubuntuforums.org/showthread.php ... 423&page=3
https://wikidevi.com/wiki/Rt2800usb
https://wireless.wiki.kernel.org/en/use ... sb/devices
https://github.com/torvalds/linux/blob/ ... t2800usb.c
我换了个网卡果然解决了,万分感谢
Bigsonge
帖子: 1
注册时间: 2016-11-19 16:21
系统: Linux mint
送出感谢: 0
接收感谢: 0

Re: 台式机安装过Ubuntu14.04后无线网卡驱动安装不了,无法上网

#12

帖子 Bigsonge » 2016-11-19 16:39

老司机啊,感谢细心的解答!!我也是在台式机上安装MW150UH,刚插入的时候会识别为CD-ROM,但是我卸载lsusb之后会这样:
Bus 001 Device 008: ID 148f:7601 Ralink Technology, Corp. MT7601U Wireless Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
,然后去找了MT7601U的驱动装老,还是不能用,,按照你上面的步骤输入的结果依次如下:
~$ sudo lshw -C net

*-network
description: Ethernet interface
product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:02:00.0
logical name: ens33
version: 01
serial: 00:1e:90:0a:b7:07
size: 100Mbit/s
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: pm vpd msi pciexpress bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=172.16.33.101 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
resources: irq:26 ioport:e800(size=256) memory:febff000-febfffff memory:febc0000-febdffff

~$ dmesg | tail -n 40

[ 558.528735] scsi 4:0:0:0: CD-ROM MediaTek Flash autorun 0.01 PQ: 0 ANSI: 0 CCS
[ 558.535620] sr 4:0:0:0: [sr0] scsi3-mmc drive: 52x/52x cd/rw xa/form2 cdda tray
[ 558.535627] cdrom: Uniform CD-ROM driver Revision: 3.20
[ 558.535891] sr 4:0:0:0: Attached scsi CD-ROM sr0
[ 558.536871] sr 4:0:0:0: Attached scsi generic sg1 type 5
[ 592.257494] ISO 9660 Extensions: Microsoft Joliet Level 3
[ 592.257911] usb 1-3: USB disconnect, device number 7
[ 592.315974] ISOFS: unable to read i-node block
[ 592.315987] isofs_fill_super: get root inode failed
[ 592.692048] usb 1-3: new high-speed USB device number 8 using ehci-pci
[ 592.835627] usb 1-3: New USB device found, idVendor=148f, idProduct=7601
[ 592.835634] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 592.835638] usb 1-3: Product: 802.11 n WLAN
[ 592.835641] usb 1-3: Manufacturer: MediaTek
[ 592.835644] usb 1-3: SerialNumber: 1.0
[ 594.356021] usb 1-3: reset high-speed USB device number 8 using ehci-pci
[ 594.464445] cfg80211: World regulatory domain updated:
[ 594.464452] cfg80211: DFS Master region: unset
[ 594.464454] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[ 594.464458] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[ 594.464461] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[ 594.464464] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[ 594.464468] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[ 594.464472] cfg80211: (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[ 594.464475] cfg80211: (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[ 594.464478] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[ 594.464481] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[ 594.490852] mt7601u 1-3:1.0: ASIC revision: 76010001 MAC revision: 76010500
[ 594.501663] mt7601u 1-3:1.0: Firmware Version: 0.1.00 Build: 7640 Build time: 201302052146____
[ 597.956043] mt7601u 1-3:1.0: Vendor request req:07 off:09a8 failed:-110
[ 601.076049] mt7601u 1-3:1.0: Vendor request req:02 off:09a8 failed:-110
[ 604.196045] mt7601u 1-3:1.0: Vendor request req:07 off:0734 failed:-110
[ 607.316028] mt7601u 1-3:1.0: Vendor request req:42 off:0230 failed:-110
[ 610.436042] mt7601u 1-3:1.0: Vendor request req:07 off:0080 failed:-110
[ 613.556053] mt7601u 1-3:1.0: Vendor request req:02 off:0080 failed:-110
[ 616.676042] mt7601u 1-3:1.0: Vendor request req:02 off:0080 failed:-110
[ 616.676101] mt7601u: probe of 1-3:1.0 failed with error -110
[ 616.682965] usbcore: registered new interface driver mt7601u
[ 953.911679] perf interrupt took too long (5003 > 5000), lowering kernel.perf_event_max_sample_rate to 25000
[ 1840.363589] device ens33 entered promiscuous mode

~$ usb-devices

T: Bus=01 Lev=01 Prnt=01 Port=02 Cnt=01 Dev#= 8 Spd=480 MxCh= 0
D: Ver= 2.01 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=148f ProdID=7601 Rev=00.00
S: Manufacturer=MediaTek
S: Product=802.11 n WLAN
S: SerialNumber=1.0
C: #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=160mA
I: If#= 0 Alt= 0 #EPs= 8 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)


系统是Ubuntu16.04LTS, 老司机可以帮忙看看吗?非常感谢啦 :Sad
gwt600
帖子: 14
注册时间: 2017-09-21 15:41
系统: 4.10.0-35-generic
送出感谢: 1 次
接收感谢: 0

Re: 台式机安装过Ubuntu14.04后无线网卡驱动安装不了,无法上网

#13

帖子 gwt600 » 2017-09-21 16:11

[quote="vickycq"][quote="老司机带带我"]大哥换QQ聊吧,这论坛上发好吃力,QQ私信给我吧跪谢[/quote]
抱歉,个人不方便使用 QQ。建议使用论坛,方便其它有相同问题的网友。自己付出一些精力也算回馈社区。[/quote]
非常感谢 vickycq 这位大哥的这种公开的精神,我也遇到了类是的问题,看了你们的讨论,给了我很多启发,把通往问题的道路更进了一部。把自己的有限获得给大家分享,希望对大家有所帮助。
首先,我确定老司机帮帮我的网卡应该是一块免驱动,我也买来块免驱动安装的网卡。在没有改变网卡的usb模式前,通过lsusb 得出
tommy@tommy-System-Product-Name:~$ lsusb
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 002: ID 17ef:602e Lenovo
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 148f:2878 Ralink Technology, Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
得出的是一块,148f:2878 Ralink Technology, Corp 的网卡,然后通过更改USB——modelswich属性(我是直接通过桌面的图标,选择把弹出)。
在使用lsusb得出。
tommy@tommy-System-Product-Name:~$ lsusb
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 002: ID 17ef:602e Lenovo
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 148f:7601 Ralink Technology, Corp. MT7601U Wireless Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
这回是148f:7601 Ralink Technology, Corp. MT7601U Wireless Adapter,遮盖才是最终正确的wifi网卡驱动。在查找遮盖型号的驱动安装就可以了,希望对大家有所帮助。感谢 vickycq ,公开精神。
mgqqlwq
帖子: 74
注册时间: 2013-06-18 17:26
送出感谢: 1 次
接收感谢: 0

Re: 台式机安装过Ubuntu14.04后无线网卡驱动安装不了,无法上网

#14

帖子 mgqqlwq » 2018-03-29 22:43

gwt600 写了:
vickycq 写了:
老司机带带我 写了:大哥换QQ聊吧,这论坛上发好吃力,QQ私信给我吧跪谢
抱歉,个人不方便使用 QQ。建议使用论坛,方便其它有相同问题的网友。自己付出一些精力也算回馈社区。
非常感谢 vickycq 这位大哥的这种公开的精神,我也遇到了类是的问题,看了你们的讨论,给了我很多启发,把通往问题的道路更进了一部。把自己的有限获得给大家分享,希望对大家有所帮助。
首先,我确定老司机帮帮我的网卡应该是一块免驱动,我也买来块免驱动安装的网卡。在没有改变网卡的usb模式前,通过lsusb 得出
tommy@tommy-System-Product-Name:~$ lsusb
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 002: ID 17ef:602e Lenovo
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 148f:2878 Ralink Technology, Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
得出的是一块,148f:2878 Ralink Technology, Corp 的网卡,然后通过更改USB——modelswich属性(我是直接通过桌面的图标,选择把弹出)。
在使用lsusb得出。
tommy@tommy-System-Product-Name:~$ lsusb
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 002: ID 17ef:602e Lenovo
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 148f:7601 Ralink Technology, Corp. MT7601U Wireless Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
这回是148f:7601 Ralink Technology, Corp. MT7601U Wireless Adapter,遮盖才是最终正确的wifi网卡驱动。在查找遮盖型号的驱动安装就可以了,希望对大家有所帮助。感谢 vickycq ,公开精神。
您好!我的这个腾达的无线网卡就是您说的这种情况,但是找了很多mt7601u的帖子,都没有成功,请问您安装成功这个驱动了吗?能否分享一下稍微详细点的步骤呢?
red_archer
帖子: 1
注册时间: 2018-07-28 15:25
系统: windows linux
送出感谢: 0
接收感谢: 0

Re: 台式机安装过Ubuntu14.04后无线网卡驱动安装不了,无法上网

#15

帖子 red_archer » 2018-07-28 15:28

我这边在ubuntu下安装了个windows虚拟机,然后把无线网卡连到windows10,等Removable devices 中出现"Ralink 802.11 n WLAN"得时候,再断开,ubuntu就切换成网卡模式了 :Haha
回复

回到 “Ubuntu 14.04 LTS”