当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu如何禁用F1弹出帮助?
帖子发表于 : 2017-02-07 11:02 

注册: 2017-02-07 10:55
帖子: 4
系统: ubuntu14.04
送出感谢: 1
接收感谢: 0 次
ubuntu14.04
当前需要F1作为其他快捷键,但是在System Settings -> Keyboard -> ShortCut中,没办法设置F1为别的快捷键
因为F1会被截断,自动弹出帮助。
请问如何取消或者禁用F1弹出帮助,非常感谢


页首
 用户资料  
 
2 楼 
 文章标题 : Re: ubuntu如何禁用F1弹出帮助?
帖子发表于 : 2017-02-07 12:38 

注册: 2009-08-04 16:33
帖子: 17893
送出感谢: 21
接收感谢: 1921
Unity 或 Gnome 或 KDE ?

參閱
http://superuser.com/questions/301931/c ... -in-ubuntu
Can I assign a function key (F1, F2..) to a running application in Ubuntu?


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ubuntu如何禁用F1弹出帮助?
帖子发表于 : 2017-02-07 13:49 

注册: 2017-02-07 10:55
帖子: 4
系统: ubuntu14.04
送出感谢: 1
接收感谢: 0 次
poloshiao 写道:
Unity 或 Gnome 或 KDE ?

參閱
http://superuser.com/questions/301931/c ... -in-ubuntu
Can I assign a function key (F1, F2..) to a running application in Ubuntu?


非常感谢您
1.是Unity;
2.参看您给的网址,有一个疑问如下:
您给的网址是如何将脚本和快捷键联系在一起,而我这边是希望如何设置F1(必须设置F1),但是设置的时候,F1按下去弹出了帮助,导致hotkey editor并不能监听到这个快捷键。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: ubuntu如何禁用F1弹出帮助?
帖子发表于 : 2017-02-07 15:50 
头像

注册: 2007-12-14 13:40
帖子: 49905
地址: 志虚国乌由市
系统: Winbuntu
送出感谢: 29
接收感谢: 414
http://askubuntu.com/questions/58147/ho ... elp-f1-key

引用:
Just to Disable F1 may not be functioning in gnome. The practice way to avoid F1 to bring up Help window is to assign it to some unused function or a common function, such as 'raise'.

In most Ubuntu releases, using Settings->Keyboard->Shortcuts to assign F1 to 'raise' should work, except Ubuntu 14.04. Under Ubuntu 14.04, use dconf-editor to reassign F1 to 'raise' described by The Thunder Chimp above.

虽然说的是禁用F1,不过设置应该也差不多,当然我的系统不是14.04,14.04可能要用dconf-editor来设置
附件:
2017-02-07 15-54-54屏幕截图.png
2017-02-07 15-54-54屏幕截图.png [ 50.77 KiB | 被浏览 1897 次 ]



_________________
冷轩信

渠月 · QY

本人只会灌水,不负责回答问题

无聊可以点一下→ http://u.nu/ubuntu

安装flash 还是要用
代码:
sudo apt install adobe-flashplugin


页首
 用户资料  
 
5 楼 
 文章标题 : Re: ubuntu如何禁用F1弹出帮助?
帖子发表于 : 2017-02-07 16:18 

注册: 2009-08-04 16:33
帖子: 17893
送出感谢: 21
接收感谢: 1921
引用:
1.是Unity;

1. 按下 alt + F2 # 打開 Dash
輸入 dconf # 出現 dconf 編輯器
點擊 dconf 編輯器 # 啟動 dconf 編輯器
org > gnome > desktop > wm > keybindings
找到 raise # 抬升視窗覆蓋其他視窗
把 ['disabled']
改為 ['F1']
關閉

2. 按一下 F1 試試
2-1. 如果還出現 Help 網頁
多試幾次看看

3. 參閱
3-1. http://askubuntu.com/a/460650
Install the DConf editor, go to org > gnome > desktop > wm > keybindings.
Assign the F1 key to some inoffensive function, like 'raise'.



_________________
评价: 7.41% qq497495160tang.zhe
 
页首
 用户资料  
 
6 楼 
 文章标题 : Re: ubuntu如何禁用F1弹出帮助?
帖子发表于 : 2017-02-07 16:53 
头像

注册: 2010-07-15 13:31
帖子: 1420
送出感谢: 78
接收感谢: 23
代码:
dconf > org > gnome > desktop > wm > keybindings > raise
把 ['disabled']改為 ['F1']

我只有nautilus里面才弹出帮助,改后已经没有了,多谢!


_________________
Ubuntu 命令技巧: http://wiki.ubuntu.org.cn/index.php?title=UbuntuSkills&variant=zh-cn
Ubuntu 桌面指南: https://help.ubuntu.com//


页首
 用户资料  
 
7 楼 
 文章标题 : Re: ubuntu如何禁用F1弹出帮助?
帖子发表于 : 2017-02-09 11:53 

注册: 2017-02-07 10:55
帖子: 4
系统: ubuntu14.04
送出感谢: 1
接收感谢: 0 次
qy117121 写道:
http://askubuntu.com/questions/58147/how-do-i-disable-the-help-f1-key

引用:
Just to Disable F1 may not be functioning in gnome. The practice way to avoid F1 to bring up Help window is to assign it to some unused function or a common function, such as 'raise'.

In most Ubuntu releases, using Settings->Keyboard->Shortcuts to assign F1 to 'raise' should work, except Ubuntu 14.04. Under Ubuntu 14.04, use dconf-editor to reassign F1 to 'raise' described by The Thunder Chimp above.

虽然说的是禁用F1,不过设置应该也差不多,当然我的系统不是14.04,14.04可能要用dconf-editor来设置
附件:
2017-02-07 15-54-54屏幕截图.png


恩恩在14.04,在应用这个界面,没办法获取到F1,按F1直接跳出帮助。谢谢你


页首
 用户资料  
 
8 楼 
 文章标题 : Re: ubuntu如何禁用F1弹出帮助?
帖子发表于 : 2017-03-27 18:45 

注册: 2017-02-07 10:55
帖子: 4
系统: ubuntu14.04
送出感谢: 1
接收感谢: 0 次
poloshiao 写道:
引用:
1.是Unity;

1. 按下 alt + F2 # 打開 Dash
輸入 dconf # 出現 dconf 編輯器
點擊 dconf 編輯器 # 啟動 dconf 編輯器
org > gnome > desktop > wm > keybindings
找到 raise # 抬升視窗覆蓋其他視窗
把 ['disabled']
改為 ['F1']
關閉

2. 按一下 F1 試試
2-1. 如果還出現 Help 網頁
多試幾次看看

3. 參閱
3-1. http://askubuntu.com/a/460650
Install the DConf editor, go to org > gnome > desktop > wm > keybindings.
Assign the F1 key to some inoffensive function, like 'raise'.



非常感谢1,2.。。已经OK


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译