server版启动时即卡死,是对硬件支持不够吗?

Trusty Tahr (长期支持)
回复
ararakiloki
帖子: 4
注册时间: 2017-05-24 12:12
系统: ubuntu 14.04
送出感谢: 0
接收感谢: 0

server版启动时即卡死,是对硬件支持不够吗?

#1

帖子 ararakiloki » 2017-05-24 12:29

新配的机器,X99+I7 6850
之前装的是M.2硬盘,装不上14.04(无法安装GRUB),后来改装了16.04一切正常
现在又加了个SSD,就想着再试试装个14.04试试,装好后能启动,但会在一个画面死机,重启几次都一样
DSC0018.jpg
何解。。。。
头像
vickycq
论坛版主
帖子: 4552
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 994 次
联系:

Re: server版启动时即卡死,是对硬件支持不够吗?

#2

帖子 vickycq » 2017-05-24 15:32

ararakiloki 写了:新配的机器,X99+I7 6850
就想着再试试装个14.04试试
新配的机器不建议安装 14.04。建议尽可能安装最新版本以最大化硬件支持。
根据图中 nouveau ... unknown chipset, ... 可猜测为旧版对硬件支持不够
如果您一定要使用 14.04,您可以尝试用 nomodeset 模式 或 Recovery mode - failsafeX 启动后安装 nvidia 私有驱动。
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
ararakiloki
帖子: 4
注册时间: 2017-05-24 12:12
系统: ubuntu 14.04
送出感谢: 0
接收感谢: 0

Re: server版启动时即卡死,是对硬件支持不够吗?

#3

帖子 ararakiloki » 2017-05-24 16:29

vickycq 写了:
ararakiloki 写了:新配的机器,X99+I7 6850
就想着再试试装个14.04试试
新配的机器不建议安装 14.04。建议尽可能安装最新版本以最大化硬件支持。
根据图中 nouveau ... unknown chipset, ... 可猜测为旧版对硬件支持不够
如果您一定要使用 14.04,您可以尝试用 nomodeset 模式 或 Recovery mode - failsafeX 启动后安装 nvidia 私有驱动。
呃。。。recovery下我没看到failsafeX的选项,可能因为我是server版的缘故?我尝试在root shell下安装nvdia驱动,但运行时报错说找不到developer-tool path“CC”,我安装一遍developer-tool也无法安装。
poloshiao
论坛版主
帖子: 18194
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1925 次

Re: server版启动时即卡死,是对硬件支持不够吗?

#4

帖子 poloshiao » 2017-05-24 17:26

I7 6850
1. I7 6850K ?
https://en.wikipedia.org/wiki/Broadwell ... hitecture)
Core i7-6850K
1-1. 沒看到 I7 6850
1-2. Broadwell is Intel's codename
装了16.04一切正常
想着再试试装个14.04
2. Intel 提供
https://01.org/linuxgraphics/downloads
可以下載 Intel 研發的 開源驅動 i915 / i965 配套程式
2-1. I7 6850 / I7 6850K 可能太新了 還不在 Broadwell 系列 支援名單內

2-2. 2.0.2 版 適用於 Ubuntu 16.04
https://01.org/zh/linuxgraphics/downloa ... redirect=1
https://01.org/zh/linuxgraphics/downloa ... redirect=1
http://ark.intel.com/products/codename/ ... dwell#@All
6850, 6850K 不在 名單內

2-3. 最新版 2.0.4 適用於 Ubuntu 16.10
https://01.org/zh/node/5437
https://01.org/zh/node/4694
http://ark.intel.com/products/codename/ ... dwell#@All
6850, 6850K 不在 名單內
ararakiloki
帖子: 4
注册时间: 2017-05-24 12:12
系统: ubuntu 14.04
送出感谢: 0
接收感谢: 0

Re: server版启动时即卡死,是对硬件支持不够吗?

#5

帖子 ararakiloki » 2017-05-24 18:23

poloshiao 写了:1. I7 6850K ?
https://en.wikipedia.org/wiki/Broadwell ... hitecture)
Core i7-6850K
1-1. 沒看到 I7 6850
1-2. Broadwell is Intel's codename
没错,I7 6850K
poloshiao 写了:2. Intel 提供
https://01.org/linuxgraphics/downloads
可以下載 Intel 研發的 開源驅動 i915 / i965 配套程式
2-1. I7 6850 / I7 6850K 可能太新了 還不在 Broadwell 系列 支援名單內

2-2. 2.0.2 版 適用於 Ubuntu 16.04
https://01.org/zh/linuxgraphics/downloa ... redirect=1
https://01.org/zh/linuxgraphics/downloa ... redirect=1
http://ark.intel.com/products/codename/ ... dwell#@All
6850, 6850K 不在 名單內

2-3. 最新版 2.0.4 適用於 Ubuntu 16.10
https://01.org/zh/node/5437
https://01.org/zh/node/4694
http://ark.intel.com/products/codename/ ... dwell#@All
6850, 6850K 不在 名單內
嗯。。。实际上,装上ubuntu-16.04.1-server可正常运行,只有换成14.04时会死机无法进入系统
poloshiao
论坛版主
帖子: 18194
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1925 次

Re: server版启动时即卡死,是对硬件支持不够吗?

#6

帖子 poloshiao » 2017-05-24 21:31

装上ubuntu-16.04.1-server可正常运行
可能還不是 完全支援

繼續追蹤看看
https://01.org/linuxgraphics/downloads
http://ark.intel.com/products/codename/ ... dwell#@All
ararakiloki
帖子: 4
注册时间: 2017-05-24 12:12
系统: ubuntu 14.04
送出感谢: 0
接收感谢: 0

Re: server版启动时即卡死,是对硬件支持不够吗?

#7

帖子 ararakiloki » 2017-05-25 11:08

感谢楼上两位的讨论。
经过尝试,装了NVIDIA.381版驱动后能正常启动了。确实是显卡驱动的问题。

不过现在进入系统后,随之而然有另外一个问题,请问我该如何挂载我原先那块M.2 NVMe硬盘...我想读里面的资料
ubuntu14.04有支援NVMe协议的驱动吗
poloshiao
论坛版主
帖子: 18194
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1925 次

Re: server版启动时即卡死,是对硬件支持不够吗?

#8

帖子 poloshiao » 2017-05-25 11:25

请问我该如何挂载我原先那块M.2 NVMe硬盘...我想读里面的资料
1. 把下面指令 複製 貼進終端機 執行
1-1. sudo efibootmgr -v
1-2. sudo parted -l print
1-3. 把結果全部直接 選取/複製/貼上來
回复

回到 “Ubuntu 14.04 LTS”