pip3链接问题

Trusty Tahr (长期支持)
回复
xyb996534057
帖子: 1
注册时间: 2017-06-24 19:29
系统: ubuntu14.04
送出感谢: 0
接收感谢: 0

pip3链接问题

#1

帖子 xyb996534057 » 2017-06-24 19:36

ubuntu14.04系统,以前安装完之后pip3自动链接到python3.4,安装软件是安装到python3.4的dist-packages,不知道谁改了什么,现在用pip3安装软件时,直接是安装到python3.5下面,我想问一下怎么改回去,让pip3 install *的时候安装软件到python3.4下面,谢谢了
onlylove
论坛版主
帖子: 4437
注册时间: 2007-01-14 16:23
送出感谢: 0
接收感谢: 100 次

Re: pip3链接问题

#2

帖子 onlylove » 2017-06-24 21:28

建议学习使用virtualenv
恒河沙数1
帖子: 295
注册时间: 2013-04-27 19:26
系统: ubuntu+win7
送出感谢: 21 次
接收感谢: 9 次

Re: pip3链接问题

#3

帖子 恒河沙数1 » 2017-06-29 10:15

xyb996534057 写了:ubuntu14.04系统,以前安装完之后pip3自动链接到python3.4,安装软件是安装到python3.4的dist-packages,不知道谁改了什么,现在用pip3安装软件时,直接是安装到python3.5下面,我想问一下怎么改回去,让pip3 install *的时候安装软件到python3.4下面,谢谢了
试试这个:

代码: 全选

$ sudo mv /usr/bin/python3 /usr/bin/python3.old
$ sudo ln -s /usr/bin/python3.4 /usr/bin/python3
没有效果的话,改回去

代码: 全选

sudo mv /usr/bin/python3.old /usr/bin/python3
poloshiao
论坛版主
帖子: 18245
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1948 次

Re: pip3链接问题

#4

帖子 poloshiao » 2017-06-29 13:25

python3.4 / python3.5 / python2.y
如果一個系統 同時安裝了 好幾個版本的 python3.x/2.y
善用
sudo update-alternatives --config python
切換

詳見

https://stackoverflow.com/questions/430 ... eaking-apt
How to update-alternatives to Python 3 without breaking apt?

https://linuxconfig.org/how-to-change-f ... bian-linux
How to change from default to alternative Python version on Debian Linux
回复

回到 “Ubuntu 14.04 LTS”