当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 更新软件源始终出错,非常需要更新这个源
帖子发表于 : 2017-07-30 17:35 

注册: 2016-11-30 1:08
帖子: 13
系统: windows
送出感谢: 0 次
接收感谢: 0 次
ubuntu14.04,希望安装mrpt,但是更新软件源始终出错,改变下载的源也没有办法,从而导致没有办法安装该软件包。
非常需要安装这个软件,所以请教是否有办法解决。

附上ppa:sudo add-apt-repository ppa:joseluisblancoc/mrpt


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 更新软件源始终出错,非常需要更新这个源
帖子发表于 : 2017-07-30 17:45 
头像

注册: 2007-12-14 13:40
帖子: 49903
地址: 志虚国乌由市
系统: Winbuntu
送出感谢: 29
接收感谢: 414
提示什么错误 ?


_________________
冷轩信

渠月 · QY

本人只会灌水,不负责回答问题

无聊可以点一下→ http://u.nu/ubuntu

安装flash 还是要用
代码:
sudo apt install adobe-flashplugin


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 更新软件源始终出错,非常需要更新这个源
帖子发表于 : 2017-07-30 22:41 

注册: 2016-11-30 1:08
帖子: 13
系统: windows
送出感谢: 0 次
接收感谢: 0 次
qy117121 写道:
提示什么错误 ?


sudo apt-get update 后,最后会显示这一条无法下载,校验和不符


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 更新软件源始终出错,非常需要更新这个源
帖子发表于 : 2017-07-31 9:06 
头像

注册: 2007-12-14 13:40
帖子: 49903
地址: 志虚国乌由市
系统: Winbuntu
送出感谢: 29
接收感谢: 414
看了下,这个PPA貌似是不支持14.04了

修改这个ppa源的系统版本,把trusty改成 wily (15.10) 或者 xenial ( 16.04 )试试


_________________
冷轩信

渠月 · QY

本人只会灌水,不负责回答问题

无聊可以点一下→ http://u.nu/ubuntu

安装flash 还是要用
代码:
sudo apt install adobe-flashplugin


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 更新软件源始终出错,非常需要更新这个源
帖子发表于 : 2017-07-31 10:51 

注册: 2009-08-04 16:33
帖子: 17780
送出感谢: 21
接收感谢: 1914
引用:
sudo apt-get update 后,最后会显示这一条无法下载,校验和不符

把終端機指令 文字回應 全部複製貼上來
摘要 及 說明 只能是補充 不能取代 以免遺漏重要資訊


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 更新软件源始终出错,非常需要更新这个源
帖子发表于 : 2017-07-31 11:45 

注册: 2016-11-30 1:08
帖子: 13
系统: windows
送出感谢: 0 次
接收感谢: 0 次
qy117121 写道:
看了下,这个PPA貌似是不支持14.04了

修改这个ppa源的系统版本,把trusty改成 wily (15.10) 或者 xenial ( 16.04 )试试


是重装系统吗?我之前装过16.04的,但是安装的mrpt就和原本14.04上安装的内容不一样了,导致程序没法用。

这个还有办法在14.04上安装吗?


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 更新软件源始终出错,非常需要更新这个源
帖子发表于 : 2017-07-31 11:50 

注册: 2016-11-30 1:08
帖子: 13
系统: windows
送出感谢: 0 次
接收感谢: 0 次
poloshiao 写道:
引用:
sudo apt-get update 后,最后会显示这一条无法下载,校验和不符

把終端機指令 文字回應 全部複製貼上來
摘要 及 說明 只能是補充 不能取代 以免遺漏重要資訊


W: 无法下载 http://ppa.launchpad.net/joseluisblanco ... slation-en Hash 校验和不符

W: 无法下载 http://extras.ubuntu.com/ubuntu/dists/t ... 4/Packages Hash 校验和不符

希望安装的是第一条


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 更新软件源始终出错,非常需要更新这个源
帖子发表于 : 2017-07-31 11:58 

注册: 2009-08-04 16:33
帖子: 17780
送出感谢: 21
接收感谢: 1914
引用:
W: 无法下载 http://ppa.launchpad.net/joseluisblanco ... slation-en Hash 校验和不符
W: 无法下载 http://extras.ubuntu.com/ubuntu/dists/t ... 4/Packages Hash 校验和不符
希望安装的是第一条

1. 可能原因之一是 你的網路連線供應商 伺服器 Cache 問題

2. 暫時解決方案 參閱
2-1. search.php?keywords=Hash+%E6%A0%A1%E9%AA%8C%E5%92%8C%E4%B8%8D%E7%AC%A6&terms=all&author=&sc=1&sf=all&sk=t&sd=d&sr=posts&st=0&ch=300&t=0&submit=%E6%90%9C%E5%B0%8B
2-2. 特別是
http://forum.ubuntu.com.cn/viewtopic.php?f=77&t=465499


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 更新软件源始终出错,非常需要更新这个源
帖子发表于 : 2017-07-31 13:25 

注册: 2016-11-30 1:08
帖子: 13
系统: windows
送出感谢: 0 次
接收感谢: 0 次
poloshiao 写道:
引用:
W: 无法下载 http://ppa.launchpad.net/joseluisblanco ... slation-en Hash 校验和不符
W: 无法下载 http://extras.ubuntu.com/ubuntu/dists/t ... 4/Packages Hash 校验和不符
希望安装的是第一条

1. 可能原因之一是 你的網路連線供應商 伺服器 Cache 問題

2. 暫時解決方案 參閱
2-1. search.php?keywords=Hash+%E6%A0%A1%E9%AA%8C%E5%92%8C%E4%B8%8D%E7%AC%A6&terms=all&author=&sc=1&sf=all&sk=t&sd=d&sr=posts&st=0&ch=300&t=0&submit=%E6%90%9C%E5%B0%8B
2-2. 特別是
http://forum.ubuntu.com.cn/viewtopic.php?f=77&t=465499


如果是网络供应商的问题,是不是可以尝试在其他网络下试一试,来验证是否是这个原因?

因为我在目前的网络下,尝试利用ppa安装shadowsocks,update也失败了


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 更新软件源始终出错,非常需要更新这个源
帖子发表于 : 2017-07-31 13:58 
头像

注册: 2007-12-14 13:40
帖子: 49903
地址: 志虚国乌由市
系统: Winbuntu
送出感谢: 29
接收感谢: 414
14.04没有支持了啊,所以我说的修改源版本的方法安装的也不是14.04版本的了


_________________
冷轩信

渠月 · QY

本人只会灌水,不负责回答问题

无聊可以点一下→ http://u.nu/ubuntu

安装flash 还是要用
代码:
sudo apt install adobe-flashplugin


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 更新软件源始终出错,非常需要更新这个源
帖子发表于 : 2017-07-31 14:29 

注册: 2016-11-30 1:08
帖子: 13
系统: windows
送出感谢: 0 次
接收感谢: 0 次
qy117121 写道:
14.04没有支持了啊,所以我说的修改源版本的方法安装的也不是14.04版本的了


恩恩,我尝试一下。

想问一下,您是怎么判断ppa有支持还是没有支持的呢?谢谢


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 更新软件源始终出错,非常需要更新这个源
帖子发表于 : 2017-07-31 14:55 
头像

注册: 2007-12-14 13:40
帖子: 49903
地址: 志虚国乌由市
系统: Winbuntu
送出感谢: 29
接收感谢: 414
LZDsjtu 写道:
qy117121 写道:
14.04没有支持了啊,所以我说的修改源版本的方法安装的也不是14.04版本的了


恩恩,我尝试一下。

想问一下,您是怎么判断ppa有支持还是没有支持的呢?谢谢

虽然这个ppa的dists目录下有trusty( 14.04) 但是软件包列表(不知道应该叫什么,就这样称呼吧) 里面是空白的
http://ppa.launchpad.net/joseluisblanco ... ary-amd64/
代码:
Packages.bz2   24-Jul-2017 00:05   14   
[   ]   Packages.gz   24-Jul-2017 00:05   20

Packages.bz2和 Packages.gz 下载下来解压后的文件内没有内容


又看了下,在15.10 wily 中才有 http://ppa.launchpad.net/joseluisblanco ... ary-amd64/
代码:
   Packages.bz2   23-Jul-2017 21:18   3.7K   
[   ]   Packages.gz   23-Jul-2017 21:18   3.7K   


16.04 http://ppa.launchpad.net/joseluisblanco ... ary-amd64/
代码:
Packages.gz   30-Jul-2017 17:13   3.9K   
[   ]   Packages.xz   30-Jul-2017 17:13   3.6K   


文件内内容
图片


_________________
冷轩信

渠月 · QY

本人只会灌水,不负责回答问题

无聊可以点一下→ http://u.nu/ubuntu

安装flash 还是要用
代码:
sudo apt install adobe-flashplugin


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 更新软件源始终出错,非常需要更新这个源
帖子发表于 : 2017-07-31 18:11 

注册: 2009-08-04 16:33
帖子: 17780
送出感谢: 21
接收感谢: 1914
引用:
https://launchpad.net/~joseluisblancoc/+archive/ubuntu/mrpt
sudo add-apt-repository ppa:joseluisblancoc/mrpt
sudo apt-get update
sudo apt-get install libmrpt-dev mrpt-apps

1. 經查
libmrpt-dev mrpt-apps 自 14.04 開始 已經進入 Ubuntu 官方套件庫 (應該是穩定版)
1-1. libmrpt-dev
https://packages.ubuntu.com/search?suit ... chon=names
1-2. mrpt-apps
https://packages.ubuntu.com/search?suit ... chon=names
1-3. 除非有特別理由 否則 直接從 Ubuntu 14.04 官方套件庫 安裝即可 :
1-3-1. 把 ppa:joseluisblancoc/mrpt 移除
代码:
sudo add-apt-repository --remove ppa:joseluisblancoc/mrpt

1-3-1-1. 進一步參閱
https://askubuntu.com/a/310
1-3-2. sudo apt-get update
1-3-3. sudo apt-get upgrade
1-3-4. sudo apt-get install libmrpt-dev mrpt-apps
1-3-5. 如果還出現 錯誤訊息 請全部複製貼上來


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译