当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 使用14.04的pip问题
帖子发表于 : 2018-05-08 11:41 
头像

注册: 2011-05-01 20:18
帖子: 97
送出感谢: 3
接收感谢: 0 次
各位好,我是python新手。我在我机器上安装了pip和python,python好像安装了好几个版本,有3.6.1和3.4,我运行pip的时候弹出这个东西,不知道什么意思,请各位指点。谢谢!

luhang@hive:~$ pip --version
Traceback (most recent call last):
File "/usr/local/bin/pip", line 6, in <module>
from pkg_resources import load_entry_point
File "/usr/local/lib/python3.4/dist-packages/pkg_resources/__init__.py", line 3036, in <module>
@_call_aside
File "/usr/local/lib/python3.4/dist-packages/pkg_resources/__init__.py", line 3020, in _call_aside
f(*args, **kwargs)
File "/usr/local/lib/python3.4/dist-packages/pkg_resources/__init__.py", line 3049, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/local/lib/python3.4/dist-packages/pkg_resources/__init__.py", line 654, in _build_master
ws.require(__requires__)
File "/usr/local/lib/python3.4/dist-packages/pkg_resources/__init__.py", line 968, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/local/lib/python3.4/dist-packages/pkg_resources/__init__.py", line 854, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'pip==1.5.4' distribution was not found and is required by the application


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 使用14.04的pip问题
帖子发表于 : 2018-05-08 11:43 
头像

注册: 2011-05-01 20:18
帖子: 97
送出感谢: 3
接收感谢: 0 次
在线等。追加个问题,怎么设置默认的python版本呢,我看我系统里稀里糊涂装了python2.7.6 python3.6.1和python3.4,pip和python版本怎么对应起来。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 使用14.04的pip问题
帖子发表于 : 2018-05-08 11:54 
头像

注册: 2008-09-18 13:11
帖子: 2945
送出感谢: 1
接收感谢: 493
先把你装的都删掉。再用系统源里自带的
sudo apt-get install --reinstall python3.4 python3-pip


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 使用14.04的pip问题
帖子发表于 : 2018-05-08 11:58 
头像

注册: 2008-09-18 13:11
帖子: 2945
送出感谢: 1
接收感谢: 493
不要改默认版本,你要用python2.7.x的就运行python2.7,python3.4的就运行python3.4。
.py里的shebang也写成 #!/usr/bin/python2.7这样带上版本号



_________________
评价: 3.7% sh42
 
页首
 用户资料  
 
5 楼 
 文章标题 : Re: 使用14.04的pip问题
帖子发表于 : 2018-05-08 12:05 
头像

注册: 2011-05-01 20:18
帖子: 97
送出感谢: 3
接收感谢: 0 次
astolia 写道:
不要改默认版本,你要用python2.7.x的就运行python2.7,python3.4的就运行python3.4。
.py里的shebang也写成 #!/usr/bin/python2.7这样带上版本号


感谢回复。按照您的说法,pip -v没有问题了,但是运行其他程序还是有问题:
luhang@hive:~$ jupyter notebook
Traceback (most recent call last):
File "/usr/local/bin/jupyter", line 6, in <module>
from pkg_resources import load_entry_point
File "/usr/local/lib/python3.4/dist-packages/pkg_resources/__init__.py", line 3036, in <module>
@_call_aside
File "/usr/local/lib/python3.4/dist-packages/pkg_resources/__init__.py", line 3020, in _call_aside
f(*args, **kwargs)
File "/usr/local/lib/python3.4/dist-packages/pkg_resources/__init__.py", line 3049, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/local/lib/python3.4/dist-packages/pkg_resources/__init__.py", line 654, in _build_master
ws.require(__requires__)
File "/usr/local/lib/python3.4/dist-packages/pkg_resources/__init__.py", line 968, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/local/lib/python3.4/dist-packages/pkg_resources/__init__.py", line 854, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'decorator' distribution was not found and is required by traitlets

我打印了一下which python3和which python:
luhang@hive:~$ which python
/usr/bin/python
luhang@hive:~$ which python3
/usr/local/bin/python3
发现python3默认的是python3.6,在/usr/local/bin/python3这个link。而python3.4是在/usr/bin/python3这个link,我直觉感觉,是不是把默认的python3改成指向3.4就行了。别的程序还要用3.6我就没删除


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译