我下载了15.10 server 版 cd镜像,安装后,openssh链接不上

为当前最终发行版之前的所有版本提供支持
回复
looyo
帖子: 15
注册时间: 2006-12-01 20:04
送出感谢: 0
接收感谢: 0

我下载了15.10 server 版 cd镜像,安装后,openssh链接不上

#1

帖子 looyo » 2015-11-25 17:35

我下载了15.10 server 版 cd镜像,安装后,用puuty之类的工具链接openssh报错,说:密钥交换失败,没有兼容的加密程序
头像
vickycq
论坛版主
帖子: 4552
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 994 次
联系:

Re: 我下载了15.10 cd镜像,安装后,openssh链接不上

#2

帖子 vickycq » 2015-11-25 17:41

1.
确保使用较新版本的 PuTTY (>=0.6)

2.
编辑 /etc/ssh/sshd_config 确保含有常见 Ciphers 和 KexAlgorithms

代码: 全选

KexAlgorithms diffie-hellman-group1-sha1,curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group14-sha1

Ciphers aes128-cbc,blowfish-cbc,3des-cbc,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com,chacha20-poly1305@openssh.com
重新启动 sshd

代码: 全选

sudo systemctl restart sshd.service
参考
http://www.linuxquestions.org/questions ... 175521194/
http://support.hostgator.com/articles/s ... her-errors
http://blog.millard.org/2014/11/repair- ... linux.html
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
looyo
帖子: 15
注册时间: 2006-12-01 20:04
送出感谢: 0
接收感谢: 0

Re: 我下载了15.10 cd镜像,安装后,openssh链接不上

#3

帖子 looyo » 2015-11-25 21:14

为什么新装的系统就没有了2中所述的这些配置???
vickycq 写了:1.
确保使用较新版本的 PuTTY (>=0.6)

2.
编辑 /etc/ssh/sshd_config 确保含有常见 Ciphers 和 KexAlgorithms

代码: 全选

KexAlgorithms diffie-hellman-group1-sha1,curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group14-sha1

Ciphers aes128-cbc,blowfish-cbc,3des-cbc,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com,chacha20-poly1305@openssh.com
重新启动 sshd

代码: 全选

sudo systemctl restart sshd.service
参考
http://www.linuxquestions.org/questions ... 175521194/
http://support.hostgator.com/articles/s ... her-errors
http://blog.millard.org/2014/11/repair- ... linux.html
poloshiao
论坛版主
帖子: 18159
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1923 次

Re: 我下载了15.10 server 版 cd镜像,安装后,openssh链接不上

#4

帖子 poloshiao » 2015-11-26 7:33

請提供
ssh server 端 作業系統及版本
ssh client 端 作業系統及版本
putty 版本
用puuty之类的工具链接openssh报错,说:密钥交换失败,没有兼容的加密程序
錯誤訊息 請直接複製 貼上來 以免遺漏重要資訊
摘譯 只能當補充 不能取代
looyo
帖子: 15
注册时间: 2006-12-01 20:04
送出感谢: 0
接收感谢: 0

Re: 我下载了15.10 cd镜像,安装后,openssh链接不上

#5

帖子 looyo » 2015-11-26 9:40

我的问题在更换putty版本为0.66后得到了解决。
looyo 写了:为什么新装的系统就没有了2中所述的这些配置???
vickycq 写了:1.
确保使用较新版本的 PuTTY (>=0.6)

2.
编辑 /etc/ssh/sshd_config 确保含有常见 Ciphers 和 KexAlgorithms

代码: 全选

KexAlgorithms diffie-hellman-group1-sha1,curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group14-sha1

Ciphers aes128-cbc,blowfish-cbc,3des-cbc,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com,chacha20-poly1305@openssh.com
重新启动 sshd

代码: 全选

sudo systemctl restart sshd.service
参考
http://www.linuxquestions.org/questions ... 175521194/
http://support.hostgator.com/articles/s ... her-errors
http://blog.millard.org/2014/11/repair- ... linux.html
回复

回到 “老旧版本支持”