当前时区为 UTC + 8 小时


版面规则


我们都知道新人的确很菜,也喜欢抱怨,并且带有浓厚的Windows习惯,但既然在这里询问,我们就应该有责任帮助他们解决问题,而不是直接泼冷水、简单的否定或发表对解决问题没有任何帮助的帖子。乐于分享,以人为本,这正是Ubuntu的精神所在。


发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 在安装某些软件时经常提示qemu-user-static,这个到底是什么东西
帖子发表于 : 2017-09-07 17:46 

注册: 2017-09-07 17:42
帖子: 5
系统: windows10
送出感谢: 0 次
接收感谢: 0 次
在安装某些软件时经常提示qemu-user-static,这个到底是什么东西
安装KVM时会提示,安装nmtui时也提示
Errors were encountered while processing:
qemu-user-static
E: Sub-process /usr/bin/dpkg returned an error code

这是错误的提示

我用的Ubuntu系统是windows10里面安装的子系统


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 在安装某些软件时经常提示qemu-user-static,这个到底是什么东西
帖子发表于 : 2017-09-07 21:27 
头像

注册: 2007-07-14 20:45
帖子: 940
送出感谢: 54
接收感谢: 21
还是源的问题,我猜你的系统是不是ubuntu14.04LTS?


_________________
开源、共享、自由

微信号:xfiles_sky

irc:chat.freenode.net/+6697
/join #ubuntu.com.cn


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 在安装某些软件时经常提示qemu-user-static,这个到底是什么东西
帖子发表于 : 2017-09-07 21:31 

注册: 2017-09-07 17:42
帖子: 5
系统: windows10
送出感谢: 0 次
接收感谢: 0 次
九天星 写道:
还是源的问题,我猜你的系统是不是ubuntu14.04LTS?

是的,系统就是14.04
那我要怎么处理?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 在安装某些软件时经常提示qemu-user-static,这个到底是什么东西
帖子发表于 : 2017-09-07 21:50 
头像

注册: 2007-07-14 20:45
帖子: 940
送出感谢: 54
接收感谢: 21
我前段时间也遇到了类似的问题,如果换成国内的源,然国内源很多都没有更新,偿试过很多方法之后,解决的都不彻底。
后来还因此发了一个贴子问:ubuntu没有了源还能做些什么!?

后来我没有办法,只有升级到ubuntu16.04LTS版。

如果不想换版本的话,你可以根据下面的思路解决,因我个人是完美主义者,并没有使用下列方法

分析问题原因:我个人认为应该是ubuntu官方将http升级成了https,且,16.04以下版本的系统源被纳入old老源地址。你在官网中找官方源地址的时候找同版本的,链接中含有old老源字样的源地址更新可解决!


_________________
开源、共享、自由

微信号:xfiles_sky

irc:chat.freenode.net/+6697
/join #ubuntu.com.cn


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 在安装某些软件时经常提示qemu-user-static,这个到底是什么东西
帖子发表于 : 2017-09-13 17:25 

注册: 2017-09-07 17:42
帖子: 5
系统: windows10
送出感谢: 0 次
接收感谢: 0 次
九天星 写道:
我前段时间也遇到了类似的问题,如果换成国内的源,然国内源很多都没有更新,偿试过很多方法之后,解决的都不彻底。
后来还因此发了一个贴子问:ubuntu没有了源还能做些什么!?

后来我没有办法,只有升级到ubuntu16.04LTS版。

如果不想换版本的话,你可以根据下面的思路解决,因我个人是完美主义者,并没有使用下列方法

分析问题原因:我个人认为应该是ubuntu官方将http升级成了https,且,16.04以下版本的系统源被纳入old老源地址。你在官网中找官方源地址的时候找同版本的,链接中含有old老源字样的源地址更新可解决!


帅哥您好!我已经升级到16.04版本了,但是在安装vsftp时还是报错了
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 在安装某些软件时经常提示qemu-user-static,这个到底是什么东西
帖子发表于 : 2017-09-14 9:56 
头像

注册: 2007-07-14 20:45
帖子: 940
送出感谢: 54
接收感谢: 21
在用apt-get安装软件时出现了类似于
install-info: No dir file specified; try –help for more information.dpkg:处理 gettext (–configure)时出错: 子进程 post-installation script 返回了错误号 1 在处理时有错误发生:
findutils
E: Sub-process /usr/bin/dpkg returned an error code (1)
第一种方法:
sudo mv /var/lib/dpkg/info /var/lib/dpkg/info.bak //现将info文件夹更名

sudo mkdir /var/lib/dpkg/info //再新建一个新的info文件夹

sudo apt-get update
// 不用解释了吧
apt-get -f install xxx

sudo mv /var/lib/dpkg/info/* /var/lib/dpkg/info.bak
//执行完上一步操作后会在新的info文件夹下生成一些文件,现将这些文件全部移到info.bak文件夹下
sudo rm -rf /var/lib/dpkg/info //把自己新建的info文件夹删掉

sudo mv /var/lib/dpkg/info.bak /var/lib/dpkg/info //把以前的info文件夹重新改回名字
到此问题顺利解决
一般上面的这个方法可以解决问题了
第二种方法;
for i in /usr/share/fonts/X11/* /usr/share/fonts/truetype/*

do sudo touch "$i"

done
第三种方法:
sudo apt-get update --fix-missing

sudo apt-get autoremove && sudo apt-get clean && sudo apt-get install -f


_________________
开源、共享、自由

微信号:xfiles_sky

irc:chat.freenode.net/+6697
/join #ubuntu.com.cn


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 在安装某些软件时经常提示qemu-user-static,这个到底是什么东西
帖子发表于 : 2017-09-15 20:58 

注册: 2017-09-07 17:42
帖子: 5
系统: windows10
送出感谢: 0 次
接收感谢: 0 次
九天星 写道:
在用apt-get安装软件时出现了类似于
install-info: No dir file specified; try –help for more information.dpkg:处理 gettext (–configure)时出错: 子进程 post-installation script 返回了错误号 1 在处理时有错误发生:
findutils
E: Sub-process /usr/bin/dpkg returned an error code (1)
第一种方法:
sudo mv /var/lib/dpkg/info /var/lib/dpkg/info.bak //现将info文件夹更名

sudo mkdir /var/lib/dpkg/info //再新建一个新的info文件夹

sudo apt-get update
// 不用解释了吧
apt-get -f install xxx

sudo mv /var/lib/dpkg/info/* /var/lib/dpkg/info.bak
//执行完上一步操作后会在新的info文件夹下生成一些文件,现将这些文件全部移到info.bak文件夹下
sudo rm -rf /var/lib/dpkg/info //把自己新建的info文件夹删掉

sudo mv /var/lib/dpkg/info.bak /var/lib/dpkg/info //把以前的info文件夹重新改回名字
到此问题顺利解决
一般上面的这个方法可以解决问题了
第二种方法;
for i in /usr/share/fonts/X11/* /usr/share/fonts/truetype/*

do sudo touch "$i"

done
第三种方法:
sudo apt-get update --fix-missing

sudo apt-get autoremove && sudo apt-get clean && sudo apt-get install -f


非常感谢,问题终于得到解决了


然后现在面临一个新的问题,我在Ubuntu中安装了selinux,配置文件已设置为enforceing。但是运行getenforce还是提示disable,这又是什么问题啊,我把AppArmor已经卸载掉了


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译