請教vickycq一個問題 還是關於hyper

为当前最终发行版之前的所有版本提供支持
回复
linuxmm9
帖子: 76
注册时间: 2017-08-19 10:12
系统: linux
送出感谢: 26 次
接收感谢: 0

請教vickycq一個問題 還是關於hyper

#1

帖子 linuxmm9 » 2017-11-14 21:11

每次啟動hyper後 頂部都有一個% 而且提示符也多一行 以前在xterm上也出現過 不過現在又正常了
附件
feh_003170_000001_2017-11-14-210433_961x479_scrot.png
xterm
(11 KiB) 尚未被下载
feh_003058_000001_2017-11-14-205804_832x494_scrot.png
正常
(11.55 KiB) 尚未被下载
feh_003213_000001_2017-11-14-205759_832x494_scrot.png
就是這個倒霉樣子
头像
vickycq
论坛版主
帖子: 4507
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 995 次
联系:

Re: 請教vickycq一個問題 還是關於hyper

#2

帖子 vickycq » 2017-11-14 22:40

linuxmm9 写了: 以前在xterm上也出現過 不過現在又正常了
如果在 xterm 上也出现过,那么先检查一下 shell 的提示符配置。如果用的 zsh/bash,把 zshrc/bashrc 发上来看看。太长的话,发到 paste.ubuntu.com
linuxmm9 写了: 頂部都有一個% 而且提示符也多一
大约 2015 年用 zsh 的时候绝对遇到过类似问题(启动终端后自动打印出若干行提示符),当时应该搜到了方案并解决了,但一时回忆不起来细节..
这些用户感谢了作者 vickycq 于这个帖子:
linuxmm9 (2017-11-15 1:21)
评价: 3.7%
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
linuxmm9
帖子: 76
注册时间: 2017-08-19 10:12
系统: linux
送出感谢: 26 次
接收感谢: 0

Re: 請教vickycq一個問題 還是關於hyper

#3

帖子 linuxmm9 » 2017-11-15 0:40

兩個問題都解決了 多一行那個是我寫了多餘的東西 刪除後就好了

%這個比較奇怪 我安裝vte看看會不會也是這樣 結果和xterm一樣 都是正常的 所以我想zsh的配置應該沒問題 問題可能出在hyper的配置文件上 於是我把hyper修改過的地方一個一個檢驗 最後發現是界面大小的緣故 不管字體設置多大 只要把界面縮小 %好就會出來 好像跟高度沒關係 只要拉寬一直到80 %就消失了 我反覆試了好多次 最後發現80以下的寬度都會顯示

這個問題算不算是個bug 因為我把hyper初始化後 問題依然存在


再次謝謝vickycq :em11
科学之子
帖子: 2260
注册时间: 2013-05-26 6:58
系统: Debian 9
送出感谢: 842 次
接收感谢: 30 次

Re: 請教vickycq一個問題 還是關於hyper

#4

帖子 科学之子 » 2017-11-15 12:18

说个无关的:
本论坛支持"@"操作呼叫某个用户.
例如@linuxmm9
注意@和名字之间不要加空格..
这样的好处是标题可以提供更多信息来帮助别人判断此问题是否适合自己来解答.

@linuxmm9
回复

回到 “老旧版本支持”