当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu真心不错,软件问题弄的快崩溃了
帖子发表于 : 2018-03-14 20:08 

注册: 2018-03-14 19:57
帖子: 5
系统: ubuntu 16.04
送出感谢: 0 次
接收感谢: 0 次
有没有大神帮忙,现在所有软件都没办法安装一直报这俩有问题
===========================================
$ sudo dpkg -i libpng12-0_1.2.54-1ubuntu1_amd64.deb 1 ↵
正在选中未选择的软件包 libpng12-0:amd64。
(正在读取数据库 ... 系统当前共安装有 271206 个文件和目录。)
正准备解包 libpng12-0_1.2.54-1ubuntu1_amd64.deb ...
正在将 libpng12-0:amd64 (1.2.54-1ubuntu1) 解包到 (1.2.49-1+deb7u2) 上 ...
dpkg: 处理归档 libpng12-0_1.2.54-1ubuntu1_amd64.deb (--install)时出错:
尝试覆盖共享的 '/usr/share/doc/libpng12-0/ANNOUNCE', 它与软件包 libpng12-0:amd64 中的其他实例不同
dpkg-deb:错误:子进程 粘贴 被信号(断开的管道) 终止了
正在处理用于 libc-bin (2.23-0ubuntu10) 的触发器 ...
在处理时有错误发生:
libpng12-0_1.2.54-1ubuntu1_amd64.deb
======================================

$sudo apt-get -f install
......
将会同时安装下列软件:
libpng12-0
下列软件包将被升级:
libpng12-0
升级了 1 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 2 个软件包未被升级。
有 3 个软件包没有被完全安装或卸载。
需要下载 0 B/116 kB 的归档。
解压缩后将会空出 23.6 kB 的空间。
您希望继续执行吗? [Y/n] y
(正在读取数据库 ... 系统当前共安装有 271206 个文件和目录。)
正准备解包 .../libpng12-0_1.2.54-1ubuntu1_amd64.deb ...
正在将 libpng12-0:amd64 (1.2.54-1ubuntu1) 解包到 (1.2.49-1+deb7u2) 上 ...
dpkg: 处理归档 /var/cache/apt/archives/libpng12-0_1.2.54-1ubuntu1_amd64.deb (--unpack)时出错:
尝试覆盖共享的 '/usr/share/doc/libpng12-0/ANNOUNCE', 它与软件包 libpng12-0:amd64 中的其他实例不同
dpkg-deb:错误:子进程 粘贴 被信号(断开的管道) 终止了
正在处理用于 libc-bin (2.23-0ubuntu10) 的触发器 ...
在处理时有错误发生:
/var/cache/apt/archives/libpng12-0_1.2.54-1ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

========================================
$ sudo dpkg -P libpng12-0 100 ↵
dpkg: 依赖问题阻止了卸载 libpng12-0:amd64 的操作:
libqtwebkit4:amd64 依赖于 libpng12-0 (>= 1.2.13-4).
libopencv-highgui2.4v5:amd64 依赖于 libpng12-0 (>= 1.2.13-4).
libwmf0.2-7:amd64 依赖于 libpng12-0 (>= 1.2.13-4).
flashplugin-installer 依赖于 libpng12-0.
libgs9:amd64 依赖于 libpng12-0 (>= 1.2.13-4).
libpoppler58:amd64 依赖于 libpng12-0 (>= 1.2.13-4).
libzvbi0:amd64 依赖于 libpng12-0 (>= 1.2.13-4).
libgdal1i 依赖于 libpng12-0 (>= 1.2.13-4).
libsdl-image1.2:amd64 依赖于 libpng12-0 (>= 1.2.13-4).
libgdiplus 依赖于 libpng12-0 (>= 1.2.13-4).
x11-apps 依赖于 libpng12-0 (>= 1.2.13-4).
gstreamer1.0-plugins-good:amd64 依赖于 libpng12-0 (>= 1.2.13-4).
netpbm 依赖于 libpng12-0 (>= 1.2.13-4).
libplymouth4:amd64 依赖于 libpng12-0 (>= 1.2.13-4).
libgxps2:amd64 依赖于 libpng12-0 (>= 1.2.13-4).
libqt5gui5:amd64 依赖于 libpng12-0 (>= 1.2.13-4).
libcupsfilters1:amd64 依赖于 libpng12-0 (>= 1.2.13-4).
liblept5 依赖于 libpng12-0 (>= 1.2.13-4).
libf
dpkg: 处理软件包 libpng12-0:amd64 (--purge)时出错:
依赖问题 - 不会执行卸载
在处理时有错误发生:
libpng12-0:amd64

有没有大神救救额吧


附件:
2018-03-14 20-02-44屏幕截图.png
2018-03-14 20-02-44屏幕截图.png [ 146.17 KiB | 被浏览 881 次 ]

2018-03-14 20-00-19屏幕截图.png
2018-03-14 20-00-19屏幕截图.png [ 239.66 KiB | 被浏览 881 次 ]

页首
 用户资料  
 
2 楼 
 文章标题 : Re: ubuntu真心不错,软件问题弄的快崩溃了
帖子发表于 : 2018-03-14 20:51 

注册: 2007-01-14 16:23
帖子: 4349
送出感谢: 0 次
接收感谢: 109
说吧,你之前干了什么,是不是把旧版本的包往新版本系统上装,或者把新版本系统的包往旧系统上装了


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ubuntu真心不错,软件问题弄的快崩溃了
帖子发表于 : 2018-03-14 21:16 

注册: 2009-08-04 16:33
帖子: 17908
送出感谢: 21
接收感谢: 1924
1. 養成習慣 要安裝套件以前 先執行
sudo apt update
sudo apt upgrade
把你的作業系統更新到最新版本
引用:
sudo dpkg -i libpng12-0_1.2.54-1ubuntu1_amd64.deb

2. https://packages.ubuntu.com/xenial/libpng12-0
套件: libpng12-0 (1.2.54-1ubuntu1)
Ubuntu 16.04 的 官方套件庫 已經可以提供 1.2.54-1ubuntu1 的 套件 libpng12-0
2-1. 你可以直接使用 下述指令安裝
sudo apt install libpng12-0
2-2. 如果還出現任何錯誤訊息 請全部複製貼上來



_________________
评价: 3.7% wy-ubuntu
 
页首
 用户资料  
 
4 楼 
 文章标题 : Re: ubuntu真心不错,软件问题弄的快崩溃了
帖子发表于 : 2018-03-14 21:23 

注册: 2018-03-14 19:57
帖子: 5
系统: ubuntu 16.04
送出感谢: 0 次
接收感谢: 0 次
onlylove 写道:
说吧,你之前干了什么,是不是把旧版本的包往新版本系统上装,或者把新版本系统的包往旧系统上装了

我也不知道为啥这样了.
为了安装mysqlworkbench 的依赖弄成这样了


页首
 用户资料  
 
5 楼 
 文章标题 : Re: ubuntu真心不错,软件问题弄的快崩溃了
帖子发表于 : 2018-03-14 21:27 

注册: 2018-03-14 19:57
帖子: 5
系统: ubuntu 16.04
送出感谢: 0 次
接收感谢: 0 次
poloshiao 写道:
1. 養成習慣 要安裝套件以前 先執行
sudo apt update
sudo apt upgrade
把你的作業系統更新到最新版本
引用:
sudo dpkg -i libpng12-0_1.2.54-1ubuntu1_amd64.deb

2. https://packages.ubuntu.com/xenial/libpng12-0
套件: libpng12-0 (1.2.54-1ubuntu1)
Ubuntu 16.04 的 官方套件庫 已經可以提供 1.2.54-1ubuntu1 的 套件 libpng12-0
2-1. 你可以直接使用 下述指令安裝
sudo apt install libpng12-0
2-2. 如果還出現任何錯誤訊息 請全部複製貼上來


无法更新了错误如下

sudo apt upgrade 100 ↵
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
您也许需要运行“apt-get -f install”来修正上面的错误。
下列软件包有未满足的依赖关系:
libpng12-0 : 破坏: libpng12-0:i386 (!= 1.2.49-1+deb7u2) 但是 1.2.54-1ubuntu1 已经安装
libpng12-0:i386 : 破坏: libpng12-0 (!= 1.2.54-1ubuntu1) 但是 1.2.49-1+deb7u2 已经安装
E: 不能满足依赖关系。不妨试一下 -f 选项。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: ubuntu真心不错,软件问题弄的快崩溃了
帖子发表于 : 2018-03-14 21:29 

注册: 2018-03-14 19:57
帖子: 5
系统: ubuntu 16.04
送出感谢: 0 次
接收感谢: 0 次
3楼大神,无法更新了

$sudo apt upgrade 100 ↵
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
您也许需要运行“apt-get -f install”来修正上面的错误。
下列软件包有未满足的依赖关系:
libpng12-0 : 破坏: libpng12-0:i386 (!= 1.2.49-1+deb7u2) 但是 1.2.54-1ubuntu1 已经安装
libpng12-0:i386 : 破坏: libpng12-0 (!= 1.2.54-1ubuntu1) 但是 1.2.49-1+deb7u2 已经安装
E: 不能满足依赖关系。不妨试一下 -f 选项。

apt-get -f install 执行就是楼的错误


页首
 用户资料  
 
7 楼 
 文章标题 : Re: ubuntu真心不错,软件问题弄的快崩溃了
帖子发表于 : 2018-03-14 21:44 

注册: 2018-03-14 19:57
帖子: 5
系统: ubuntu 16.04
送出感谢: 0 次
接收感谢: 0 次
感谢大家,搞定了,还是简单粗暴点解决问题,
直接修改 /var/lib/dpkg/status 删除冲突的重新来


页首
 用户资料  
 
8 楼 
 文章标题 : Re: ubuntu真心不错,软件问题弄的快崩溃了
帖子发表于 : 2018-03-18 19:48 

注册: 2006-01-06 22:55
帖子: 705
系统: ubuntu
送出感谢: 0 次
接收感谢: 10
可能会有后遗症


_________________
我的git代码
我的简书


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译