pppoe无法使用ipv6

为当前最终发行版之前的所有版本提供支持
回复
peishenfei2
帖子: 143
注册时间: 2016-07-20 16:40
系统: Ubuntu15
送出感谢: 9 次
接收感谢: 0

pppoe无法使用ipv6

#1

帖子 peishenfei2 » 2018-01-08 13:10

最近学校不用锐捷了,换了服务商,认证方式也变成了pppoe
好处是不用下载锐捷客户端了,直接点鼠标就能把网络连接好。
但是不知道为啥访问不了ipv6的站点,比如北邮人pt
最不能忍的是,没有ipv6,我的xx-net就翻不了墙了。。。。。

废话结束
-----------------------------------------------------
windows下面,拨号之后,就能访问ipv6站点,不用配置。
Ubuntu拨号之后,能正常访问网络(ipv4),但不能使用ipv6。

之前有个已经解决的相同的问题,

说在 /etc/ppp/options 最后,加上ipv6 ,(ipv6后面一个空格一个逗号)
但是我加上之后没用,有人和我有一样的问题,说是因为Ubuntu版本太新(我不想用旧的。。。)

还有人说,在 etc/default/ufw 下面加上 IPV6=yes
可是我的文件里面本来就有IPV6=yes(非注释状态)

双系统,windows 10 和 Ubuntu 17.10,桌面是KDE 5
谢谢。

附上我的ifconfig
:~$ ifconfig
enp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet6 fe80::10f6:79b8:2062:36f4 prefixlen 64 scopeid 0x20<link>
ether ee:fc:14:8d:c0:c8 txqueuelen 1000 (Ethernet)
RX packets 55477 bytes 75706759 (75.7 MB)
RX errors 0 dropped 75 overruns 0 frame 0
TX packets 59323 bytes 5215225 (5.2 MB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 1000 (Local Loopback)
RX packets 34858 bytes 12471628 (12.4 MB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 34858 bytes 12471628 (12.4 MB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

ppp0: flags=4305<UP,POINTOPOINT,RUNNING,NOARP,MULTICAST> mtu 1492
inet 10.60.3.5 netmask 255.255.255.255 destination 10.60.0.1
inet6 2001:250:1004:d000:2836:2899:60c3:ea2f prefixlen 64 scopeid 0x0<global>
inet6 2001:250:1004:d000:30ce:690e:a8f4:47f6 prefixlen 64 scopeid 0x0<global>
inet6 fe80::2836:2899:60c3:ea2f prefixlen 10 scopeid 0x20<link>
ppp txqueuelen 3 (Point-to-Point Protocol)
RX packets 1546 bytes 1404631 (1.4 MB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 1435 bytes 172827 (172.8 KB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
peishenfei2
帖子: 143
注册时间: 2016-07-20 16:40
系统: Ubuntu15
送出感谢: 9 次
接收感谢: 0

Re: pppoe无法使用ipv6

#2

帖子 peishenfei2 » 2018-01-14 15:12

自己顶一下,是不是我少给了一些信息,怎么没人回复呢。。。
peishenfei2
帖子: 143
注册时间: 2016-07-20 16:40
系统: Ubuntu15
送出感谢: 9 次
接收感谢: 0

Re: pppoe无法使用ipv6

#3

帖子 peishenfei2 » 2018-01-16 16:43

参考这个,解决了
blog.csdn.net/qq_18820397/article/details/51171220
原来是临时ipv6地址的问题.
回复

回到 “老旧版本支持”