安装P4est过程出现F77无法创建可执行文件

为当前最终发行版之前的所有版本提供支持
回复
desila
帖子: 6
注册时间: 2018-01-05 15:19
系统: Ubuntu
送出感谢: 1 次
接收感谢: 0

安装P4est过程出现F77无法创建可执行文件

#1

帖子 desila » 2018-01-09 16:49

代码如下:
d@d:~/下载/p4est-1.1$ ./configure --enable-mpi
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether make supports nested variables... (cached) yes
checking for a sed that does not truncate output... /bin/sed
checking Major version... 1
checking Minor version... 1
checking Point version... 1.1
o---------------------------------------
| Checking options
o---------------------------------------
o---------------------------------------
| Checking MPI and related programs
o---------------------------------------
checking whether we are using MPI... yes
checking whether we are using MPI I/O... yes
checking whether we are using MPI_Init_thread... yes
checking for mpiexec... mpiexec
configure: F77 set to mpif77
configure: FC set to mpif90
configure: CC set to mpicc
configure: CXX set to mpicxx
checking whether the Fortran 77 compiler works... no
configure: error: in `/home/d/下载/p4est-1.1':
configure: error: Fortran 77 compiler cannot create executables
See `config.log' for more details

我猜测是fortran的配置没有做好,但是不知道怎么改也不晓得猜测对不对,来请教下各位。
头像
九天星
帖子: 1347
注册时间: 2007-07-14 20:45
送出感谢: 67 次
接收感谢: 39 次

Re: 安装P4est过程出现F77无法创建可执行文件

#2

帖子 九天星 » 2018-01-09 18:49

权限不够
这些用户感谢了作者 九天星 于这个帖子:
desila (2018-01-10 9:27)
评价: 3.7%
desila
帖子: 6
注册时间: 2018-01-05 15:19
系统: Ubuntu
送出感谢: 1 次
接收感谢: 0

Re: 安装P4est过程出现F77无法创建可执行文件

#3

帖子 desila » 2018-01-10 9:27

九天星 写了:权限不够
谢谢!
回复

回到 “老旧版本支持”