当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 20 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 配置gedit的默认编码方式
帖子发表于 : 2006-11-20 22:23 

注册: 2006-07-26 22:18
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
我比较喜欢用英文界面,但是我很多文本文件又都是中文的(GBK)编码,每次双击打开,gedit都显示乱码,必须重新在打开窗口,选正确的编码(GB18030)才能正常显示。

解决方法:
用Configuratio Editor (命令:gconf-editor),修改app->gedit-2->preferences->encoding中的auto_detected, 把GB18030放在最前面即可。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-12-20 10:50 
头像

注册: 2006-09-06 12:24
帖子: 272
地址: Southeast University
送出感谢: 0 次
接收感谢: 0 次
不错,多谢了


_________________
awesome + stalonetrayer + urxvt + rox-filer + feh + SLiM


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-12-26 18:43 
头像

注册: 2006-12-09 19:22
帖子: 55
送出感谢: 0 次
接收感谢: 0 次
thank you


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-01-06 10:42 

注册: 2006-12-14 19:14
帖子: 160
送出感谢: 0 次
接收感谢: 0 次
如果用中文界面则没有这个问题。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-01-06 11:32 
头像

注册: 2006-10-18 12:57
帖子: 417
送出感谢: 0 次
接收感谢: 1
呵呵,楼主好办法,不过要是新建一个文件的时候会不会也默认gb18030的编码啊,
可以实现新建的时候选utf8吗


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-01-22 9:43 

注册: 2006-04-13 13:53
帖子: 305
送出感谢: 0 次
接收感谢: 1
fjchenq 写道:
如果用中文界面则没有这个问题。


如果中文设置为zh_CN.UTF8,好像gedit 也无法正确显示gbk编码的文件


_________________
奇虎聚客,客聚奇虎
http://ju.qihoo.com/u/kuerant/14528,4ba436.html

stay hungry, stay foolish


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-01-22 10:12 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
gedit在我机器里面是死鱼。几乎不用。不过似乎从来没编码识别的问题。而且文本文件需要gbk优先?尽量使用utf8吧。要不不如直接vim。


_________________
● 鸣学


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-12-21 13:49 
头像

注册: 2007-07-11 20:59
帖子: 3922
送出感谢: 0 次
接收感谢: 0 次
eexpress 写道:
gedit在我机器里面是死鱼。几乎不用。不过似乎从来没编码识别的问题。而且文本文件需要gbk优先?尽量使用utf8吧。要不不如直接vim。


不改编码,VIM一样是乱码


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-05-28 18:17 
头像

注册: 2007-12-03 9:54
帖子: 943
送出感谢: 0 次
接收感谢: 0 次
照楼主说的试了试还是不行,leafpad有的能打开有的打不开,但是gedit基本上都打不开


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-09-18 10:09 

注册: 2007-11-18 16:11
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
赞,lz的方法很解决问题!


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 配置gedit的默认编码方式
帖子发表于 : 2009-03-24 11:36 
头像

注册: 2008-02-01 13:24
帖子: 169
地址: 无锡
送出感谢: 0 次
接收感谢: 0 次
感谢楼主


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 配置gedit的默认编码方式
帖子发表于 : 2009-06-25 0:49 
头像

注册: 2008-04-17 11:29
帖子: 39
地址: 成都
送出感谢: 0 次
接收感谢: 0 次
很有用,谢谢分享。


_________________
永无止尽的学习


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 配置gedit的默认编码方式
帖子发表于 : 2009-10-02 23:40 
头像

注册: 2009-08-09 17:34
帖子: 300
送出感谢: 0 次
接收感谢: 0 次
和你说的不太一样
/apps/gedit-2/preferences/encodings/auto_detected


附件:
Screenshot-1.png
Screenshot-1.png [ 446.67 KiB | 被浏览 7266 次 ]



_________________
淡定,不要听风就是雨。淡定是一种境界,是一种超然世外的意识。只有修养达到一定阶段,才能产生并拥有。拥有了淡定,就拥有了风度。于是淡定便成了一种气质,让我辈无论如何努力和奋斗,始终难望其项背。淡定需要时间和实践的积淀和净化,是一种拨云见日,是一种豁然开朗!君子坦荡荡,小人长戚戚。愿我们除了自卑多了自由,少了忙乱多了从容,去了怨恨多了温煦,戒了偏激多了沉着。一切在淡定中发展,在淡定中凯旋。
页首
 用户资料  
 
14 楼 
 文章标题 : Re: 配置gedit的默认编码方式
帖子发表于 : 2009-11-10 21:43 

注册: 2009-04-09 7:47
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
谢谢分享


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 配置gedit的默认编码方式
帖子发表于 : 2009-11-15 15:35 
头像

注册: 2009-11-11 17:09
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
很好,我的问题解决了!


_________________
我的世界很精彩,我的世界很无奈!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 20 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译