当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求助,按照贴子里的改xorg.conf文件后启动进入不了图形界面
帖子发表于 : 2009-02-22 17:09 

注册: 2007-10-17 20:40
帖子: 41
送出感谢: 0 次
接收感谢: 0 次
安装了hiweed 2.0RC3,终于看到五笔了,可是分辨率太小了,才800*600,上网搜索一下,找到如下文章,说是能够有1024*768分辨率的选项。
引用:
方法1、修改xorg.conf文件

1、安装Vboxaditions增强工具包
2、sudo leafpad /etc/X11/xorg.conf
3、在Section "Device" 中增加Driver "vboxvideo"

Section "Device"
Identifier "Configured Video Device"
Driver "vboxvideo"
Option "UseFBDev" "true"
EndSection

4、Section "Monitor"
Identifier "Configured Monitor"
HorizSync 30-95
VertRefresh 60-75
EndSection

5、Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
SubSection "Display"
Virtual 1280 800
Depth 24
Modes "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
EndSection


按照如上修改后,结果重启的时候进不了图形界面,郁闷,在命令行下startx也进入不了,如下图:
图片
请教应该怎么解决?
还好是在虚拟机中测试。。。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 求助,按照贴子里的改xorg.conf文件后启动进入不了图形界面
帖子发表于 : 2009-02-22 17:34 
头像

注册: 2008-12-19 13:44
帖子: 2337
地址: 东8区
送出感谢: 0 次
接收感谢: 0 次
虚拟机虚拟的硬件时和你写的xorg.conf会一样吗?


_________________
代码:
 
       \   ,__,
        \  (oo)____
           (__)    )\
              ||--|| * 
 


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 求助,按照贴子里的改xorg.conf文件后启动进入不了图形界面
帖子发表于 : 2009-02-22 17:53 

注册: 2007-10-17 20:40
帖子: 41
送出感谢: 0 次
接收感谢: 0 次
虚拟机里的硬件应该也跟外面的系统硬件配置一样的,刚刚找金山词霸翻译了一下,估计问题出在这句上
failed to load module "vboxvideo"(module does not exist,0)
vboxvideo模块加载失败(模块不存在)

在那方法里面第一步:1、安装Vboxaditions增强工具包,可能这个我没有安装吧,可是我当时在CMD命令行下apt-get Vboxaditions的时候他是没有找到。

现在问题就是如何还原回来,在命令行下编辑xorg.conf文件后应该能还原回来,可是命令行下的我不会啊。。可以教教我么。。。 :em06 :em06 :em06 :em03 :em03 :em03


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 求助,按照贴子里的改xorg.conf文件后启动进入不了图形界面
帖子发表于 : 2009-02-22 20:17 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
Hiweed2.0RC3是基于810的,可以到硬件支持板块找显卡驱动的安装贴子。
命令行修改Xorg.conf的命令超简单,我都不好意思回复了。 :em03
sudo leafpad /etc/X11/xorg.conf
修改后保存就可以了。
在Hwd官方论坛,Hua大已经给出了修改后的Xfce4的各Deb包了,可以下回来试下。


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 求助,按照贴子里的改xorg.conf文件后启动进入不了图形界面
帖子发表于 : 2009-02-23 9:18 

注册: 2007-10-17 20:40
帖子: 41
送出感谢: 0 次
接收感谢: 0 次
不行,因为是在命令行下的。。。。编辑不了啊。。。大家请看。。。
图片
现在我是已经startx进不了图形界面了。。。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 求助,按照贴子里的改xorg.conf文件后启动进入不了图形界面
帖子发表于 : 2009-02-23 10:01 
头像

注册: 2007-06-13 15:57
帖子: 12567
地址: 在他乡
送出感谢: 50
接收感谢: 87
用vi 吧


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 求助,按照贴子里的改xorg.conf文件后启动进入不了图形界面
帖子发表于 : 2009-02-23 11:13 
头像

注册: 2008-12-19 13:44
帖子: 2337
地址: 东8区
送出感谢: 0 次
接收感谢: 0 次
虚拟机里的硬件应该也跟外面的系统硬件配置一样的,会一样吗?vboxvideo这个时虚拟机的模块vbox看到没。真机上会有这个vboxvideo吗?


_________________
代码:
 
       \   ,__,
        \  (oo)____
           (__)    )\
              ||--|| * 
 


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 求助,按照贴子里的改xorg.conf文件后启动进入不了图形界面
帖子发表于 : 2009-02-23 15:41 

注册: 2007-10-17 20:40
帖子: 41
送出感谢: 0 次
接收感谢: 0 次
经过一翻搜索,终于解决, 本论坛里的另一张贴子教的, sudo dpkg-reconfigure xserver-xorg,
打开后是乱码,那贴子说之前先 export LANG=en_US:UTF-8 ,但是弄了以后还是乱码,我只好在那乱码界面乱按回车,乱输东西,最后回到黑色界面了,再次输入startx的时候就能进到界面了...耶.... :em11 :em11 :em11


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译