问一个ati显卡配置的问题

Ubuntu中文汉化版
回复
yulewang
帖子: 154
注册时间: 2006-08-12 22:00
送出感谢: 0
接收感谢: 0

问一个ati显卡配置的问题

#1

帖子 yulewang » 2006-09-18 20:47

现在我要拿着我的laptop去做一个讲座。我的电脑是dell 6400,ati x1300显卡。
由于电脑是宽屏的,投影仪不是,所以要分别设置分辨率,怎么做?
当初我安装ubuntu的时候是自己安装的ati私有驱动,装完以后,
桌面菜单里面有一个ati的可以设置第一个屏幕和第二个屏幕的分辨率的配置软件,
但是好像hiweed里面没有。
头像
huangjiahua
帖子: 3294
注册时间: 2005-03-30 0:27
送出感谢: 0
接收感谢: 1 次
联系:

你的是什么 ATI 显卡啊

#2

帖子 huangjiahua » 2006-09-19 1:38

不太旧的 ATI 显卡会自动安装 fglrx-control 和 xorg-driver-fglrx ,
可以用 fireglcontrol 来调整屏幕。

如果菜单里没有找到 fireglcontrol , 就在终端里执行 fireglcontrol



如果没有自动安装 ATI 私有驱动, 就手工安装

代码: 全选

    sudo apt-get install xorg-driver-fglrx     fglrx-control
    sudo aticonfig --initial
    sudo aticonfig --overlay-type=Xv
    
    sudo depmod -a ; sudo modprobe fglrx
跃过无数的时间断层,只为了在
yulewang
帖子: 154
注册时间: 2006-08-12 22:00
送出感谢: 0
接收感谢: 0

#3

帖子 yulewang » 2006-09-19 10:13

我认为我的驱动已经在安装hiweed的时候自动安装了,因为我跑xgl很流畅。但是fireglcontrol会出现一些问题。

我现在已经按照你的去做了。重新弄了一下(xgl下),然后
yulewang@yulewang-laptop:~$ fglrxinfo
Xlib: extension "XFree86-DRI" missing on display ":3.0".
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon X1300 Generic
OpenGL version string: 2.0.5814 (8.25.18)
说XFree86-dri missing
接着fireglcontrol,提示,driver does not provide the FireGL X11 extensions!
Panel components will operate only partially
yulewang
帖子: 154
注册时间: 2006-08-12 22:00
送出感谢: 0
接收感谢: 0

#4

帖子 yulewang » 2006-09-19 10:16

然后我到了xfce非xgl下,
yulewang@yulewang-laptop:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon X1300 Generic
OpenGL version string: 2.0.5814 (8.25.18)

yulewang@yulewang-laptop:~$ fireglcontrol
X Error: BadDevice, invalid or uninitialized input device 168
Major opcode: 148
Minor opcode: 3
Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 168
Major opcode: 148
Minor opcode: 3
Resource id: 0x0
Failed to open device

依然无法配置分辨率,虽然可以出来的选项卡多了一些~~
头像
huangjiahua
帖子: 3294
注册时间: 2005-03-30 0:27
送出感谢: 0
接收感谢: 1 次
联系:

#5

帖子 huangjiahua » 2006-09-19 17:49

难不成用的 Ubuntu 6.06 提供的驱动太旧了 ?

自己安装新的 ati 驱动呢 ?
跃过无数的时间断层,只为了在
yulewang
帖子: 154
注册时间: 2006-08-12 22:00
送出感谢: 0
接收感谢: 0

#6

帖子 yulewang » 2006-09-19 18:34

好像真的是这样子的。源里面的好像是8.25的,而我当初安装的时候好像就是8.27.10的,呵呵。
看来我要重新安装一下。请问我现在应该怎么安装呢?
当初我是这样装的,您过目一下,这样可以吗?
How to install ATI driver?

Fisrt get the driver package:

wget https://a248.e.akamai.net/f/674/9206/0/ ... 10-x86.run
apt-get install module-assistant build-essential
apt-get install fakeroot dh-make debconf libstdc++5 gcc-3.3-base


blacklist old fglrx module from linux-restricted-modules
emacs /etc/default/linux-restricted-modules-common

Edit DISABLED MODULES to include fglrx
DISABLED_MODULES=’’fglrx’’


Next create .deb packages:
chmod +x ati-driver-installer-8.27.10-x86.run
./ati-driver-installer-8.27.10-x86.run --buildpkg Ubuntu/dapper


Install .deb packages:
dpkg -i xorg-driver-fglrx_8.27.10-1_i386.deb
dpkg -i fglrx-kernel-source_8.27.10-1_i386.deb
dpkg -i fglrx-control_8.27.10-1_i386.deb

Compile the kernel module:
module-assistant prepare
module-assistant update
module-assistant build fglrx
module-assistant install fglrx
depmod -a

aticonfig --initial
aticonfig --overlay-type=Xv

Reboot and confirm that it worked
#fglrxinfo

My laptop use a widescreen display, but X window has not support its resolution yet.

So you can manullay add Virtual 1280 800 under your xorg.conf Mode line.

我看了一下,当初我还用VIrtual修改分辨率,现在我看xorg.conf里面却没有这一项,hiweed是怎么做的?呵呵

还有为什么在xfce和xgl compiz下面运行fireglcontrol和fglrxinfo的结果是不一样的,我被搞糊涂了
头像
huangjiahua
帖子: 3294
注册时间: 2005-03-30 0:27
送出感谢: 0
接收感谢: 1 次
联系:

安装没问题

#7

帖子 huangjiahua » 2006-09-19 20:46

在 Xorg 下运行吧,
Xgl 不支持多显示器不同输出。
跃过无数的时间断层,只为了在
回复

回到 “Ubuntu中文衍生版”