当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]huahua请进,升级到beryl,应该怎样修改 startxfce4xgl.sh 来启动beryl??
帖子发表于 : 2006-10-13 20:32 

注册: 2006-03-21 10:47
帖子: 406
送出感谢: 0 次
接收感谢: 0 次
终于升级到beryl了,可以通过在自启动程序里面添加beryl-manager来启动beryl,但是觉得不爽,huahua,请问怎样修改 startxfce4xgl.sh 来启动beryl呢??


ps:装了nvidia的beta驱动,终于可以在beryl下实现加速了,direct render 为 yes,用mplayer看电影流畅了很多。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-10-14 2:32 

注册: 2006-08-12 22:00
帖子: 154
送出感谢: 0 次
接收感谢: 0 次
Xgl -fullscreen :1 -ac -accel glx:pbuffer -accel xv:pbuffer -br & sleep 2 && DISPLAY=:1
runberyl(){
sleep 5
killall xfwm4
/usr/bin/beryl-manager &
/usr/bin/xmodmap -e "keycode 22 = BackSpace"
DISPLAY=:0.0 setxkbmap us -print | xkbcomp - $DISPLAY
xmodmap /usr/share/apps/kxkb/ubuntu.xmodmap
}
runberyl &
xfce4-session
我的脚本就这样。第一行你照着你的显示卡修改。sleep的数值按照你的实际情况。我的只要1就可以了。
不要把那个东西加到启动项目,不好。我在这个论坛吼了n下,每人理会我:(


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-10-14 11:19 

注册: 2006-03-21 10:47
帖子: 406
送出感谢: 0 次
接收感谢: 0 次
是不太方便,因为启动出错的话,要到 ~。/config/aotustart/下面把启动脚本删掉才行,我昨天晚上就是因为升级了系统,beryl出错了,白屏,开始不知在哪里把启动项去掉,找了好久才找到,不过去掉后还是有问题,今天重装了显卡驱动,终于好了。 :D


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-10-14 11:47 

注册: 2006-03-21 10:47
帖子: 406
送出感谢: 0 次
接收感谢: 0 次
yulewang,试了你的脚本,还是不行阿,不知道是怎么回事??
下面是.xsession-error的错误信息,帮忙看看是怎么回事??
引用:
/etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
/etc/gdm/PreSession/Default: running: /usr/X11R6/bin/sessreg -a -w /var/log/wtmp -u /var/run/utmp -x "/var/lib/gdm/:0.Xservers" -h "" -l ":0" "libohui"
/etc/gdm/Xsession: Beginning session setup...
Setting IM through im-switch for locale=zh_CN.
Start IM through /etc/X11/xinit/xinput.d/zh_CN linked to /etc/X11/xinit/xinput.d/scim.
Launching a SCIM daemon with Socket FrontEnd...
Loading simple Config module ...
Creating backend ...
/bin/bash: -
: invalid option
Usage: /bin/bash [GNU long option] [option] ...
/bin/bash [GNU long option] [option] script-file ...
GNU long options:
--debug
--debugger
--dump-po-strings
--dump-strings
--help
--init-file
--login
--noediting
--noprofile
--norc
--posix
--protected
--rcfile
--restricted
--verbose
--version
--wordexp
Shell options:
-irsD or -c command or -O shopt_option (invocation only)
-abefhkmnptuvxBCHP or -o option


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-10-14 12:45 

注册: 2006-08-12 22:00
帖子: 154
送出感谢: 0 次
接收感谢: 0 次
要么试试看这个?你用的是什么卡?要么第二行还是换成huahua脚本来?
我用的是ati x1300显卡。写了一个脚本,我的机器上没有任何问题。
然后正要找人测试,每人搭理我:(

另外你根据那些文章修改gdm.conf之类的文件,有没有改动回来?
由于我是startx进入桌面,不存在这个问题。要不你换成startx试试看?

http://www.hiweed.com/node/344



#!/bin/sh
Xgl -fullscreen :1 -ac -accel glx:pbuffer -accel xv:pbuffer -br & sleep 2 && DISPLAY=:1
runberyl(){
sleep 5
killall xfwm4
/usr/bin/beryl-manager &
}
runberyl &
xfce4-session


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-10-14 12:50 

注册: 2006-08-12 22:00
帖子: 154
送出感谢: 0 次
接收感谢: 0 次
上面的原因可能是你运行脚本的时候多加了一个-之类的东西,你检查一下?或者直接startx试试看。
编辑.xinitrc如下:
startxfce4xgl.sh
然后gdm停掉sudo /etc/init.d/gdm stop
字符终端下面输入startx试试看.
等你的结果.


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-10-14 13:50 

注册: 2006-03-21 10:47
帖子: 406
送出感谢: 0 次
接收感谢: 0 次
先要谢谢yulewang。
我用的是nvidia gf3显卡,我用的是xubuntu 6.10 beta,我没有修改过gdm.conf,我只是按照xgl:how to里面说的添加了xfce4-xgl.desktop和/usr/bin/startxfce4xgl.sh这两个文件。
xfce4-xgl.desktop:
代码:
[Desktop Entry]
Encoding=UTF-8
Name=xfce-xgl
Exec=/usr/bin/startxfce4xgl.sh
Icon=
Type=Application

startxfce4xgl.sh:
代码:
#!/bin/bash -v
#
# start a Xgl session
#
#Xgl -fullscreen :1 -ac &

Xgl -fullscreen :1 -ac -accel glx:pbuffer -accel xv:pbuffer -dpi 96  & sleep 2 && DISPLAY=:1

runberyl(){
    sleep 5s
    killall xfwm4
    sleep 1s
    /usr/bin/beryl-manager &
    /usr/bin/xmodmap -e "keycode 22 = BackSpace"   # for  shift + Backspace
    DISPLAY=:0.0 setxkbmap us -print | xkbcomp - $DISPLAY
    xmodmap /usr/share/apps/kxkb/ubuntu.xmodmap
}
runberyl &
xfce4-session

看看这两个文件有什么错误吗??
其他什么地方都没有修改过,也不知道为什么beryl起不了的,不过现在暂时把beryl-manager放到自启动程序里面用着先。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-10-14 14:00 

注册: 2006-03-21 10:47
帖子: 406
送出感谢: 0 次
接收感谢: 0 次
我用的是xubuntu 6.10 beta,我原来是用hiwee的,后来hiweed出了问题,就试试xubuntu,与hiweed对比,我发觉xubuntu在速度上要快一点,尤其是thunar,打开目录不用等上好一阵子。不过缺点就是软件要自己安装,自己动动手也是有好处的。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-10-14 14:30 

注册: 2006-08-12 22:00
帖子: 154
送出感谢: 0 次
接收感谢: 0 次
抱歉了。我的还是dapper。没有使用过edgy。我计算机中有非常重要的资讯,不敢轻易升级。
edgy好像对于nv的卡不用xgl的吧~直接可以通过aiglx来beryl。还是问一下huahua吧~
另外您是不是参看过一些帖子,其中教导要修改/etc/gdm.conf和/etc/gdm.conf-custom等档。网路上面很多帖子都是这样说的。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-10-14 14:32 

注册: 2006-08-12 22:00
帖子: 154
送出感谢: 0 次
接收感谢: 0 次
gmlbh 写道:
我用的是xubuntu 6.10 beta,我原来是用hiwee的,后来hiweed出了问题,就试试xubuntu,与hiweed对比,我发觉xubuntu在速度上要快一点,尤其是thunar,打开目录不用等上好一阵子。不过缺点就是软件要自己安装,自己动动手也是有好处的。

呵呵,我把hiweed重新大修了一下,现在开机只要25秒钟就进入X了。很锻炼动手能力的。呵呵。


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2006-10-14 21:42 

注册: 2006-03-21 10:47
帖子: 406
送出感谢: 0 次
接收感谢: 0 次
我已经按照wiki里面说的安装了sysv-rc-conf,而且修改了不少随系统启动的服务,但是现在开机不算很快,你有什么秘诀吗??怎么大修阿??


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译