当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : hiweed 1.0 升级到 ubuntu 6.10
帖子发表于 : 2006-11-02 11:27 

注册: 2006-10-27 19:20
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
已经升级了好几天了,没出什么问题,当然,我没出问题并不意味着所有人都不会出问题,所以,假如你决定把它升级到6.10,那么,还是那句老话:On your own risk.

一、把源升级到edgy

sudo vi /etc/apt/sources.list

:%s/drapper/edgy/g (这是vi的替换命令,%-整个文档范围,drapper - 待替换字符串,edgy - 替换字符串)
:wq (write & quit,存盘退出)

二、update
sudo apt-get update
(用新立得也可以,就是刷新一下)

三、dist-upgrade
sudo apt-get dist-upgrade
(注意,是dist-upgrade,不是upgrade。)

然后,就会告诉你哪些包将会升级,哪些会删除,哪些保持不变。一般来说,删除的包都是改名了或者被别的包代替了,注意看看,如果重要的包被删除了而又没有安装新的相应的包的话,就要检查一下你的源了。

我这里升级中途把X杀了,所以,建议退到console(Ctrl+Alt+F1)下面执行,回到X用Ctrl+Alt+F7。

四、dist-upgrade
sudo apt-get dist-upgrade

是的,这个命令要再执行一次。

五、upgrade
sudo apt-get upgrade
注意要把所有的包都升级哦,如果有些包没有升级,可以sudo apt-get install xxxxx,多半是因为要删除或替换某些包,所以,必须手工升级它。

六、检查xorg
据说(我没遇到)xorg不会自动装上,要手工装一次,所以,试试sudo apt-get install xserver-xorg,如果已经装了就不管了。

七、reboot
sudo reboot

呵呵,应该就算升级完了,我这里显卡驱动需要重新安装一下,别的都没什么。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-11-02 12:00 

注册: 2006-10-27 19:20
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
补充说明:

一、显卡驱动

升级后,显卡驱动一般来说需要重新安装,不同的显卡安装方法不一样,请自行查找相关文档。我用的是ati 9550,完全参照这篇文档就OK了:http://wiki.cchtml.com/index.php/Ubuntu_Edgy_Installation_Guide

注意,如果3D加速打不开,请注意文档的其中一段: “Disable Composite Extension”

二、开关机画面

我升级后开关机画面都没有了,可以这么处理:

sudo apt-get install usplash-theme-ubuntu

这个包提供了/usr/lib/usplash/usplash-theme-ubuntu.so,然后运行:

sudo update-alternatives --config usplash-artwork.so

这时会给出你当前安装了的splash,比如我的运行结果是:

There are 3 alternatives which provide `usplash-artwork.so'.

Selection Alternative
-----------------------------------------------
+ 1 /usr/lib/usplash/hiweed-splash.so
2 /usr/lib/usplash/usplash-theme-xubuntu.so
* 3 /usr/lib/usplash/usplash-theme-ubuntu.so

Press enter to keep the default[*], or type selection number:

第3个就是我要使用的splash,输入3即可,如果你喜欢hiweed原来的画面,就输入1,我还装了xubuntu的splash(xubuntu-artwork-usplash),你也可以尝试一下。

最后,别忘了重新生成initramfs,让你的splash生效。

sudo dpkg-reconfigure linux-image-$(uname -r)

6.10默认是quiet,也就是开关机没有那些ok的提示了,你可以编辑grub配置文件,把quiet去掉:

sudo vi /boot/grub/menu.lst
去掉kernel 那一行后面的quiet。

三、如果。。。。。。

更多问题,参考

http://www.debianadmin.com/ubuntu-edgy- ... tions.html

和官方wiki,也欢迎在此提问 。

enjoy~


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-11-03 18:20 
头像

注册: 2006-05-13 14:38
帖子: 171
送出感谢: 0 次
接收感谢: 0 次
:em50


页首
 用户资料  
 
4 楼 
 文章标题 : 上不了网
帖子发表于 : 2006-11-04 16:29 

注册: 2005-04-26 3:29
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
照lz方法升级,然后上不了网。
昨天开机能连上一次,再重启又不行。
检查软件包发现有pppoeconf,但没有pppoe,装上后还是不行。
我是adsl,这是什么原因啊?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译