当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : hiweed1.0升级后不能进入xfce4的问题
帖子发表于 : 2007-01-03 18:16 

注册: 2005-08-21 15:30
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
hiweed1.0升级后不能进入xfce4的问题

(本来是贴在linuxsir的,现在挪过来)
--------------------------------------------------------------------------------


如题。原来在hiweed1.0上装了imagemagic以后不能用xgl了,装上beryl也不能用,最近发现原来是xfce4根本就启动不起来(因为我平时用fvwm,所以没有发现这一点)。看了一下错误报告,总说是在~/.config/.xfce4/下缺一个文件。原以为是高本版的xfce4和以前版本的有区别,可是没有见到大家有类似的错误报告,于是确定是hiwwed的问题。在fvwm中启动xfce4-session可以运行,说明是gdm启动xfce4时有问题。找了找,发现/usr/bin/startxfce4和/usr/bin/startxfce4xgl.sh这两个脚本是gdm启动xfce4和带xgl的xfce4所用的脚本,而且,这两个脚本作者是花花同学~~~

把两个脚本里的内容换成

代码:
exec xfce4-session

就可以正常起动xfce4了,beryl也可以正常运行

请有类似问题的同学参考一下,
另外,这两个脚本是做什么用的??请懂shell的人帮着看看。
还有一个问题,我怎么才能让beryl自动运行呢??每回我都是进入xfce4后又输入的beryl和beryl-manager启动。。。

两个脚本代码如下:
代码:
#/usr/bin/startxfce4:

#!/bin/sh
#
#  xfce4
#
#  Copyright (C) 1996-2003 Olivier Fourdan (fourdan@xfce.org)
#
#  This program is free software; you can redistribute it and/or modify
#  it under the terms of the GNU General Public License as published by
#  the Free Software Foundation; either version 2 of the License, or
#  (at your option) any later version.
#
#  This program is distributed in the hope that it will be useful,
#  but WITHOUT ANY WARRANTY; without even the implied warranty of
#  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
#  GNU General Public License for more details.
#
#  You should have received a copy of the GNU General Public License
#  along with this program; if not, write to the Free Software
#  Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
#

if test x"$XDG_CONFIG_HOME" = x""
then
  BASEDIR=$HOME/.config/xfce4/
else
  BASEDIR=$XDG_CONFIG_HOME/xfce4
fi

if test x"$XDG_DATA_DIRS" = x""
then
  XDG_DATA_DIRS="/etc/xdg/xubuntu:/usr/share:/usr/local/share:/usr/share"
else
  XDG_DATA_DIRS="$XDG_DATA_DIRS:/usr/share"
fi
export XDG_DATA_DIRS

if test x"$DISPLAY" = x""
then
  echo "$0: Starting X server"
  prog=xinit
else
  echo "$0: X server already running on display $DISPLAY"
  prog=/bin/sh
fi

if [ -f $BASEDIR/xinitrc ]; then
  exec $prog $BASEDIR/xinitrc $*
elif [ -f $HOME/.xfce4/xinitrc ]; then
  mkdir -p $BASEDIR
  cp $HOME/.xfce4/xinitrc $BASEDIR/
  exec $prog $BASEDIR/xinitrc $*
else
  exec $prog /etc/xdg/xfce4/xinitrc $*
fi 



代码:
#/usr/bin/startxfce4xgl.sh:

#!/bin/bash -v
#
# start a Xgl session
#
# Author: huangjiahua
#
# Depends:  compiz  compiz-plugins cgwd cgwd-themes  xserver-xgl    xfce4 metacity  compiz-manager csm  libgl1-mesa  libglitz-glx1


Xgl -fullscreen :3 -ac &
Xgl -fullscreen :3 -ac -accel glx:pbuffer -accel xv:pbuffer -dpi 96  &

export DISPLAY=:3
sleep 2s

## xmodmap end Xresources
/usr/bin/xmodmap /usr/share/apps/kxkb/ubuntu.xmodmap || true
/usr/bin/xmodmap -e "keycode 22 = BackSpace"   # for  shift + Backspace
/usr/bin/xrdb -merge ~/.Xresources || xmessage xrdb ~/.Xresources  failed &

## about Xsession.d
#for i in /etc/X11/Xsession.d/* ; do
# source $i
#done

. /etc/X11/Xsession.d/*im-switch   || xmessage . /etc/X11/Xsession.d/*im-switch failed  &

## launch fcitx
#export XMODIFIERS=@im=SCIM ; fcitx || scim -d


domycompiz(){
    ## for the drivers bug
    export LD_PRELOAD=/usr/lib/libGL.so.1.2
   
    #xfwm4 &
    sleep 5s
    killall xfwm4
    ## about compiz-manager
    ( pidof compiz-manager || compiz-manager || compiz --replace dbus csm ) &
    sleep 1s
    # compiz --replace dbus csm
    ## launch cgwd
    sleep 1s
    mkdir -p ~/.cgwd/theme
    dbus-launch cgwd --replace &
}
domycompiz &

#xfce4-panel
#startxfce4
xfce4-session

# unlock
rm -f /tmp/.X3-lock  /tmp/.X11-unix/X3


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-01-04 0:40 
头像

注册: 2005-03-30 0:27
帖子: 3294
送出感谢: 0 次
接收感谢: 2
升级以后, 如果不用 Xgl ,或者你改了启动脚本, 可以把 beryl-manager 添加到自启动里。
( 开始菜单-》设置-》自启动, 添加 )


gdm 用的登录项在 /usr/share/xsessions/ 下面, 去看看里边的 .desktop 文件, 看看改了什么


另,详细的错误报告 ?


_________________
跃过无数的时间断层,只为了在


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-01-04 13:18 

注册: 2005-08-21 15:30
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
/usr/share/xsessions/下面没有 .desktop文件。有xfce4 session和xfce-xgl两个脚本,内容分别是起动/usr/bin/startxfce4和/usr/bin/startxfce4xgl.sh两个脚本


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-01-04 13:32 

注册: 2005-08-21 15:30
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
错误报告在这里,不过这个是经过我改动后报告出来的,改动前,他说找不到~/.config/xfce4/xinitrc

代码:
/etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
/etc/gdm/PreSession/Default: running: /usr/X11R6/bin/sessreg -a -w /var/log/wtmp -u /var/run/utmp -x "/var/lib/gdm/:0.Xservers" -h "" -l ":0" "yuelang"
/etc/gdm/Xsession: Beginning session setup...
Setting IM through im-switch for locale=zh_CN.
Start IM through /home/yuelang/.xinput.d/zh_CN linked to /etc/X11/xinit/xinput.d/fcitx.
/usr/bin/startxfce4: X server already running on display :0


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-01-04 23:04 
头像

注册: 2005-03-30 0:27
帖子: 3294
送出感谢: 0 次
接收感谢: 2
/usr/share/xsessions/ 下那些就是 desktop 文件 ( 文件类型不管扩展名)

xfce4 的里面理应是 Exec=xfce4-session
( 而不是 startxfce4 )
你的不知道什么原因被修改了。


_________________
跃过无数的时间断层,只为了在


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-01-05 9:28 

注册: 2005-08-21 15:30
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
晕,我是没有改过。而且我重装了系统两遍,都是出现这个问题。我没有电脑,所以再尝试的可能性很小,不知道还有没有人出现这个现象


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译