[问题]xorg-dev无法安装

Ubuntu中文汉化版
回复
drazet
帖子: 34
注册时间: 2006-02-10 13:24
送出感谢: 0
接收感谢: 0

[问题]xorg-dev无法安装

#1

帖子 drazet » 2007-01-14 23:47

要编译emacs需要安装xorg-dev
但是sudo apt-get install xorg-dev 后出现依赖错误,无法安装怎么办?
错误信息:

代码: 全选

drazet@nbyteam:~$ sudo apt-get install xorg-dev
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
  xorg-dev: 依赖: libxcomposite-dev 但是它将不会被安装
            依赖: libxcursor-dev 但是它将不会被安装
            依赖: libxdamage-dev 但是它将不会被安装
            依赖: libxfixes-dev 但是它将不会被安装
E: 无法安装的软件包
头像
huangjiahua
帖子: 3294
注册时间: 2005-03-30 0:27
送出感谢: 0
接收感谢: 1 次
联系:

#2

帖子 huangjiahua » 2007-01-15 0:02

apt 会自己解决编译依赖

代码: 全选

sudo apt-get build-dep emacs-snapshot-gtk
跃过无数的时间断层,只为了在
回复

回到 “Ubuntu中文衍生版”