当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求救:ping localhost不通怎么办?
帖子发表于 : 2007-02-27 18:48 

注册: 2006-10-18 15:48
帖子: 700
送出感谢: 0 次
接收感谢: 0 次
sun@young:~$ ping localhost
PING localhost (127.0.0.1) 56(84) bytes of data.

然后就定在那里

ping自己的ip也是这样

但是在别人机子上ping自己的ip可以ping通

各位大侠,怎么办?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 求救:ping localhost不通怎么办?
帖子发表于 : 2007-02-27 18:50 

注册: 2006-10-18 15:48
帖子: 700
送出感谢: 0 次
接收感谢: 0 次
我的/etc/hosts如下:

211.69.199.234 young
127.0.0.1 localhost
211.69.199.254 gate
211.69.199.236 old
211.69.199.209 yao
202.114.0.242 dns
66.102.11.125 talk.google.com

sunzhaoyu2000 写道:
sun@young:~$ ping localhost
PING localhost (127.0.0.1) 56(84) bytes of data.

然后就定在那里

ping自己的ip也是这样

但是在别人机子上ping自己的ip可以ping通

各位大侠,怎么办?


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-02-27 20:00 
头像

注册: 2006-05-19 21:23
帖子: 1277
送出感谢: 0 次
接收感谢: 0 次
ifconfig -a 结果中有没有下面的内容:
代码:
lo        链路封装:本地环回 
          inet 地址:127.0.0.1  掩码:255.0.0.0
          inet6 地址: ::1/128 Scope:Host


_________________
其实我是一个演员!-http://blog.csdn.net/xport/


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-02-27 21:54 

注册: 2006-10-18 15:48
帖子: 700
送出感谢: 0 次
接收感谢: 0 次
ifconfig -a结果如下,再该怎么办:)


eth0 Link encap:Ethernet HWaddr 00:16:E6:5C:85:5C
inet addr:211.69.199.234 Bcast:211.69.199.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:71004 errors:0 dropped:0 overruns:0 frame:0
TX packets:44272 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:39093798 (37.2 MiB) TX bytes:13438693 (12.8 MiB)
Interrupt:169 Memory:e8000000-0

lo Link encap:Local Loopback
LOOPBACK MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)



xport 写道:
ifconfig -a 结果中有没有下面的内容:
代码:
lo        链路封装:本地环回 
          inet 地址:127.0.0.1  掩码:255.0.0.0
          inet6 地址: ::1/128 Scope:Host


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-02-27 22:17 

注册: 2006-10-18 15:48
帖子: 700
送出感谢: 0 次
接收感谢: 0 次
在你的提示下我发现是interfaces的问题
现在已经解决了
万分感谢

xport 写道:
ifconfig -a 结果中有没有下面的内容:
代码:
lo        链路封装:本地环回 
          inet 地址:127.0.0.1  掩码:255.0.0.0
          inet6 地址: ::1/128 Scope:Host


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-02-27 22:30 
头像

注册: 2006-05-19 21:23
帖子: 1277
送出感谢: 0 次
接收感谢: 0 次
这个...我只想到了开头,却没有预料到结局!你做了生么样的fix呢?


_________________
其实我是一个演员!-http://blog.csdn.net/xport/


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-02-27 23:07 

注册: 2005-10-28 17:40
帖子: 172
送出感谢: 0 次
接收感谢: 0 次
在interfaces里加上:
auto lo
iface lo inet loopback


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-02-28 7:53 
头像

注册: 2006-05-19 21:23
帖子: 1277
送出感谢: 0 次
接收感谢: 0 次
gtx 写道:
在interfaces里加上:
auto lo
iface lo inet loopback


这个...楼主在配置网络的时候为什么会没有这段的设定呢? :roll:


_________________
其实我是一个演员!-http://blog.csdn.net/xport/


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-02-28 9:49 

注册: 2006-10-18 15:48
帖子: 700
送出感谢: 0 次
接收感谢: 0 次
我自己也奇怪
怎么会这样呢哈哈

xport 写道:
gtx 写道:
在interfaces里加上:
auto lo
iface lo inet loopback


这个...楼主在配置网络的时候为什么会没有这段的设定呢? :roll:


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-05-22 16:37 

注册: 2005-05-31 19:32
帖子: 156
送出感谢: 0 次
接收感谢: 0 次
我这里设定了
auto lo
iface lo inet loopback
也ping不通localhost, 怎么回事?


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-05-22 17:17 

注册: 2006-09-09 0:35
帖子: 349
送出感谢: 3
接收感谢: 0 次
嗯?为什么我直接用刚装好到hiweed1.o就可以ping localhost通过呢?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译