如何安装libgtk2.0-dev

Ubuntu中文汉化版
回复
mayirong
帖子: 8
注册时间: 2007-02-21 10:14
送出感谢: 0
接收感谢: 0

如何安装libgtk2.0-dev

#1

帖子 mayirong » 2007-03-11 23:15

安装时的信息如下:
//////////////////////////////////////////////////////////////////////////////////////////////////////
ma@ma-desktop:~$ sudo apt-get install libgtk2.0-dev 正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libgtk2.0-dev: 依赖: libxcursor-dev 但是它将不会被安装
依赖: libxfixes-dev 但是它将不会被安装
E: 无法安装的软件包
//////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
ma@ma-desktop:~$ sudo apt-get install libxfixes-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libxfixes-dev: 依赖: libxfixes3 (= 1:3.0.1.2-0ubuntu3) 但是 1:4.0-0ubuntu1 正 要被安装
E: 无法安装的软件包
////////////////////////////////////////////////////////////////////////////////////////////////////////////////
ma@ma-desktop:~$ sudo apt-get install libxcursor-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libxcursor-dev: 依赖: libxfixes-dev 但是它将不会被安装
E: 无法安装的软件包
我的破机:FIC-AN11(KT266A) DDR:256M SIS6326
头像
huangjiahua
帖子: 3294
注册时间: 2005-03-30 0:27
送出感谢: 0
接收感谢: 1 次
联系:

#2

帖子 huangjiahua » 2007-03-12 0:15

代码: 全选

sudo apt-get install -f
跃过无数的时间断层,只为了在
回复

回到 “Ubuntu中文衍生版”