求教:编译时 Can't find X includes

Ubuntu中文汉化版
sunzhaoyu2000
帖子: 700
注册时间: 2006-10-18 15:48
送出感谢: 0
接收感谢: 0

求教:编译时 Can't find X includes

#1

帖子 sunzhaoyu2000 » 2007-03-16 20:15

checking for X... configure: error: Can't find X includes. Please check your installation and add the correct paths!



这个是要装什么库先?
头像
huangjiahua
帖子: 3294
注册时间: 2005-03-30 0:27
送出感谢: 0
接收感谢: 1 次
联系:

#2

帖子 huangjiahua » 2007-03-16 21:27

你先说你要编译什么先。
跃过无数的时间断层,只为了在
sunzhaoyu2000
帖子: 700
注册时间: 2006-10-18 15:48
送出感谢: 0
接收感谢: 0

x的问题搞定了,问题又出在qt上

#3

帖子 sunzhaoyu2000 » 2007-03-17 12:17

我主要是想装一个科学绘图软件
本来一直用matlab绘图但是前天出问题了
不能在图形界面修改图形的x轴名称以及给图表命名等操作
一点就自动退出

gnuplot会用
但是全命令行有点繁琐

我在网上找到一些相关软件

昨天编译报的错我瞎装了一下带x字样的库好像就搞定了
然后我今天把那些软件再编译
出了另外的错误


首先是LabPlot-1.6.0.pre2
./configure时出现
... ... ...
checking for Qt... configure: error: Qt (>= Qt 3.1 (20021021)) (headers and libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.

我就试着装libavahi-qt3-dev:但是依赖关系出错:
依赖: libavahi-qt3-1 (=0.6.10-0ubuntu3.4) 但是将会安装 0.6.10-0ubuntu3.3
依赖: libqt3-mt-dev 但是此软件包将不会被安装




然后我放弃转而装kmatplot-0.4
./configure的时候再次
configure: warning: libjpeg not found. disable JPEG support.
checking for Qt... configure: error: Qt (>= Qt 2.2.2) (headers and libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.



然后我再安装grace 和 octave成功
不过他们应该是图形界面的
我一用
还是命令行的呀
尤其是octave,有人说它实现了matlab的大多数功能,好像也不是



我就是想找一个这样的软件
它可以用一个简单的命令把一组数据绘出一个图形
而图形的各种特性比如轴的位置,点的形状,虚线实线,等等,可以像matlab那样用鼠标设置。









huangjiahua 写了:你先说你要编译什么先。
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#4

帖子 zhuqin_83 » 2007-03-17 12:21

把~/.matlab备份一下,然后删掉,看看好了没有。
不然就重装一次matlab.
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
sunzhaoyu2000
帖子: 700
注册时间: 2006-10-18 15:48
送出感谢: 0
接收感谢: 0

重装无效

#5

帖子 sunzhaoyu2000 » 2007-03-17 12:51

我试过了
我安装在/opt/matlab
我把/opt/matlab 和 ~/.matlab全删除了再重新装
仍然这样的错误


以前我试过各种版本的matlab4linux
很多都是装了不能作图但是可以干数组操作
后来在hiweed0.6上也装好过一次
用了不久又挂了

现在又这样挂掉了

不知道是不是我自己的人品问题嘻嘻



zhuqin_83 写了:把~/.matlab备份一下,然后删掉,看看好了没有。
不然就重装一次matlab.
sunzhaoyu2000
帖子: 700
注册时间: 2006-10-18 15:48
送出感谢: 0
接收感谢: 0

发现源里原来有scilab,装了却因字体有问题无法启动

#6

帖子 sunzhaoyu2000 » 2007-03-17 12:55

sun@young:~$ scilab
(zterm:16106): ZVT-WARNING **: Cannot get required fonts from "monospace 13"

(zterm:16106): ZVT-WARNING **: Use "-*-*-*-*-*-*-13-*-*-*-*-*-*-*" XLFD fontname - some characters may not appear correctly


(zterm:16106): ZVT-WARNING **: Use "-*-*-*-*-*-*-0-*-*-*-*-*-*-*" XLFD fontname - some characters may not appear correctly


(zterm:16106): ZVT-CRITICAL **: file zvti18n.c: line 812 (zvt_term_get_xfontset) : assertion `new_fontset != NULL' failed

(zterm:16106): ZVT-WARNING **: Failed to load any required font, so crash will o ccur..check X11 font pathes and etc/pangox.alias file


(zterm:16106): ZVT-WARNING **: Cannot get required fonts from "monospace 13"

(zterm:16106): ZVT-WARNING **: Use "-*-*-*-*-*-*-13-*-*-*-*-*-*-*" XLFD fontname - some characters may not appear correctly


(zterm:16106): ZVT-WARNING **: Use "-*-*-*-*-*-*-0-*-*-*-*-*-*-*" XLFD fontname - some characters may not appear correctly


(zterm:16106): ZVT-CRITICAL **: file zvti18n.c: line 812 (zvt_term_get_xfontset) : assertion `new_fontset != NULL' failed

(zterm:16106): ZVT-WARNING **: Failed to load any required font, so crash will o ccur..check X11 font pathes and etc/pangox.alias file




我以前在baidu上找文章对字体进行了美化
不想显示opera里的open file看见汉子变成方块了
现在干脆scilab不启动了
不知道怎么解决?
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#7

帖子 zhuqin_83 » 2007-03-17 13:01

你装的什么版本的matlab?java有没有设置过?
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
sunzhaoyu2000
帖子: 700
注册时间: 2006-10-18 15:48
送出感谢: 0
接收感谢: 0

java?

#8

帖子 sunzhaoyu2000 » 2007-03-17 13:40

java我就不懂了
但是我的lumaqq可以运行得很好
应该说明java是好的吧?

我的matlab是Mathworks.Matlab.R2006b.UNIX.ISO-TBE
以前也用过其它版本呀
不知道有没有什么问题?

你的matlab运行很正常么?什么版本?
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#9

帖子 zhuqin_83 » 2007-03-17 13:47

和你一样的版本,但是我把java设置为使用系统的,也就是添加了export MATLAB_JAVA=xxxx
matlab自带的版本低,而且有问题。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
sunzhaoyu2000
帖子: 700
注册时间: 2006-10-18 15:48
送出感谢: 0
接收感谢: 0

这样呀,详细怎么设置路径呢?

#10

帖子 sunzhaoyu2000 » 2007-03-17 13:52

是说在.bashrc中export MATLAB_JAVA=/usr/lib/jvm/java-1.5.0-sun-1.5.0.06这个吗?

详细一点撒
sunzhaoyu2000
帖子: 700
注册时间: 2006-10-18 15:48
送出感谢: 0
接收感谢: 0

万分感谢zhuqin_83,已经搞定

#11

帖子 sunzhaoyu2000 » 2007-03-17 14:03

我看了一下自己的.bashrc
发现它是:
JAVA_HOME=/opt/jre1.5.0
PATH=$JAVA_HOME/bin:$PATH
export JAVA_HOME PATH

后来我按照zhuqin_83的提议
把java的路径指向ubuntu系统自带的jre
即在.bashrc中添加:
export MATLAB_JAVA=/usr/lib/jvm/java-1.5.0-sun-1.5.0.06/jre

之后就没有问题了


也不想去细想为什么一直好好的忽然出问题了
总之解决了哈哈
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#12

帖子 zhuqin_83 » 2007-03-17 14:06

一直到jre。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
sunzhaoyu2000
帖子: 700
注册时间: 2006-10-18 15:48
送出感谢: 0
接收感谢: 0

不过编译软件出错的问题还是希望huahua帮忙看看

#13

帖子 sunzhaoyu2000 » 2007-03-17 14:07

关于qt库的错误还是希望huahua看看

还有上面提到的系统字体设置被修改之后打不开scilab的问题 :lol:
sunzhaoyu2000
帖子: 700
注册时间: 2006-10-18 15:48
送出感谢: 0
接收感谢: 0

to zhuqin_83:

#14

帖子 sunzhaoyu2000 » 2007-03-17 14:22

可不可以在桌面设置一个matlab的图表?
我发现只有在终端输入matlab才可以启动它,很奇怪

我添加到面板时也必须点上“在终端中运行”才跑得起来
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#15

帖子 zhuqin_83 » 2007-03-17 14:45

可以的,但是命令必须是 matlab -desktop,否则一定起不来。
图标在$matlab73/X11/icons/
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
回复

回到 “Ubuntu中文衍生版”