如何修复apt依赖损坏

Ubuntu中文汉化版
回复
wangping
帖子: 89
注册时间: 2007-01-08 19:22
送出感谢: 0
接收感谢: 0

如何修复apt依赖损坏

#1

帖子 wangping » 2007-06-24 10:19

强制安装了一个kile,主要是我已经用了texlive 了,不想用tetex。
可是现在apt非得让我装tetex不可。因为feisty下的kile错误的关联了tetex。查了一下gusty好像解决了。
可是现在怎么修复apt?
我实在不想装tetex。
不爽,现在不能装其他软件了。老是提示我装tetex!

清大家教我!
谢谢
头像
zmcbb30
帖子: 2717
注册时间: 2006-09-30 0:32
来自: 巴拉特星系第四行星──海尼森
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 zmcbb30 » 2007-06-24 10:43

那个可能是必要关联

可以考虑自己编译
头可断,血可流,靓女不可不追求
相艾唔好口,够姜就只抽

BARTON 2500+/1536MDDR400
EP8RDA3G/MX4000 128M64bit 8X
DiamondPlus9-6Y080L0-ATA133
Samsung743DF
HiweedDesktop-1.0
头像
huangjiahua
帖子: 3294
注册时间: 2005-03-30 0:27
送出感谢: 0
接收感谢: 1 次
联系:

#3

帖子 huangjiahua » 2007-06-24 11:46

kile 依赖的是 tetex-bin | texlive-base-bin , 是两者之一呀。

楼主不是 apt 装的 texlive ?
那么就装个假的 tetex-bin 吧,见附件
附件
tetex-bin_4.0-fake1_all.deb
假的 tetex-bin 包
(620 Bytes) 下载 44 次
跃过无数的时间断层,只为了在
wangping
帖子: 89
注册时间: 2007-01-08 19:22
送出感谢: 0
接收感谢: 0

#4

帖子 wangping » 2007-06-24 12:20

我用的是texlive2005.iso,中文化已经做好的.
谢谢,总算等到高人了 :lol:
头像
huangjiahua
帖子: 3294
注册时间: 2005-03-30 0:27
送出感谢: 0
接收感谢: 1 次
联系:

#5

帖子 huangjiahua » 2007-06-24 14:38

补充下, 这并不是错误,
kile 依赖的是 tetex-bin | texlive-base-bin , 是两者之一,这个依赖是没问题的
但是楼主用的是 iso , iso 并不会向 deb 系统注册。
跃过无数的时间断层,只为了在
回复

回到 “Ubuntu中文衍生版”