新人提问:libxfixes-dev装不上如何解决?

Ubuntu中文汉化版
回复
jova
帖子: 230
注册时间: 2007-11-16 15:24
送出感谢: 1 次
接收感谢: 0

新人提问:libxfixes-dev装不上如何解决?

#1

帖子 jova » 2007-12-08 13:39

在安装lazarus时,需要安装free pascal,在安装libgtk2.o-dev的时候,出现以下提示:

正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libgtk2.0-dev: 依赖: libxcursor-dev 但是它将不会被安装
依赖: libxfixes-dev 但是它将不会被安装
E: 无法安装的软件包

而后安装libxfixes-dev,又出现以下提示:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libxfixes-dev: 依赖: libxfixes3 (= 1:3.0.1.2-0ubuntu3) 但是 1:4.0-0ubuntu1 正 要被安装
E: 无法安装的软件包

请问如何解决这个问题。
回复

回到 “Ubuntu中文衍生版”